Adguard Home incompatible with Ios 15.4

I recently started using Adguard home on my RPI4b, after I change the dns port of dnsmasq to any value and give port 53 to AGH, all ios devices stop working. Android and windows devices still work fine, ios devices only work when dnsmasq has custody of port 53! Can someone explain to me what is happening and help.
Thank you.

Can you provide more information regarding the relevant configurations you made?

1 Like

Just moved dnsmasq to 5353 and then to 1702 port, in both cases ios devices show no internet.
Only connect when port 53 is given to dnsmasq and then AGH is used a upstream of dnsmasq.

DNS port is 53, nothing should work if it's moved.

Android devices could use DoH or DoT instead, same goes for Win, depending on how you do your tests.

1 Like

I directly use doh on Adguard home so it works systemwide for Android and Windows. What I usually do is allot port 53 to AGH, but ios doesn't work with that config.

Also can you guys help me with 1 more thing, I need to use a custom doh server on openwrt but in the http dns proxy app only presaved configs are shown!

That's used by dnsmasq by default, or have you stopped it?

I generally used to change dnsmasq port to 5353.

And have you generally already done it?

Yes, have been using that config for months but now got new ios devices and started facing problems.
I am really sorry for not being able to convey my problem appropriately.

What if you disable all adblocking, so agh becomes transparent?

To see if the issue's with a blocked canary domain, or something else.

Yes have tried this but doesn't work.

The other members already asked you to post some configuration files to have a better understanding.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; \
netstat -lnp

Also the relevant configuration of adguard.

Hey, have you ever fixed this problem?

Yes it was able to solve it, by adding the settings below.
Network -> Interfaces -> lan -> DHCP Server -> Advanced Settings -> DHCP-Options (add 3, and 6, here) Replace with your router IP.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.