AdGuard Home + DDNS error

Hi, in an effort to block as much advertising as possible, even on YT (hopefully at least within the videos) I am trying to use AdGuard Home instead Simple AdBlock

However, I realized that once installed, the DDNS service is no longer able to retrieve my external IP in any way.

I tried reading further in the OpenWrt installation page where it explains how to install AdGuard Home, but I can't find anything about DDNS

The DDNS log shows

;; communications error to 127.0.0.1#53: connection refused

and the SysLog says

Sat Sep 10 15:37:15 2022 user.err ddns-scripts[24140]: dynv6: BIND host error: '1'
Sat Sep 10 15:37:15 2022 user.warn ddns-scripts[24140]: dynv6: Get registered/public IP for '***.dynv6.net' failed - retry 1/0 in 60 seconds

Has this happened to anyone before?
Do you have any idea what I can do?

J

I would guess the adblocker blocks the site, the script is using for this ddns, or for checking its own public IP, or both, if not the same.

Yeah I feel the same, the port 53 make me suspicious.
Do you know where the DDNS scripts are stored?