Adding Zerotier to TelcOS

I have a Telco Antennas X1 Pro running TelcOS at the moment (says it's OpenWrt based). Upgraded to latest TelcOS firmware which says it's based on OpenWrt 22.03. Tried to add the ZeroTier package to this using SSH and opkg update. Then using opkg list, Zerotier doesn't show up although there is a compatible version available. Checked dependencies. Four installed, three missing. Tried to install the missing dependencies, but they don't show up in the available packages either, although THEIR dependencies are installed. What is wrong? Has the vendor disabled installing extra packages? How can I check? Can I fix this? Is the only way to dump TelcOS and flash with OpenWrt?


maybe, but not recommended path is to download missing packages from openwrt repo, then upload via scp to /tmp and from there install using opkg

and maybe you will success or you will be in big trouble :slight_smile:

if you're not using official openwrt, but some derivative, those questions should be directed to the provider of the device / image.

whatever advice you receive here, might brick your router.

1 Like

@frollic - yes, I realise this. There is a factory reset procedure which I have tested which I am hoping will get me out of trouble. I have tried to contact the provider, but they are a small company and the original author of the OS has left. Those who are left suggest that I can try this, but they cannot give me any help because they have never tried to do anything like that.

Thank you @NPeca75 - yes, I will try this.

@NPeca, should I download to /tmp (which has lots of files) or /tmp/tmp (which is empty) ?

same file system, no ?

Yes, it's the same file system.

plain /tmp

then it doesn't matter.

If the download creates its own subdirectory, then I agree, it probably doesn't matter and maybe plain /tmp is better.

Do I have to change the feed location then when trying to install from /tmp? How do I do that? I think I read something on the wiki about that.

opkg install file.ipk

1 Like

While sitting in the same directory? That makes sense. Worth a try.


feeds are relevant when your device downloading packages from internet, so it should know where to look for packages

but when you using local file system opkg will install from there

1 Like

Thanks. I think I understand now.

One more question: One of the dependencies is "ip" which says it is a "metapackage that will offload on whatever ip provider you have chosen" How do I install that or what do I do about that?

i think , but maybe i am wrong, this refer to ip-tiny or ip-full package, which should be already installed anyway


Yes, that makes sense. I have enough information now.
Okay - here we go!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.