Adding support for Zbtlink WE5126

Please add support for this device
The device already comes with custom openwrt firmware but it is outdated and there is no image builder (this is the most necessary)
The archive contains various logs and configuration files.I can try to extract other additional data from the router.

I continued experimenting with my router. I tried to find a similar target, built a firmware for mediatek_mt7628an-eval-board and flashed it into the router. Тhe router did not become a brick, It works now

  1. ethernet
  2. WiFi 2.4 GHz bgn
  3. USB maybe work, lsub shows the devices list
    I installed the kmod-mt76x2 package but the 5GHz wifi doesn't work. Also could not get the data from the SD card ..
    again in the archive different logs ...

What is the probability that sooner or later the support of my router will be added to the openwrt? It is very necessary, thank you ...
PS I tried using the build system to build a firmware with the support of PCI-e and mmc/sd... nothing works, apparently the kernel lacks drivers or I don't know what exactly to turn on

I used force source :slight_smile:
І downloaded the building system and searched where and how to turn on the pci bus ... and i found and turned on.
the patch is very simple

diff --git a/target/linux/ramips/dts/mt7628an.dtsi b/target/linux/ramips/dts/mt7628an.dtsi
index aa46de7134..9374f285fc 100644
--- a/target/linux/ramips/dts/mt7628an.dtsi
+++ b/target/linux/ramips/dts/mt7628an.dtsi
@@ -462,7 +462,7 @@
 		clocks = <&clkctrl 26 &clkctrl 27>;
 		clock-names = "pcie0", "pcie1";
-		status = "disabled";
+		status = "okay";
 		device_type = "pci";

and that's what happened, the mt7612e chip was found and started working, I'm actually writing this message by connecting through it.
more data

root@OpenWrt:~# lspci -k
00:00.0 PCI bridge: MEDIATEK Corp. Device 0801 (rev 01)
lspci: Unable to load libkmod resources: error -12
01:00.0 Network controller: MEDIATEK Corp. MT7662E 802.11ac PCI Express Wireless Network Adapter
        Subsystem: MEDIATEK Corp. MT7662E 802.11ac PCI Express Wireless Network Adapter
        Kernel driver in use: mt76x2e

the kernel log is here:
But there is one problem: this chip works at a very low power - 1 dBm (1mW), the router is at a distance of 3m from me and the wifi signal is a little more than zero, although it works stably, I can watch videos from YouTube, the speed is enough.

1 Like

search helps, i found this

now my patch looks like this

diff --git a/target/linux/ramips/dts/mt7628an.dtsi b/target/linux/ramips/dts/mt7628an.dtsi
index aa46de7134..9e07ff54f4 100644
--- a/target/linux/ramips/dts/mt7628an.dtsi
+++ b/target/linux/ramips/dts/mt7628an.dtsi
@@ -462,7 +462,7 @@
 		clocks = <&clkctrl 26 &clkctrl 27>;
 		clock-names = "pcie0", "pcie1";
-		status = "disabled";
+		status = "okay";
 		device_type = "pci";
diff --git a/target/linux/ramips/dts/mt7628an_mediatek_mt7628an-eval-board.dts b/target/linux/ramips/dts/mt7628an_mediatek_mt7628an-eval-board.dts
index 5418dac886..cd49c80ce3 100644
--- a/target/linux/ramips/dts/mt7628an_mediatek_mt7628an-eval-board.dts
+++ b/target/linux/ramips/dts/mt7628an_mediatek_mt7628an-eval-board.dts
@@ -56,6 +56,14 @@
+&pcie0 {
+	wifi@0,0 {
+		reg = <0x0000 0 0 0 0>;
+		mediatek,mtd-eeprom = <&factory 0x8000>;
+		ieee80211-freq-limit = <5000000 6000000>;
+	};
 &wmac {
 	status = "okay";

wifi power is 18 dBm (63 mW) Is it possible to raise the power even more, at least to 100mW?

Another study: I have a router tp-link archer c50, a cousin of this WE5126 - the same wifi chip at 5GHz only SoC in this mt7620. I replaced data in the factory partition WE5126 on data in the radio partition from archer and was able to set the radio power to 22dBm (158mW). But the MAC address has changed. I think that the amount of power is hidden somewhere in the factoryif I find this byte partition, I need to find this byte and change it in the factory partition (I saved the backup beforehand) ....
PS I'm talking to myself

1 Like

Well, I'll join in! :wink:

I would highly recommend you submit your patches to the OpenWrt repo. Not only it would be useful for others with similar devices (even if the PR is ultimately rejected), you may very well get some advice on issues you're facing.

Slightly dealt with the eeprom data of chip mt7612e, i found where MAC address is written.
I thought there must be a utility to configure these chips .....

I will extend the topic a bit. Reading this file was very useful, I figured out which bytes to fix in eeprom for mt7612e and now it works stably for me at a power of 22 dBm (158mW).

i have similar model to we5126, its we2426-c (also known as we4626-bkc).
Im dont have knowledge to apply patches.
maybe do you have a ready firmware?

i will be very grateful for help.

I can't find this router (WE2426) on the manufacturer's website ( It will be difficult for me to help you.

I dont need to assemble new firmware.
Looks like the WE5126 is redesigned version WE2426/4626 (only form of box changed, its still the same MT7628/7612).
So i want to reflash it with your firmware of WE5126.
Its dont brick im sure. I`ll be very grateful)

could you share your firmware?

all here

Aquaforum, Link is broken, can you provide a new link please?

it is very old, I do not recommend using it now

ok, the patch you posted in this thread, is up to date? did you made any more progress? I got a we5126 here and want to experiment with.

I haven't checked for a long time. The router is now in the box, the need for it has disappeared. Of the latest issues I've found with modified eeprom for mp7612e wifi 5GHz working unstable and often shuts down. With the original eeprom - works stably but low power.