Adding support for WAN device on Asus GT-AC5300

I have successfully installed OpenWrt 23.05.2 on an Asus GT-AC5300 however no WAN device was setup as part of the standard install. Four LAN ports are also missing but I don't care about that issue.

Given the powerful specs I was hoping to turn this machine into my primary router coupled with some APs for Wifi coverage. Not having a WAN device with OpenWrt is in the way of that goal.

In an attempt to create a workaround I removed one of the four usable LAN ports from the standard lan bridge and setup a new bridge device connecting the eth0 device and lan6 device and then created two WAN interfaces (wan and wan6) to use the new bridge device. I plugged the internet cable on lan6 port. That allowed me to access the internet but speeds are about 1/3 of what I should be getting.

What does it take to add support for the WAN device on this router?

For reference, here's what network config looks like:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd35:837d:e2d0::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan5'
	list ports 'sw'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.XXX.X'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option type 'bridge'
	option name 'br_eth'
	list ports 'eth0'
	list ports 'lan6'
	option bridge_empty '1'
	option macaddr 'XX:XX:XX:XX:XX:XX'
	option promisc '0'

config interface 'wan'
	option proto 'dhcp'
	option device 'br_eth'

config interface 'wan6'
	option proto 'dhcpv6'
	option device 'br_eth'
	option reqaddress 'try'
	option reqprefix 'auto'

You, and X amount of free time.

bcm4908 support is very 'fresh' at best - and support for Broadcom based devices gets rather little attention to begin with.

These are helpful pointers to get started. Thank you!

Understood, I realized what I was getting myself into given the thin documentation on this model out there. The wiki page and many other posts in this forum focused on the lack of wireless support (which I don't care about) but never called out the lack of support for wan. That misled me down this path of trying to use it as a full router. It's a shame I won't be able to put this hand me down unit to better use than collecting dust.