Adding support for VRX518 (and maybe VRX320)

After some further testing by @mm933, it turned out that the issue is actually reproducible on vendor firmware with the magic disabled in the device tree. The dc_ep_clk_on failed error was just no longer present in the dmesg output in the support data, because there were too many other kernel messages.

I also found out why my adaptation of the magic hack for OpenWrt didn't work. The upstream DesignWare PCIe driver code includes auto detection of the number of ATU regions. This involves overwriting some ATU registers, and happens after the host_init function of the Qualcomm PCIe driver is called. As a result, the programmed ATU entry wasn't actually active.

I fixed that, and it seems to work now. I also did some additional cleanup and sent the patch to the mailing list.

Mailing list:

@varda, @jaghatei, or anyone else who encountered the dc_ep_clk_on failed error: This patch should really fix the issue. If you tested it successfully, consider sending your Tested-by to the mailing list.


Hi, i managed to upload the first builds and firmware to my Fritzbox 7530 MA and got a DSL link.

But when I updated to the official build 7530 openwrt-22.03.3-ipq40xx-generic-avm_fritzbox-7530-squashfs-sysupgrade.bin and adding the firmware files as stated in the wiki, I don't have any VDSL menu items nor device in the Lucy webfrontend.

Is there anything I can check what the problem is? Syslog and Kernel log don't reveal anything missed :thinking:

22.03.3 does not contain the patches yet. You'll have to stick to SNAPSHOT for now.

I wrote "The integrated VRX518 DSL modem is only supported in releases later than 22.03 and snapshot [...]".
Do you think I should add "(i.e. 23.x)"? Since 22.03.03 might be considered later than 22.03. Or should I phrase "22.03.x" to make it clear?

1 Like

for myself, i also thought the latest release 22.03.3 should work, i would write ie. 23.x.

Also i would thank you all for your efforts to bring a cheap all-in-one device for vdsl back into openwrt. I used vr200v for some time and was never happy. DSL was also good but wifi only worked on 5ghz and it didn't go well. There are so many issues in mt76 firmware with this device: you have to guess eeprom values for better wifi range and even with patches wifi was very bad in multi-user situations.
I enjoyed to just copy my old router config. Since both targets use dsa now this worked quite well.
Now a 30€ Fritzbox 5720 is running openwrt latest master and wifi is great (as expected from qualcomm). DSL sync is much faster (not the data rate, just the time to dsl init sync) than with old lantiq and seems to be stable in 24h.

Big thumbs up!


Yeah sorry it was my misunderstanding, but maybe the clarification will also help others :wink:

Device seems to be stable and very smooth, Thank you all for this great job! :heart_eyes:

1 Like

@dhewg, can you please reupload the old vr11 branch that you recently deleted on github so I can make my own build based on older stuff from like end of Dec. 22. That's when everything worked perfectly for me. Nothing new seems to work anymore as the "Unidentified network" always shows up on fresh installs, even on 22.03 stable builds. Only 19.x stable builds work now.

Maybe you can label it as "vr11 old" in github or provide it elsewhere so people don't mix it up. Thanks!

As far as I can tell it works for everybody else.

The vr11fw branch is still there, the pre-merged stuff is gone for good, but you can rebase the relevant commits onto whatever you want. But I don't see that fixing anything.

I'm pretty sure that I have a local copy, but I can't check before the weekend.

What do you mean with "Unidentified network"?

one question about building for the ipq40xx target
it seems the patch I linked to earlier in this thread that boosted cpu clock speeds has been scrubbed off other people's trees
is there a particular reason why the higher clocking of 896000 got removed from those trees ? I've left the patch in my builds because i've never seen the device crash yet but I figure there must be a reason why it seems to have gone bye bye

I wonder how wise it is to overclock cpus without making sure that the heat removal system is up to the task. As far as I understand running at increased temperature does not necessarily lead to crashes but might lead to a shortened device life time, but my understanding is quite superficial....

1 Like

Does the 7520 flashed with OpenWrt master with included firmware files support vdsl up to super vectoring now? profile 35b (250/40 speeds)
I couldn't find any clear answer, yet. ^^

No, because there are no included firmware files. All firmware files need to be installed separately, after installing OpenWrt. The instructions are on the Wiki page.

I know, I want to know, if vdsl supervectoring works with those firmwarefiles or only adsl or vdsl 50/10.

I can not answer for profile 35b (aka "supervectoring in Germany), but the linked files allow 100/40 (syncing currently at 116.7/37 Mbps) with bi-directional vectoring and G.INP. That does not answer your original question, but shows that VDSL2 >> 50/10 does work "out of he box" (I put the firmware files into the "files" folder and built my own snapshot so the firmware files are part of my installation image).

1 Like

Yes, profile 35b works.

1 Like

Hi @andyboeh , I posted a few posts up in detail what the problem was. Any fresh install of snapshot or stable 22.03.x or even 21.x doesn't work as the PC doesn't identify the network (Ethernet adapter on PC says "Unidentified network") and so I can't SSH via Putty into the router at all. And of course I can't access Luci. I also tried different PCs, same problem. Some 22.03.x (I think 22.03.1) worked at first after the new vr11fw was launched, but now nothing works besides the 19.x stable builds.

I would appreciate it if you can upload the old vr11 somewhere when you have time. No worries and thank you :slight_smile:

This has been asked and mentioned before, but: when flashing a new make sure that you do not keep settings as the network config structure has changed.

Does failsafe mode work with a new snapshot?

For a workaround, before you flash the new firmware, set up a usb network adapter and put it in your lan and then after flashing if you can't access the device try the usb adapter though I guess this is only useful if there's support for the adapter already.

What do you mean by do not keep the settings?

I don't really know how to get into the failsafe mode on the Fritz 7520, it doesn't even have a reset button and by pressing all other buttons on startup, nothing happens.