Adding support for VRX518 (and maybe VRX320)

Will look out for a cheap one, thanks. Since I have a working solution, I can just wait....

Hi, after sucessfully flashing your build to my fritzbox 7530, I would love to get some details on how I can extract the firmware (if still possible with OpenWRT flashed to the box?). Could you please point me some notes what to place where?

(BTW would happyly support the development by sharing logs or donation, to help to get this fixes upstream)

basically download 7530 firmware from here


copy/move the file into an empty directory
and then unzip it
7z e
then unzip that
7z e FRITZ.Box_7530-07.39-101552-Labor.image
then unzip that
7z e filesystem.image
choose "Always" press A

then scp -O vr11-B-dsl.bin root@
or copy vr11-B-dsl.bin to a usb drive and then mount it and copy it to /lib/firmware

then in the web config network-> interfaces->dsl set the dsl firmware file to : /lib/firmware/vr11-B-dsl.bin

if for some reason you need the annex A file instead you can generate it with:
bspatch vr11-B-dsl.bin vr11-A-dsl.bin vr11-A-dsl.bin.bsdiff
and then the file to copy over will be: vr11-A-dsl.bin

As far as I know everything is working great the only drawback at the moment is you can't restart the dsl_control service, if you do the dsl can get stuck and never sync up. I am thinking of putting watchcat in and setting up some condition so if the link ever goes down for more than 30 minutes to reboot the router just to be sure it never gets stuck in that never work state.


I'm new to OpenWRT. How would I be able to create the .bin file for the VRX518 Fritz 7520 from your branch? Through the Image Builder? And then flash it to the router with the normal official steps?

What .bin file would that create if taken from your branch? The sysupgrade.bin and not the initramfs.bin, right?

Thanks to all!

I posted the steps a while ago: Adding support for VRX518 (and maybe VRX320) - #271 by andyboeh

This uses dhewg's branch, you need to replace the URL.

It creates whatever use select, the default is both, initramfs and sysupgrade.

1 Like

2 posts were merged into an existing topic: Setting up FRITZ 7520 unofficial version with DSL

Hi, I started to use your image instead of the one I built prior.
But now I habe some problems with additional packats I would like to install.
Seems they Install fine, and teh executeabkes are also seen in e.g. /usr/sbin/... but they fail to start.
I always get file not found. But the files are definitly there and als executeable.
Any idea why this is not working in this case? Searching a bit the net, maybe it is a wrong architecture,...

Any idea why binarys of packages istalled via opkg are not working , and how to install packs?


I don't know when the mentioned image was updated the last time, but since the vrx518 patches target the master branch, the image might be incompatible with current packages installed via opkg.
For development releases it's usually the best approach to include all packages you want in the image. The opkg packages are always targeting the latest master branch, so if there are changes to something like musl, newly installed packages might be binary incompatible.

1 Like

Thanks. I used the one from this post, as I first thought it includes everything I need.

Is thefe no way to install packages later? I am sure even if I build it now myself with all needed, one mo th later again I need some small package.


As I said: When your image is a development build (from master branch) you can try to install packages via opkg, but if that fails you have to re-build your image.

A quick and dirty howto on building the latest master with the patches applied

  1. Add remote for the patches:
git remote add dhewg
  1. create a new branch:
git switch -c vr11
  1. Use the branch with the patches and rebase on latest master:
git fetch
git reset --hard dhewg/vr11
git rebase origin/master

Repeat the last 3 commands every time before you build a new image. If the last command fails, wait for the devs to rebase the patches in dhewg/vr11 manually (and run git rebase --abort).


To be honest, I was happy to be able to build it, and I don't have any knwledge about git and the build process.

I tried this now, so created the build environment, cloned
cloned master
chainged to the folder and tryed your commands.

But git reset.... fails here.

A guid for dummys would be nice. I know networking, and how to use openwrt, but building is ot one of my favorite.
At the moment I dont need much, just Luci, Wireguard,... but I am sure I need to add some packages later.
As this router is also installed a bit remote it would be nice to be able to use opkg to add some small packages later.

Okay, maybe I got it, here the steps I have done. Make is running, and I am not sure if correct. :grinning:
Please correct if I did something wrong.

create build env

sudo apt-get install unzip
sudo apt-get install build-essential subversion libncurses5-dev zlib1g-dev
sudo apt-get install gawk gcc-multilib flex git-core gettext libssl-dev

create a working folder

sudo mkdir /openwrtbuilddir
sudo chown myuser /openwrtbuilddir
sudo chmod 755 /openwrtbuilddir

clone master

cd /openwrtbuilddir
git clone
cd openwrt

add remote for the patches
git remote add dhewg

create a new branch
git switch -c vr11

use the branch with the patches and rebase on latest master

git fetch dhewg
git reset --hard dhewg/vr11
git rebase origin/master

update the feeds

./scripts/feeds update -a
./scripts/feeds install -a

config the build

make menuconfig
#target system Qualcomm Atheros IPQ40XX
#target profile: AVM FRITZ!Box 7520 (AVM FRITZ!Box 7530)


Build failed. :expressionless:

Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency cgi-io for luci-base
 * pkg_hash_fetch_best_installation_candidate: Packages for luci-base found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency attendedsysupgrade-common for luci-app-attendedsysupgrade
 * pkg_hash_check_unresolved: cannot find dependency cgi-io for luci-app-attendedsysupgrade
 * pkg_hash_fetch_best_installation_candidate: Packages for luci-app-attendedsysupgrade found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci:
 *      cgi-io
 *      attendedsysupgrade-common
 *      cgi-io
 * opkg_install_cmd: Cannot install package luci.
 * pkg_hash_check_unresolved: cannot find dependency openconnect for luci-proto-openconnect
 * pkg_hash_fetch_best_installation_candidate: Packages for luci-proto-openconnect found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package luci-proto-openconnect.
make[2]: *** [package/Makefile:70: package/install] Error 255
make[2]: Leaving directory '/ow/openwrt'
make[1]: *** [package/Makefile:111: /ow/openwrt/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/stamp/.package_install] Error 2
make[1]: Leaving directory '/ow/openwrt'
make: *** [/ow/openwrt/include/ world] Error 2
1 Like

Could you share your older 7.21 flash tool? Dropbox or so is great.

I will soon flash my device which is also on 7.29.

The wiki for the 7530 shows a particular VLAN configuration. Is it mandatory to use those VLANS, or can you choose any?

When the 7530 runs the AVM firmware, it talks about changing LAN1 to the WAN port for when you (no longer run ADSL and instead) have like fibre to the home, and you connect LAN1 to the fibre convertor.

Does LAN1 require a special VLAN number in this case, or just any, and set up DHCP?

If you run the DSA-converted version, i.e. the one mentioned in this thread, then you can choose any. If you run the 22.03 version, the driver is very picky about the VLAN configuration. The Wiki shows a screenshot of a 22.03 version.

For the DSA-version, you can use any - the generic instructions on the Wiki apply.

1 Like

Hi all,
by the first, thank you all for the great work.
I'm trying to install the VR11 branch on my Fritzbox 7530 for use it as VDSL WAN router.
But it seems I'm missing something.
I compiled my build and downgraded my device to 07.21.
But I hang at the first step.
When I try to load the uboot on my Fritz, I dramatically fail.
I set on my NIC, ethernet cable connected, and when I start the device and launch the I only obtain a "No route to host".
I tried a continuous ping to and during the boot I never success. I start to successfully ping this address only when the device is fully started and at this point the eva_ramboot replies with "Connection refused".
I tried a connection with a switch to have the ethernet port immediately UP, but it's the same. I tried from my Debian OpenWRT Build VM, from my ArchLinux host OS and from a Windows guest VM (the same that I used for downgrading)... no luck!
I tried with ... no luck!
This issue is driving me crazy and I can't understand where I'm wrong.
Unfortunately, this router is my main access, so I had to rollback to the original FritzOS.
Did you have this problem? Can you help me?
Thank you.

Hi again, could somebofy help me here, or give me some hints if I did it correct or/and what was wrong?

I tried this now several times, with so.e small variations, but Ialways fail. :frowning:

Or can somebody maybe share a basic image (just with luci and wg added) that would support adding packaves via opkg?

Thank you.

On the other hand myactual setup is very stable. I use it in Austria with Fonira as ISP. Via macvlan configured to have both, static IP via PPPOE and also dynamic for normal surfing. So I am a bit less trackable via IP.


I've seen the IP address in EVA mode being set to something completely different on an older model, maybe it's the same for you?
You can easily check by running the AVM recovery tool, it prints the IP address of the box when it searches for it.

On which distribution are you trying to build?

Some packages can only be installed on the same day the image was built, some can't be installed at all (kmods) and others won't install after a longer period. That's why building it yourself is the safer option.

1 Like

@andyboeh I don't know what happened.

I successfully flashed the vr11 branch on my Fritz, using the network and without downgrading to 07.21 . I made a test using 07.29 and... wow... it worked!

I had to use the Windows VM. I didn't understand why with Linux systems I couldn't accomplish the feat ... I'm missing something I can't identify.

Actually I'm connected to VDSL WAN with an uptime of 20 hours. The link appears to be stable. I just have some errors, not a big problem, but I never had errors on my line. I'll monitor the increment rate.

Line State:Showtime with TC-Layer sync
Line Mode:G.993.2 (VDSL2, Profile 17a)
Line Uptime:20h 14m 8s
Data Rate:107.855 Mb/s / 21.600 Mb/s
Max. Attainable Data Rate (ATTNDR):108.422 Mb/s / 35.398 Mb/s
Latency:0.13 ms / 0.00 ms
Line Attenuation (LATN):3.5 dB / 2.2 dB
Signal Attenuation (SATN):3.5 dB / 2.2 dB
Noise Margin (SNR):6.3 dB / 12.6 dB
Aggregate Transmit Power (ACTATP):13.1 dB / -24.6 dB
Forward Error Correction Seconds (FECS):154 / 113422
Errored seconds (ES):0 / 42
Severely Errored Seconds (SES):0 / 0
Loss of Signal Seconds (LOSS):0 / 0
Unavailable Seconds (UAS):60 / 60
Header Error Code Errors (HEC):0 / 0
Non Pre-emptive CRC errors (CRC_P):138 / 0
Pre-emptive CRC errors (CRCP_P):0 / 0
ATU-C System Vendor ID:Broadcom 192.110
Power Management Mode:L0 - Synchronized

But now I've another question.

I see on the "Updates" tab that there are updates availble.

Do you think it's safe to update a custom build through the Luci interface?

Great community ... This is the real soul of FOSS.

Obviously I'm available for helping If I can do something.

Thank you all again!

1 Like