Adding support for VRX518 (and maybe VRX320)

I did a quick test with the 8D1917/8D0C12 firmware from Vigor 165 MDM2 and it works.

Another alternative is 8.13.1.12.1.7 from Speedport Pro / VMG3006. It works just as well as AVM's variants of 8.13.1.10.1.7 here (the reported SNR values are slightly higher, but that doesn't make any actual difference on my line, maybe that would be different on a line that runs closer the physical limit).

At some point, a firmware upgrade on a 3x90 model changed the IP address the boot loader would listen on. I noticed that while running the AVM recovery tool - can you rule this out?

One time I thought it worked when I used 1 instead of the 178 but I couldn't repeat this feat and told myself I must have imagined it!

Nice, thanks for that info, I'll give it a spin.

Here's a quick comparison:

8.13.1.10.1.7:

8.13.1.12.1.7:

Looks pretty similar... slight differences in the estimate of the "Max. Attainable Data Rate (ATTNDR)", but your link appears to be limited by the ISP's maximum profile in the downstream direction (assuming a physical German VDSL link operated bei deutsche Telekom, that limit is 116.800 Mbps) and likely by the ISP's DM system in upstream direction (36.999 indicates a hard sync limit at 37.000).

In my link ATTNDR actually fluctuates over the course of a day somewhat, but less than the 3 Mbps you see between the different firmware blobs. However ATTNDR is at best an estimate so it is not clear whether one could realize actually noticably higher sync with the 8.13.1.12.1.7 firmware...

@blogic
A question for you since you commited to various gitlab.com/prpl-foundation/intel repos:

For VRX518 support we require the following firmware files:

The first two don't have a license file at all. The last one has "Intel Confidential Information 10.24.2016"
Are you in a position to poke anyone to get these under something compatible for OpenWrt to use and ship?
I don't know if the latter is compatible, but IIRC the lantiq firmware for VR9 had a special/open license for that reason?

@ynezz
I've seen your name on some prpl issues, maybe you can help out?

Pushed a few cleanups and a firmware bump we were missing.

I also moved the drivers and firmwares to the lantiq folders. I think that makes sense, it groups the evolution nicely, and 'intel' in not really correct anymore anyway since maxlinear acquired it? Also 'intel/ltq-vdsl-vr11' was confusing already :slight_smile: Does that make sense?

1 Like

can someone help me i can build it with the master but how do i merge the vrx518 in the master branch to make it work with dsl im new to the the one i made has an outdatet kernel so i cant install some apps.

so its great work and working.

Maybe try my vr11 branch, you can use, merge, rebase or whatever:

1 Like

Let's hope this gets us anywhere:
https://jira.prplfoundation.org/browse/PCI-16

4 Likes

I Took your Branch and it worked thanks for the help

Receiving a AVM7360 next week. Are we close to a working solution? Would especially like to understand the process to get OpenWRT on it for the first time.

FB 7360 is vrx200 and full supported already

My fault, AVM 7530. :wink:

Found it already. https://openwrt.org/toh/avm/avm_fritz_box_7530

Just booted my AVM 7530 with a first (initram) image. One of the first observations is that the LAN port numbering seems to be reverse, i.e. what the GUI calls out as LAN4 is on de device itself in fact LAN1. Has this been observed before ?

Yeah, I have seen the same thing on the https://github.com/dhewg/openwrt/commits/vr11 branch. I am not sure if the official builds have the same problem (although I assume they probably do). Shouldn't be too hard to fix though.