Adding support for Ubiquiti UniFi 6 Plus (U6+)

I've been running 6.1 kernels on my U6+ ever since I got it, without noticing any such issues. But I don't use sae-mixed mode.

Just tested the 6.6 support and haven't noticed any obvious regression yet. The only issue I had was a rename of the radio paths from 'platform/18000000.wifi' to 'platform/soc/18000000.wifi', requiring manual fixup in /etc/config/wireless. But that seems to be independent of the 6.6 update. It is caused by commit 0ef927472148 ("mediatek: filogic: move mt7981 on-SoC blocks to "soc" node in DT")

Mine is still stable today after 41hrs. I made no changes except changing the channel of the 5.8Ghz network from 36 to 112 (I didn't touch encryption mode). I will continue to keep an eye on it and report back.

It eventually happened again, this time 2.4Ghz devices were getting extreme poor performance while 5Ghz remained ok. Once again a reboot restored performance.

Can you do a WiFi scan of your environment and see if there's anything that might interfere with your setup? Take multiple scans at times it works and when it doesn't work. The nature of the failures seem completely random to me and @bmork hasn't seen issues with recent snapshots. So I'm guessing some external factor is causing problems. Maybe also try changing the channel of the 2.4GHz radio?

I recently owned a U6+, and I’m going to install OpenWRT on it today and report back results. For my setup, I will use this strictly as an AP and connect it as a Dumb Access Point to my main Linksys 3200 ACM.

With this, if anyone needs me to run some tests on it, please let me know and I’ll help if I can.

1 Like

Do report back. The U6+ is an incredible AP from my experience with their proprietary firmware but haven't put OpenWrt on mine yet (have a GL-MT6000 with latest snapshot for my home network now). Since both are Filogic/mt76 based so performance is expected. Curious how well U6+ works with OpenWrt, it should be great, but I would miss Ubiquiti's single SSID/single sign-on band stearing, it just works flawless on the office I put it in.

1 Like

I haven't had to reset mine in 5 days now. The only changes I've made since the instability are to explicitly choose channels for both radios rather than have them on auto. Hopefully it continues to work.

1 Like

For what it's worth, I run multiple APs so I always set the channel explicitly to minimize the possibility of interference between them. It would explain why I haven't seen the same issues that require rebooting.

I don’t have an office, so I don’t think I’ll notice those differences in my findings.

Is it possible to disable blue led? It is very bright for sleeping environment...

  1. Go to LuCI→"System" menu→"LED Configuration" page
  2. Click "Add LED action"
  3. Set "Name" to whatever you want
  4. Set "LED Name" to "blue:dome"
  5. Set "Trigger" to "Always off (kernel: none)"
  6. Click "Save"
  7. Click "Save & Apply"
2 Likes

As I'm starting this, we should add a wiki with the instructions + link to existing Unifi documentation, specifically this one. My network is not on 192.168.1.1/24, so the fallback IP method of 192,168.1.20 does not work for me. Figuring out how to connect otherwise.

192.168.1.20 only works when you connect the AP directly to a PC's NIC with a manually configured IP address such as 192.168.1.2. If you connect the AP to a functioning network, it will obtain a DHCP lease. If your router runs OpenWrt, go to your router's overview page and look for the AP's IP address in the "Active DHCP Leases" section.

After you flash OpenWrt, the AP will use the default OpenWrt static IP address 192.168.1.1. So it's best to flash and configure the AP with it directly attached to your PC through a PoE injector or switch in any case. Alternatively, you can customize the build and have the OpenWrt AP obtain a DHCP lease using the uci-defaults feature. The Firmware Selector allows you to customize a firmware's uci-defaults before downloading it.

Agreed, especially since that U6+ is now supported in a stable release. I have Wiki access so I'll be able to do this at some point soon.

1 Like

I have U6+ running OpenWRT with the latest release as a dumb AP. I chose specific channels. Right now I’m running the Linksys WiFi and the U6 AP WiFi while I migrate existing devices and allowing a fallback. After migration I’ll disable the Linksys WiFi.

As of now, no major issues or concerns. Speed seems to be about the same between Linksys 3200 ACM WiFi and U6+ - not sure if this is just a perf limitation of the 3200?

Hi, I noticed there wasn't a Wiki page for the U6+. I added one, but I do not own a U6+. Could someone please review the wiki page? https://openwrt.org/toh/ubiquiti/unifi_6_plus

1 Like

I just tried upgrading my u6+ from snapshot to stable using sysupgrade image from Luci and can no longer access it :frowning:

I seem to be able to enter failsafe (fast flashing) by pressing reset button during boot, but then cannot access documented openwrt failsafe address of 192.168.0.1. have tried via Poe switch and injector straight to PC.

Any ideas before I try and restore ubiquiti fw using tftp?

nevermind, I failed to realise my snapshot kernel was ahead of stable, so my wifi networks disappeared due to platform vs platform/soc in the wifi-device paths. I'm still puzzled why failsafe appeared to not work on this device though.

Where did you read that? This wiki page says the failsafe address is 192.168.1.1/24, and the NIC needs to be manually set to something like 192.168.1.2 with netmask 255.255.255.0.

Congrats, you beat me to getting the wiki up for this device. :slight_smile: I do have some more information I want to add to that page, but what you put there it's a great start. Thanks!

1 Like

You are right, not sure why I read 192.168.0.1. In any case I also tried 192.168.1.1 (using 192.168.1.2 as my local address) without success.