Adding support for Mercusys MR90X

I'm having difficulty with a new MR90x. I went through the intallation instructions, appearing to work quite fine until step 15. Following a reboot, the device seems to be booting into the u-boot recovery option, providing web access to upload firmware only. Attempting to upload the OEM bin firmware file reports to be successful, but then I'm straight back to the same recovery stage after a powercycle.

So now I'm trying to recover the device without having to solder in the serial connectors.

Judging by how quick the upload part of the recovery firmware upload goes (about 5 seconds), could it be the OEM firmware is not being uploaded correctly? Is there anything else I can try to recover the device?

Edit: Never mind. I ended up going the serial port route (and boy is it touch to open). Somehow one partition got corrupted, throwing many ubi read errors (error -74). The other partition is fine, and I've been able to install via serial onto that. I'll try fixing the other partition later.

1 Like

I vaguely remeber that my initial recovery test also went blazing fast, to me the observed 5 seconds don‘t seem overly unusual.
(My other mt7621 devices take over a minute to flash via recovery in comparison)

hi everybody i has lost internet tonight

mr90x lost internet

the only way to recuperate the connexion internet is make static ip in windows .. why ??

i can share my kernel log and sytem log in private at developper for see the problem

edit the ip full was the problem

in case anyone is looking for sysupgrade feedback:
for me the regular sysupgrade (which does not keep custom packages) from 23.05rc3 to 23.05.0 (+checkmarked, to retain config) worked without issues (so far).

hi is this router is avalaible for the france swiss ? i can't found actually

not a good omen regarding availability: amazon de no longer has it listed. Though it was just 3 month ago, when it was first listed there. Other German onlineshops never had it the last months.
Could be, it stays a rare niche device. Maybe the chip shortage is still going on.

A quick scan shows iponshop de and iponshop at have it, but I don't know this vendor at all or whether that is trustworthy, so stay cautious, it is up to you to decide, where to order safely.

My general recommendation is: first check the https://openwrt.org/toh/views/toh_available_16128_ax-wifi list, if any other device with the same mediatek mt7981 chip or another supported AX device looks decent enough for you to buy and is available in a shop near you, before starting cross-country purchasing adventures for rare devices.

Maybe check back on amazon de in 2-3 weeks, maybe miracles happen and they get a new batch.

1 Like

ok just is normal i have just 21.89 mb of storage or not ?

Software

Free space:
98%
21.89mb thanks

df -h
...
overlayfs:/overlay 31.7M 180.0K 29.9M 1% /

and:
https://openwrt.org/toh/mercusys/mr90x_v1#flash_layout:
0x000000300000-0x000003500000 : "ubi0" 0x3200000
Should be around 0x3200000 minus some minimum config data = ~30Megabyte,
(if nothing has been installed yet and if you have no extensive config stuff exists):

what is wrong i can't revert to stock and remanip you thi

I tend to say, something could be wrong on my side.

mine currently shows:
image

Hm, there should be a kernel partition of 9 MB as well in the beginning of the 32MB of the UBI partition, I currently don't get, why mine shows 32MB free space, if the UBI partition is also just 32MB. ...I might need to investigate mine the next days.

I would not be worried from your perspective. Without knowing details, my gut feeling says, yours looks more correct than mine at this point.

(I've installed mine via SSH, not via serial cable)

1 Like

ok if you want know i don't has use serial console but ssh directly

thanks pico

...oh, now I seem to get it, you weren't asking, where to buy it, but how to switch display language to french?

opkg install luci-i18n-base-fr

no at all i already bought it but i don't see it on the website anymore you understood right ^^

Can I ask what behaviour you were seeing when trying to repair with stock install? I am getting a 100% upload, on the manufacturer's recovery page, and a success message, but then when I go to reboot, I get nothing unless I reboot back into the recovery mode.

Anyone have any ideas about how this happened, or how I might fix this in software?

This is what i was experiencing too. It was only after getting console access that i learned it was caused by failure in one partition. The install into the second partition was successful.

Perhaps you'll need console access too?

1 Like

I'd like to ask for some help in installing a second instance of OpenWRT on my MR90X, if this is something that is possible?

I was expecting ubi1 to mirror ubi0 as they're the same size on flash, but they don't appear to be alike.

root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00200000 00020000 "boot"
mtd1: 00100000 00020000 "u-boot-env"
mtd2: 03200000 00020000 "ubi0"
mtd3: 03200000 00020000 "ubi1"
mtd4: 00800000 00020000 "userconfig"
mtd5: 00400000 00020000 "tp_data"
> root@OpenWrt:~# ubinfo /dev/ubi1 -a
> ubi1
> Volumes count:                           1
> Logical eraseblock size:                 126976 bytes, 124.0 KiB
> Total amount of logical eraseblocks:     32 (4063232 bytes, 3.8 MiB)
...
> Present volumes:                         0
> 
> Volume ID:   0 (on ubi1)
> Type:        dynamic
> Alignment:   1
> Size:        18 LEBs (2285568 bytes, 2.1 MiB)
> State:       OK
> Name:        **tp_data**
> Character device major/minor: 248:1

In this case, filesystem tp_data is mounted into /tmp/tp_data and appears to contain firmware, suggesting I don't really have any grasp on this device really :slight_smile:.

Can anyone tell me simply, is it possible to have two separate OpenWRT firmwares on this device? If so, how do I go about it?

It's possible. Need to make changes in OpenWrt sources (device dts file and some other) and build firmware for the second slot.

Orient me on the wifi settings in OpenWrt (23.05.0): the network adapter (intel ax201) in Windows connects to the router via wifi6 at a maximum speed of 1.7Gb/s, but with stock firmware it connects in two streams - 2.4Gb/s.

Strange, now I turned on the PC and router to check, and the problems went away: the connection is at a stable 2.4Gb/s.

2023-11-15 21-59-15 1  OpenWrt - LuCI — Яндекс Браузер

It turned out that intel wifi adapters have regional restrictions Intel LAR/DRS, so my adapter was periodically connected to the router according to the 802.11ac standard instead of 802.11ax. The problem was solved by replacing the driver.