Adding support for Comfast cf-wr617ac

Hello.
Trying to build image for chinese comfast cf-wr617ac.

I have dmesg of original FW: https://paste2.org/UFshJLMt

I did this: https://paste2.org/kbB3tPK0

That is what i'm getting on UART: https://paste2.org/e98ehzKJ
Nothing happens after "Starting kernel ..."
I tried to listen for traffic and it doesn't seems like it's problem with TTY or logging, at least not directly - i don't see any traffic originated from mac of the device withing 10 minutes after it boots.

Could you please help me to figure out what i'm doing wrong?

Something wrong with your build system. Current trunk for ramips/mt76x8 use kernel 5.4 and branch 19.07 use kernel 4.14 but your logs:

## Booting image at bc050000 ...
14:44:10.961 ->
   Image Name:   MIPS OpenWrt Linux-4.19.91
14:44:10.961 ->
   Image Type:   MIPS Linux Kernel Image (lzma compressed)
14:44:10.961 ->
   Data Size:    1803868 Bytes =  1.7 MB
14:44:10.996 ->
   Load Address: 80060000
14:44:10.996 ->
   Entry Point:  80060000
14:44:10.996 ->
   Verifying Checksum ... OK
14:44:12.564 ->
   Uncompressing Kernel Image ... OK
14:44:15.348 ->
No initrd
14:44:15.348 ->
## Transferring control to Linux (at address 80060000)

show that you use kernel 4.19. And BTW strange kernel load address 80060000 (typical 80000000)

1 Like

Thank you for your reply. Weird kernel version caused by the fact that i tried to backport this patches to an older codebase as i seen some similar bugs for master. Apparently none of this related - i spent half of the day flashing wrong firmware for different device. Noticed that size of tftp upload didn't changed after rebuilds

Right now config is:
https://paste2.org/87PEEEKt

and i cannot get local switch or wan port working - always getting https://paste2.org/AfAwd8cG

Obviously i ported my code back to master.

Well, it's working for 19.07, there is definitely some issue with master.

I did a PR https://github.com/openwrt/openwrt/pull/3118 but not really sure if i'll find enough time to get up to the code. If someone can pick work from here or at least let me know what i need to do to get it merged i would appreciate that.

It's possible.
But incomplete patch/PR is not good. It waste developers time only.
I see some errors at first glance:

09:53:04.041 -> [    6.096346] Creating 4 MTD partitions on "spi0.0":
09:53:04.041 -> [    6.101228] 0x000000000000-0x000000030000 : "u-boot"
09:53:04.076 -> [    6.107425] 0x000000030000-0x000000040000 : "u-boot-env"
09:53:04.076 -> [    6.113880] 0x000000040000-0x000000050000 : "factory"
09:53:04.076 -> [    6.120111] 0x000000050000-0x0000007b0000 : "firmware"
09:53:04.076 -> [    6.131725] libphy: Fixed MDIO Bus: probed

so "firmware" partition is not splitted into "rootfs" and "rootfs_data".
In current trunk there are some cosmetic changes of dts syntax.
One of them is removing "ralink" in pinctrl

&pinctrl {
       state_default: pinctrl0 {
               gpio {
                       ralink,group = "i2c";
                       ralink,function = "gpio";
               };
       };
};

Also absence of gpio LED/keys descriptions is strange.

Please help,

I bought a cf-wr617ac wi-fi router. When I installed it, the signal status indicator first lit blue, then red and now lights purple-pink all the time. The internet is weak. Is the router broken? Thanks
stevce.cosevski@gmail.com

The COMFAST CF-WR617AC is advertised by manufacturer as having 16MB flash memory, but I just checked the stock COMFAST CF-WR617AC newest firmware (CF-WR617AC-V2.6.1), and
dmesg reveals this:

m25p80 spi32766.0: en25qh64a (8192 Kbytes)
[ 0.660000] m25p80 spi32766.0: using chunked io
[ 0.670000] 5 ofpart partitions found on MTD device spi32766.0
[ 0.670000] Creating 5 MTD partitions on "spi32766.0":
[ 0.680000] 0x000000000000-0x000000030000 : "u-boot"
[ 0.690000] 0x000000030000-0x000000040000 : "u-boot-env"
[ 0.690000] 0x000000040000-0x000000050000 : "factory"
[ 0.700000] 0x000000050000-0x0000007b0000 : "firmware"

Could pls somebody more experienced with OpenWrt confirm now, that the data from manufacturer, so that COMFAST CF-WR617AC has 16MB flash memory are definitelly wrong, or is it still chance, that CF-WR617AC has 16 MB flash memory ?

Is it fixed.
Can we conclude that Comfast CF-WR617AC is not supported by Openwrt.