Adding Software packages for different routers

I am trying to get my head around adding software packages for my Linksys WRT32X, but also looking for more generic advice as I have other Routers.

I gather some are part of the OS and some are not, for example let me start with WGET

I search google and come up with this link, I notice the Lede17 does that mean it is not suitable for OpenWrt 19.07.7 even though the version of Wget at that location is 1.19.2-2, does the 19 in that mean it is supported by OpenWrt 19.07.7 ?

Also I notice that it has dependencies of

libc, libssp, libpcre, zlib, libopenssl, librt

Each of these on their own page, but I am not clear on which ones are base or otherwise.

But then I stumbled upon a completely different route

I started with the page for my router

Then I found a link to a series of router

Scrolling down to my router on that page had a table for arm_cortex-a9_vfpv3 cal

Following that link took me to a page called

Index of (root) / releases / packages-18.06 / arm_cortex-a9_vfpv3 /

https://downloads.openwrt.org/releases/packages-18.06/arm_cortex-a9_vfpv3/

It looks hopeful albeit that I am not sure where the dependencies would be

|File Name|File Size|Date|

|base/|-|Fri Jan 8 06:49:36 2021|
|luci/|-|Fri Jan 8 06:49:36 2021|
|packages/|-|Fri Jan 8 06:49:36 2021|
|routing/|-|Fri Jan 8 06:49:36 2021|
|telephony/|-|Fri Jan 8 06:49:36 2021|
|feeds.conf|0.4 KB|Fri Jan 8 06:49:27 2021|

ALSO I noticed has packages 18.06 so should there be a similar page for 19.07.7 or would I be OK going down that rabbit hole ?

Finally other than a google search how to I find out what a package does, for example zlib in OpenWRT

I am sorry if these questions are totally nubish but just trying to find best way to do this right.

Tell me that their is an easier way to find a package, install it for the right version of OS and the right version for router (if any) and the to get all the dependencies (if they are not already installed

I tried going to Software screen and searching for WGET but it did not come up with anything

Did you click "update lists"?

Also wget is provided via uclient-fetch (in a slim version).

2 Likes

Many thanks, that solved it.