Adding OpenWrt support for Zyxel EX5601-T0

It validates the stuff it boots/reads.
Here's the differance, from a secure boot enabled Acer W6m: Support for Asus ZenWiFi BT8 Tri-band Wifi7 (Mediatek MT7988) - #112 by Pulver.

Not until you actually reboot, after writing the images.

If B10 is the brand new version, then yes.

So far I haven't gotten a straight answer.
I was going to add a warning to the wiki page.

1 Like

14 posts were split to a new topic: For development work: EX5512-T0 units available

I accidentally replied to you but that was not intended....sorry

i sysupgraded 23 to 24.10 and i couldnt enter the device with the keep settings option. In serial i entered firstboot and i was able to config it again.

But when i just and only just, change the ip to 192.168.1.203 the device becomes unusable. Suddenly my nic gets a 169.x.x.x ip.


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd62:86ae:696c::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.203'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'

as you can see only default stuff except the ip change...

in serial i can see reconnecting the cable though:

<6>[ 1419.992991] mt7530-mdio mdio-bus:1f lan3: Link is Down
<6>[ 1434.555812] mt7530-mdio mdio-bus:1f lan3: Link is Up - 100Mbps/Full - flow control rx/tx
<6>[ 1434.555836] br-lan: port 3(lan3) entered blocking state
<6>[ 1434.569632] br-lan: port 3(lan3) entered forwarding state

EDIT: flashed back to 23 using the itb file in cli and changing ip works again. So whats up with the sysupgrade to 24.10....?

Isn't the default DHCP setup giving out IPs in the x.100-x.250 range, so that kind of conflicts?

I had the device as dumb AP. There was no dhcp server active. I'll have a go at it more to double check the dhcp server was indeed off. Also I'm going for attended sysupgrade instead of just flashing the file in luci

EDIT: Nope. After 'keep settings' attended upgrade the device is just gone... Not pingable anymore. I checked the dhcp server was off, and also made sure the range was 240-250(just in case it turns on after flash or whatever).....

Also the green LAN led is solid on(no blinks) and the nic-led on the back stays off.

So only way to make it usable again now is to go back to v23.

  1. go in with serial, factory default it with command "firstboot && reboot"
  2. device (still on v24) becomes available again by nic on 192.168.1.1
  3. upload 23.05 itb file with winscp
  4. cli command 'sysupgrade' that file.

EDIT2: I wanted to go back and flash 23 and accidentally flashed 24 again over itsself. I thought since i did an oopsy i might as well try it once more to config v24 as i want to (ip 192.168.1.203). And now suddenly it works. Fingers crossed.

1 Like

I have a strange issue with the WAN port in bridge mode.

I have a MT6000 as main router, the T-56 as 'dumb AP'. On the T-56, I have bridged the WAN port (eth1) to the LAN-ports, and eth1 is connected to the MT6000. I have three SSIDs, so besides the 'regular' eth1, I also have two VLANs. My etc/conf/network:

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config device
	option name 'br-vpn_lan'
	option type 'bridge'
	list ports 'eth1.20'

config device
	option name 'br-gast'
	option type 'bridge'
	list ports 'eth1.30'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'
	option delegate '0'

config interface 'vpn_lan'
	option device 'br-vpn_lan'
	option proto 'none'
	option delegate '0'

config interface 'gast'
	option device 'br-gast'
	option proto 'none'
	option delegate '0'

This works great, until I reboot the MT6000. The link will come up, but there is no traffic at all. The MT6000 isn't even receiving any packets on the interface. When I reboot the T-56, everything is working again... It seems that losing the link on eth1 causes some issue in the T-56, but besides the obvious link is up entries, there's nothing in the T-56's syslog.

Is anyone else running into issues bridging all ports together?

I can relate to this although not exactly comparable. I have a network with 4 old Archer c7 v2 running openwrt. Slow but stable as fck.

Now with changing one of those with a t-56 on v24 with eth1 added to the bridge, my proxmox cluster is complaining it's not stable to a point where nodes auto reboot. Tomorrow I'll be undoing the eth1 and see if that stabilizes the corosync which syncs the node.

Also suddenly a archer c7 behind the t-56 has intermittent WiFi dropouts of iot stuff all of a sudden. Been stable for 2 years minimal.

EDIT1: I removed eth1 from the bridge and rebooted. afterwards i had a ping logger script running and out of nowhere i get a ping error. can be half an hour or many hours. Exactly those times my proxmox cluster nodes start to throw errors it lost connection to the other nodes and starts to reinitiate.
For now i removed the T-56 and reinstated the archer c7 and see if the errors are gone. Then its most def then T-56.
BUT not then for me at least its not the 'ETH1 adding to the switch' related. I have troubles with or without that. Its something else

EDIT2: ill post any updates here once i know more

It seems there's some things to iron out for the next openwrt updates. For now I want to flash from Odido to stock EX5601 firmware and layout. And then continue to openwrt from there, when these issues have been ironed out. Is thehybrid1337's guide in post 641 still the right way to do that?

EDIT2 Since i cannot edit my previous post anymore ill write here: Ive been pinging for 18 hours through straight and there are no errors anymore. So changing back to Archer C7 router fixed my network instability. All i can tell right now is the T-56 on v24 at least appears to be the culprit. dunno about v23.

I have 4x T-56 here. Im am going to flash them with a fresh v23 and daisy chain them together for a new ping test so the ping will go through all t-56(as dumb APs). Not sure how to test which one (or all) are faulty... any thoughts?

1 Like

I was experiencing problems with my WAN connection (eth1) going down and this in the startup tab fixes it.

ethtool -s eth1 advertise 0x028
ethtool -s eth1 speed 1000 duplex full autoneg off

From https://github.com/openwrt/openwrt/issues/14437
https://github.com/openwrt/openwrt/issues/14192

1 Like

It seems fixed for now by changing br-lan from eth1 to eth1.10. So only VLANs on the (bridged) WAN interface now. It doesn't make much sense to me, but I'll monitor for any changes to the mediatek target.

Got a T-56 from wifilinks today and it's still on V5.70(ACEA.0)T56C_b7_1006 :+1: Ordered on March 10

2 Likes

It depends on which firmware version you're running at the moment.
If b7 then it will work.
If b10 then im unsure.

Also i suspect that there already existed a b10 version before, since i saw people talking about it back in november 2024

So i think that b10 is a different one than the b10 i personally got on 27 feb 2025

Also i'm close to getting mtk_uartboot to work again. Im not sure if it will work on any other device but mine since i changed almost all the source code to make it compatible.

EDIT:
as suspected there are more of the same b10 version. might be more than these two.

There's a risk of bricking your device if you're on the b10_0122 version as i did. It's possible that b10_0130 is safe.

V5.70(ACEA.0)T56C_b10_0122 ( my device bricked )

V5.70(ACEA.0)T56C_b10_0130 ( ? )

According to this post b10_0130 is safe

location? Netherland ? Bcz I was going to order one in Netherland but need to know the shipping time.

Maybe this can be useful https://forum.banana-pi.org/t/wed-and-beamforming-on-bpi-r3/15099/123

After tomorrow i think i will focus on the issues regarding wifi instead of the other stuff. There is no point in setting up guides how to install OpenWrt if OpenWrt is not working correctly.

I'm located in Germany. Afaict they dispatched it right away.

Hi everyone, is it possible to get the SFP port on the EX5601-T0 working?
I'm using the modded openwrt firmware v23.05.0 (downloaded from https://hack-gpon.org/zyxel/). GPIOs 57 and 10 are already exported. I'm using a 10GBASE-T transceiver (with support for 2.5G) that has worked on other Zyxel devices. However, OpenWRT doesn’t detect the SFP port, even when connected to other devices.
Has anyone managed to get the SFP port working? I’d really appreciate any help. Thanks

we have no idea what a 3rd party firmware is capable of doing (and not doing), ask the person who provided you with it.

That firmware was already discussed in this thread and recommended along with the guide. Based on earlier replies, I think other users also followed it. Moreover, it seems that the firmware has only minor changes regarding the SFP port. Perhaps someone managed to make the port work even with other openwrt versions, which is why I'm asking
edit: I wrote the fw version and what i used just for reference

I am the author of that. And the sfp works as a combination of:

Dts: put the phy6 in fixed link
At runtime a script initializes the interface in fixed link 2500 (no autoneg!!!!)

Exporting the pins only is not enough indeed in that firmware there is a scrip that swaps pin 10 (gpio410) when an sfp is detected (pin 53)

Long story short the transceiver you plug in must be able to link 2500 without any sort of auto negotiation.

There is a parallel work in progress to bring native kernel support for multi phy -Mac interfaces but that is far long from going live any time soon.

If you want you can just do the same with 24.10 too.
Clone the code, change the dts import the script and it should work. (If it doesn’t it is mostly because the transceiver you are using is expecting auto negotiation to work)

https://github.com/openwrt/openwrt/compare/main...pameruoso:openwrt-ex5601t0-porting:ex5601-t0-fixedlink.patch

4 Likes