Adding OpenWrt support for Xiaomi "Redmi Router AX6S"/"Xiaomi Router AX3200"

I am experiencing a problem with my gigabit LAN port. I have an LTE modem with a gigabit LAN connection. However, when I connect my LTE modem to the router using the gigabit LAN, the speed reduces to 20 Mb/s, even though the actual LTE speed is 100 Mb/s.

I tested the LTE modem with a laptop's gigabit port, and everything works fine. This indicates that the cable and LTE modem's gigabit port are not the problem. Additionally, I tested the router with another LTE modem that has a megabit LAN, and everything is working correctly.

The speed issue seems to be specific to the gigabit connection between the LTE modem and the router. I even tried changing the cable, but the result remained the same.
The cables I'm using are Cat5e. My OpenWrt version is 22.03. From what I can remember, I didn't have this problem with earlier versions of OpenWrt.


Hello everyone!
I have an ax3200 RB01 with factory enabled telnet (08/2021)
I haven't installed the factory version of OpenWrt yet but I wanted to know if you think I could also upgrade it.
I know I could use the UART procedure to unblock it in case of birck but I don't have the equipment to do that right now.
Thanks so much for the support!

I'm going to buy AX6S RB03 to my brother, they still can be flashed with OpenWrt with same instructions as before? Thanks

Okay, I was dumb/lazy enough not to read the warning about updating a RB03. Happy that MiWifi repair tool worked like a charm once again. Router back up in no time. I'll wait at least 4 months before I try another update.
@Gilgamesh: if you can flash https://github.com/YangWang92/AX6S-unlock/raw/master/miwifi_rb03_firmware_stable_1.2.7.bin on your router you should be fine.

1 Like

Hi all! I tried today to flash the Readme Router AX6C (RB03) according to the main guide, but after executing the command "mtd -r write factory.bin firmware", the router rebooted, shines constantly with a yellow lamp and does not react to anything. I tried to reset to factory settings using power and the reset button, the same thing. Are there any methods of saving a device turned into a brick? Thanks

I always have issues when running 5ghz wifi ssid on more than one device. I find my device constantly looses internet access and I have to toggle wifi off and on.
So now I turned off 5ghz wifi on 1 ap and keep it on the other ap since I only really need 5ghz from that 1 ap. No idea what the issue is, assume it's a bug that is still to be ironed out since ax wifi is flaky so far.
I keep the 2.4ghz ssid on for both and haven't had issues with it. Never tested how well the fast roaming is on the 2.4 as I generally only use 2.4 for the iot devices scattered around the house.
So my guess with your issue is that it's an issue with the wifi that is still not stable just yet.

I have a similar issue. I have a Redmi AX6000 as the main router and two AX6S as access points. Roaming from AX6S AP's to AX6000 is working well but roaming from AX6000 to AX6S or AX6S to AX6S fails on iPhone 13, 2021 MacBook Pro (M1 Pro) and other devices. They appear to roam across well, and I see the new BSSID on the client but after a few seconds they loose their IP address and won't reconnect. Has anyone had roaming working successfully with newer apple devices and AX6S?

In summary:

AX6S (AP) ---> AX6000 (Router) :heavy_check_mark:
AX6000 (Router) ---> AX6S (AP) ✘
AX6S (AP) ---> AX6S (AP) ✘

cat /etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/18000000.wmac'
        option band '2g'
        option country 'GB'
        option channel '1'
        option cell_density '0'
        option htmode 'HT20'
        option log_level '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '5g'
        option country 'GB'
        option cell_density '2'
        option he_bss_color '8'
        option he_su_beamformee '1'
        option beacon_int '100'
        option channel '100'
        option htmode 'VHT80'
        option log_level '1'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid '########'
        option encryption 'psk2'
        option key '########'
        option network 'home'
        option dtim_period '3'
        option ieee80211r '1'
        option mobility_domain '9ba4'
        option nasid '5C0214B65E9F'
        option ft_psk_generate_local '1'
        option ft_over_ds '0'
        option bss_transition '1'
        option wnm_sleep_mode '1'
        option time_advertisement '2'
        option time_zone 'GMT0BST,M3.5.0/1,M10.5.0'
        option ieee80211k '1'
        option reassociation_deadline '20000'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid '########'
        option encryption 'psk2'
        option key '########'
        option network 'corporate'
        option dtim_period '3'
        option ieee80211r '1'
        option mobility_domain '5b60'
        option nasid '5E0214B65E9F'
        option ft_psk_generate_local '1'
        option ft_over_ds '0'
        option bss_transition '1'
        option wnm_sleep_mode '1'
        option time_advertisement '2'
        option time_zone 'GMT0BST,M3.5.0/1,M10.5.0'
        option ieee80211k '1'
        option reassociation_deadline '20000'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid '########'
        option encryption 'psk2'
        option hidden '1'
        option key '########'
        option network 'management'
        option dtim_period '3'
        option ieee80211r '1'
        option mobility_domain '4d86'
        option nasid '5A0214B65E9F'
        option ft_psk_generate_local '1'
        option ft_over_ds '0'
        option bss_transition '1'
        option wnm_sleep_mode '1'
        option time_advertisement '2'
        option time_zone 'GMT0'
        option ieee80211k '1'
        option reassociation_deadline '20000'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid '########'
        option encryption 'psk2'
        option key '########'
        option network 'home'
        option dtim_period '3'
        option ieee80211r '1'
        option mobility_domain '9ba4'
        option nasid '5C0214B65EA0'
        option ft_psk_generate_local '1'
        option ft_over_ds '0'
        option bss_transition '1'
        option wnm_sleep_mode '1'
        option time_advertisement '2'
        option time_zone 'GMT0BST,M3.5.0/1,M10.5.0'
        option ieee80211k '1'
        option reassociation_deadline '20000'

config wifi-iface 'wifinet4'
        option device 'radio1'
        option mode 'ap'
        option ssid '########'
        option encryption 'psk2'
        option key '########'
        option network 'corporate'
        option dtim_period '3'
        option ieee80211r '1'
        option mobility_domain '5b60'
        option nasid '5E0214B65EA0'
        option ft_psk_generate_local '1'
        option ft_over_ds '0'
        option bss_transition '1'
        option wnm_sleep_mode '1'
        option time_advertisement '2'
        option time_zone 'GMT0BST,M3.5.0/1,M10.5.0'
        option ieee80211k '1'
        option reassociation_deadline '20000'

config wifi-iface 'wifinet5'
        option device 'radio1'
        option mode 'ap'
        option ssid '########'
        option encryption 'psk2'
        option hidden '1'
        option key '########'
        option network 'management'
        option dtim_period '3'
        option ieee80211r '1'
        option mobility_domain '4d86'
        option nasid '5A0214B65EA0'
        option ft_psk_generate_local '1'
        option ft_over_ds '0'
        option bss_transition '1'
        option wnm_sleep_mode '1'
        option time_advertisement '2'
        option time_zone 'GMT0BST,M3.5.0/1,M10.5.0'
        option ieee80211k '1'
        option reassociation_deadline '20000'

Running latest snapshot (OpenWrt SNAPSHOT r23422-e0fb38f4ee)

Edit: For anyone coming across this issue in the future, it was caused by MAC address learning on the switch that the APs are connected to. It was significantly helped (but not solved) by setting the ageing time on all bridge devices to 10.

hi just installed OpenWrt on my rb03 ax6sand would like to add to the wiki some guidelines for new users

  1. in the part when you connect via PuTTy you should make the connection type other and not the default SSH otherwise the connection will be refused
  2. after updating the firmware to the closedbeta 1.2.7 in order to enable telnet. the link in the first step will show telnet as false even though its enabled and working

although the guide was very clear and the system now is running better and faster than the stock firmware and more importantly in english
additionally what packages or certein settings you guys recommend for a network newbie to install or change on OpenWRT

1 Like

A very large disclaimer that you cannot update the AX6S with a default sysupgrade file would also help!

I use X-WRT, which is OpenWRT with Luci and most important packages already installed.

edit: this update problem no longer seems to exist in recent snapshots.
running "hexdump /dev/mtd8 | head" via ssh gives the correct response: "0000000 0dd0 edfe0000000 0dd0 edfe" etc.

Watchcat

OpenWrt 23.05.0-rc2 (r23228-cd17d8df2a)

Does not restart the interface.
In the log, all events occur, in the log it says that the interface is being overloaded, but in fact this does not happen.

Summary

Tue Jul 4 06:37:55 2023 daemon.info watchcat[2597]: Could not reach 8.8.8.8 via "cloudfire" for "10" seconds. Restarting "cloudfire" after reaching "30" seconds
Tue Jul 4 06:38:05 2023 daemon.info watchcat[2597]: Could not reach 8.8.8.8 via "cloudfire" for "20" seconds. Restarting "cloudfire" after reaching "30" seconds
Tue Jul 4 06:38:15 2023 daemon.info watchcat[2597]: Could not reach 8.8.8.8 via "cloudfire" for "30" seconds. Restarting "cloudfire" after reaching "30" seconds
Tue Jul 4 06:38:15 2023 daemon.info watchcat[2597]: Restarting network interface: "cloudfire".
Tue Jul 4 06:38:15 2023 daemon.notice netifd: Network device 'cloudfire' link is down
Tue Jul 4 06:38:15 2023 daemon.notice netifd: Network device 'cloudfire' link is up

If you click on the reset button of the same interface in the LUCI, then the reboot occurs.

Is this a firmware issue or a plugin issue?

I have my entire network connected on 5GHz and it is perfectly stable. The AX performance seems a little lower than AC, but I have never had a dropped connection or anything. My AX6S functions as the WAN router via PPPoE, too.

With RB01 version and telnet disable, the only solution is to use an UART?Is it a correct understanding? Thx.

Hello All,

My Xiaomi AX3200 router was telnet locked so I installed OpenWRT using USBTTL. How can I restore the original factory system if the TFTP function is not available?

MIWIFIRepairTool.x86

Was the 100 Mbit/s switch bug ever fixed? If so, I seem to have discovered a similar issue. When a 100BASE-TX device is connected to ethernet, clients on the 5 GHz radio are capped at 100 Mbit/s. When I unplug the 100BASE-TX device, full speed resumes. This only happens on the SSID which is bridged to the matching VLAN of the connected ethernet device/port. Other SSIDs bridged to other VLANs but also using the 5GHz radio are unaffected. I have not tested if this is also the case with the 2.4 GHz radio (but it''s not likely to exceed this speed regardless). Other wired clients seem unaffected. This is with OpenWrt SNAPSHOT (r23566-37ff916af7).

This failed, TFTP mode does not work. When I turn off the router, press the reset button and plug in power, the LED does not blink. It's like TFTP mode is not working. What should I do? Can't I reset it on the web interface?

You need to wait for some time, within 10-30 seconds, without releasing the reset, you also need to set the network card to 192,168,31,100 and no other.

Okay, but even if I wait 10-30 seconds, the LED doesn't start blinking. What's that? Is there another way? Can't I reset it via the web interface?

If this does not work, then you may have a unique situation, which most likely cannot be, most likely you are doing something wrong. I have not seen prepared stock firmware for using the return via the web interface.
You can experiment, but with a "broken" TFTP, this will most likely end sadly.

There is a firmware for converting 3200 into AX6S (China), but it is also not sewn through WEB.

So I can only restore it with TFTP? Or what other methods are there? It is currently running full OpenWRT. Isn't there a web command for it? Or a solution?