Adding OpenWrt support for Xiaomi "Redmi Router AX6S"/"Xiaomi Router AX3200"

I did on the latest development release, dirty flash, wifi working for me in dumb access point but, i don't recommand doing it as being problem free.
Build is: r21900-ac21dff5b6, flashed the sysupgrade way.

So, I used the Mediatek drivers for a couple days, and performance was amazing.

Today I finally got my fiber service installed, during the install I unplugged the router, and after that my Wifi wont come up at all.

I flashed the 22.03.02 from firmware selector and I got 2.4Ghz working again, but 5Ghz isn't working at all.

EDIT: After setting the 5Ghz to channel 44 it works fine.
Did a reboot and I still have working WiFi.
No ideia why the Mediatek drivers leave with no working WiFi.

Hi poyz,
sorry for the late answer. I went from 22.03.02 to 22.03.03. I used the official build I downloaded from https://openwrt.org/toh/xiaomi/ax3200
Please keep in mind that if you're upgrading you should use the " [Firmware OpenWrt Upgrade]" version. For openwrt 22.03.03. The direct link is: http://downloads.openwrt.org/releases/22.03.3/targets/mediatek/mt7622/openwrt-22.03.3-mediatek-mt7622-xiaomi_redmi-router-ax6s-squashfs-sysupgrade.bin
I hope everything will be good for you. Keep us informed.

1 Like

do you compiled the firmware? or ....

Hi everyone,

I installed openwrt today, but the wifi is very unstable,
The speeds are worse than on my mi 4ac gigabit,

Is it normal?
I have the rb01 model

Try snapshot build. It work very good with my device

1 Like

What results do you have with iperf3?

Are you using 802.11ax? If so, try switching to 802.11ac. This and some other devices have issues with 802.11ax and OpenWrt in certain conditions (see below and more details here in this other topic).

1 Like

Running stock openWrt, from the firmware selector, and then added the Mediatek drivers from this Mega folder:

It worked perfectly for a week or two, during that time I never rebooted my router. Once I did a reboot it never worked again.
The WiFi interfaces after booting would be both disabled, I could enable 2.4Ghz, but not 5Ghz.

And its not good to lose WiFi after a reboot.

well, never happened on my build,i do not know why that.

Hi guys,
I am stuck flashing a RB01 model using the UART mode using Windows.

I use pxsrv as a TFTP Server and I flashed fw 1.0.71 successfully many times now. I feel like I am missing an important step:

When booting the device, I can see the Uboot screen and the 5 seconds countdown. But the Arrow keys won't let me select the console option.

Is there any setting in Putty I need to change, so the arrow keys get transmitted correctly?

Is there anyway to test whether my TX cable is connected correctly? I guess this would also be a symtom of not being able to send keys to the console....

Thanks,
Frank

You need to tftp flash the firmware twice in a row without allowing it to boot properly. This will enable UART input.

I did this and I can see the 5 second countdown, but neither pressen 1 or 2 nor the arrows work...

Frank

Make sure you have RTS/CTS disabled (somewhere in Putty port settings).

I set the flow control from Xon/Xoff to None, still not better

Screenshot 2023-01-30 154015

Neither pressing 1 or 2 nor up/down works.
Frank

Try to connect your adapter TX to RX and type something to Putty. It should echo typed keys back.

I feel stupid now....

I think I looked at the pins 5 times - but I had TX and GND mixed up, now it obviosly works... thanks for your patience...

Frank

Is this configuration OK (mt76 drivers):

for mtk wifi drivers or for mt76?
anyway no, you do not need compile all modules.
you have every module as M why that?

Thanks @anon4457646 - I have compiled firmware using your github repo. I have removed mt76 opensource drivers, wpad and hostapd. Russian is added to LuCi. .vermagic is kept.
Firmware - http://ax6s.zyxmon.org/openwrt/
Packages with proprietary drivers - http://ax6s.zyxmon.org/openwrt/ipk/