Adding OpenWrt support for Xiaomi "Redmi Router AX6S"/"Xiaomi Router AX3200"

nice, i have made some changes hope that will help you
if you wan try let me know

absolutely love to. please drop it and thank you for your effort in advance.

with stock xiaomi firmware, 5GHz only channels available are 35,40,44 and 48. Resetting the router and changing countries don't give extra channels, the 5GHz channels I need 149 153 157 161 165. Is it normal?

Anyone has idea on how to set following function on stock wireless drive of this AX3200? I couldn't find these option anywhere in wireless settings.

  1. 802.11r fast transition.
  2. Mac white list (to enforce my son & daughter to disable Private address in iPhone)

ForceRoamSupport=1

try this setting

Thank bricco, its you again come to help.

the second question is not clear, i'm not sure if is possible do mac filtering on mtk drivers, i will check


Enabled ForceRoamSupport=1 but can't find 802.11r option anywhere.
I think this is the mesh configure option from mtk driver? which can't connect to my existing 802.11r network.

to test that we need two device, anyway i compiled the drivers with that option included.
you can try to enable another ssid on the asus without fast roming support, and connect only the xiaomi ax3200 and check if that work.

ok @bricco1981 , thank you and I will try that tomorrow, going to sleep now. good night~

that's mt76, he is on mtk drivers

Ah ok, i see it now, sorry for that

Tested mesh today on stock wireless driver, it worked.
But I still prefer 802.11r for roaming, as I have all 4 routers (1 main, 3 AP) connected through CAT6.

Regarding MAC filter, still nowhere to be found, it is very important function that I need to limit my kids online time by disconnect them by schedule.

An easier option would be to create them a separate network/SSID and a different password and just disable it when it’s time to get off.

1 Like

@soxrok2212 good suggestion, I will try as you advised. thank you.

1 Like

No problem of MAC filter with mt76. It works very well.
I have built a (simple) home made system to limit my kids online time.
It is based on "hostapd_cli DENY_ACL".
Idea was to adapt time based on children age (shutdown children SSID is not an option for me).

@Elmer I am currently using mtk driver, there is no MAC filter, 802.11r options to be found.
I will try mt76 driver, still back reading this topic on how to enable 5G adapter on mt76.

I've tried boot with official firmware, there is no 5G adapter by default.

No matter what I've tried, I cannot pass these :

  LD [M]  /home/username/works/AX6S/build_dir/target-aarch64_cortex-a53_musl/linux-mediatek_mt7622/mt_wifi/mt_wifi_ap/mt_wifi.o
  MODPOST /home/username/works/AX6S/build_dir/target-aarch64_cortex-a53_musl/linux-mediatek_mt7622/mt_wifi/mt_wifi_ap/Module.symvers
ERROR: modpost: "ppe_dev_register_hook" [/home/username/works/AX6S/build_dir/target-aarch64_cortex-a53_musl/linux-mediatek_mt7622/mt_wifi/mt_wifi_ap/mt_wifi.ko] undefined!
ERROR: modpost: "ra_sw_nat_hook_rx" [/home/username/works/AX6S/build_dir/target-aarch64_cortex-a53_musl/linux-mediatek_mt7622/mt_wifi/mt_wifi_ap/mt_wifi.ko] undefined!
ERROR: modpost: "ra_sw_nat_hook_tx" [/home/username/works/AX6S/build_dir/target-aarch64_cortex-a53_musl/linux-mediatek_mt7622/mt_wifi/mt_wifi_ap/mt_wifi.ko] undefined!
ERROR: modpost: "ppe_dev_unregister_hook" [/home/username/works/AX6S/build_dir/target-aarch64_cortex-a53_musl/linux-mediatek_mt7622/mt_wifi/mt_wifi_ap/mt_wifi.ko] undefined!
make[4]: *** [scripts/Makefile.modpost:123: /home/username/works/AX6S/build_dir/target-aarch64_cortex-a53_musl/linux-mediatek_mt7622/mt_wifi/mt_wifi_ap/Module.symvers] Error 1
make[4]: *** Deleting file '/home/username/works/AX6S/build_dir/target-aarch64_cortex-a53_musl/linux-mediatek_mt7622/mt_wifi/mt_wifi_ap/Module.symvers'
make[3]: *** [Makefile:1741: modules] Error 2
make[3]: Leaving directory '/home/username/works/AX6S/build_dir/target-aarch64_cortex-a53_musl/linux-mediatek_mt7622/linux-5.10.156'
make[2]: *** [Makefile:271: /home/username/works/AX6S/build_dir/target-aarch64_cortex-a53_musl/linux-mediatek_mt7622/mt_wifi/.built] Error 2
make[2]: Leaving directory '/home/username/works/mtwifi/mt_wifi'
time: package/feeds/mtwifi/mt_wifi/compile#154.61#30.56#185.45
    ERROR: package/feeds/mtwifi/mt_wifi failed to build.
make[1]: *** [package/Makefile:116: package/feeds/mtwifi/mt_wifi/compile] Error 1
make[1]: Leaving directory '/home/username/works/AX6S'
make: *** [/home/username/works/AX6S/include/toplevel.mk:230: package/mt_wifi/compile] Error 2

Have you encountered it?

how did you manage to get radio1 (MT7915E 802.11ax) working with open source driver? I only have radio0 (MT7622 802.11bgn)