Adding OpenWrt support for Xiaomi "Redmi Router AX6S"/"Xiaomi Router AX3200"

Has anyone successfully reverted to OEM/stock firmware? I would like to perform some Wi-Fi tests with stock firmware but I was unable to find any report of reverting firmware to stock.

very easy, tftp, dnsmasq


I used the Mi Wifi Repair tool without problems. (AKA Xiaomi Recovery Tool)


Anyone using hardware offloading? In my tests after turning on hardware offloading, there was no difference in cpu usage. I am using FTTH + GPON + PPPoE link (max 500mbit). SQM is in the off state.

Could it be that hardware offloading is not working?

Here are the CPU usages in the speedtest test:

do you want try working hardware offlloading on this device?

Hardware offloading is already on. Could it be that hardware offloading is not working over wifi?

are you on 22.03.0? if so i think no.

Yes, the router's version is 22.3.0.

@MeIsReallyBa was that pppoe offload issue you ran into ever get fixed in master?

WiFi HW offload only works on snapshot and needs WED_ENABLE kernel parameter, I tested on DHCP

I think this is a known problem. I hope it will be fixed in the next version.

May I know which version it is? Let me test it.

Raspberry Pi is connected to the router with a cable.

Hardware offload on and off results are as follows. There is no problem with the wired connection.

Retest after this commit and let us know how you go.

Thank you for the information. How can I test this? I guess I have to build it myself.

The latest snapshot includes it. Here are my results using it. Make sure to enable wed per the post above.

1 Like

Many thanks @Sti for the new method discovered and shared with the owrt community.
Added this β€œnetmode: 4” method to the wiki: Please feel free to edit and correct details if something does not accurately describe this method.


It works. :slight_smile: Steps are as follows:

1 Like

2.4Ghz band 40Mhz bandwitdh was not working in version 22.03.0. The same situation continues in build r20775-165b66d910. Has anyone encountered this problem?

1 Like

40mhz won't come up in the presence of other access points occupying the channels. Unless you have noscan specified in your config, which you don't appear to have.

Don't be surprised if you do not see an uplift in throughput or even a decline.

1 Like