Adding OpenWrt support for Xiaomi "Redmi Router AX6S"/"Xiaomi Router AX3200"

do you want try a version with hardware nat enabled?

Well... it builds just fine now... the only thing I did different was to create a new VM but based on Debian (11) this time around.

I've built both OpenWRT 22.03.0 without mtwifi and with (@bricco1981's version) it.

Can't really say why, but thats my story anyways

Sure! Why not

ok, just i have a strange iusse on ethernet side, you can check how work for you.

when you flash it do not keep setting

I never keep settings, bitten once twice shy

please let me know, disable the service that you don't need. i sented

note this version is swconfig so you have a switch option in luci

Just sold my old router, so shouldn't really experiment with the new one. I'm happy with its robustness, even if it is "slow"
But then you say the bottleneck is due SW NAT. Fair enough.

i have it as a client wwan, so mabie that's why, need test

@spwnrpe any news?

Sorry, no updates, too much to do today

What tests (specifically) would you like me to do?

the firmware i sented you is driving me crazy, with hardware nat enabled, if i use it as a station wifi only the wifi client works, on ethernet does not work. so can you test if ethernet lan client work if you use the wan port for internet

edit
my god i had sotware and hardware nat disabled, working now, can you test it anyway?

this is a great firmware, looks like even cake is working with hardware nat.

leds both are working

1 Like

Alright. Thanks!

have you tested the difference of the two version? also the switch? dsa vs old sw patched?

I have posted a separate question, but maybe asking here will help, because people in this thread should have the actual hardware. Mine is an AX6S, and I cannot find the web UI for installing the beta firmware nor an instruction for installing the beta firmware. Must I connect to the Internet to access the firmware installation web UI?

try this.

That utility seems to require that the initial set up has been already done. If you read my linked question, the Xiaomi router is not allowing me to pass the initial set up screen because the router is not connected to the Internet.

Anyway, I have used several home routers in my life, but this is the first router that does not allow me to enter the web UI if the Internet is not connected. Is this a new trend (like how Windows 11 does not allow you to set up the PC until you connect to the Internet), or is Xiaomi trying to mine user data?

use your phone for hotspot, and connect the router as repeter

Already tried that (I think, I am not sure because I do not understand Chinese and just guessed it), and it seems if I do that, the router disables Ethernet ports so that the computer could not access the router. I tried to connect to the router wirelessly from my phone, but after entering the correct Wi-Fi password, it got disconnected saying there was an error getting network configuration. I guess it is because the phone was not actually connected to the Internet. My point was not connecting the router to the Internet before flashing OpenWRT, so it would be pointless if I connect the phone to the Internet.

PS: Correction. The Ethernet is not disabled, but the network changes (no longer 192.168.31.XXX), so that I have no idea how to access the router administration web UI.

Found a way. Using the second connection option DHCP something. That made the setup process end.