Adding OpenWrt support for Xiaomi AX3600

100mbps is kind of low for this SoC tho. For comparison, I could get more than 200mbps with WireGuard across two dual-core1GHz broadcom SoCs.

We do not win anything until we can have full mainstream OpenWRT for the device with source code available. Hacks using a mystery Chinese binary blob is nice from benchmarking point of view but the whole point of OpenWRT is the "open" part :wink:

10 Likes

I agree with you.
But its huge step forward to maybe better understand what going on and the difference between the official firmware and a pure OpenWrt build.
An example like the NSS

3 Likes

What I noticed, is if you choose a FIG_TARGET_ALL QSDK, then the QCA-hyfí and NSS parts are missing (the build script alarms about them right at the beginning), although the relevant source files are there. But if I choose an "NHSS" named release, these missing elements are there during the build, but no kernel 5.4 yet. So I dont think this is a "proprietary" issue, more like they forget tot add it, or something like that.

MOD: this QSDK is as crap as it gets. Large pile of compile errors everywhere... No dependency list etc. If anyone thinks that it is really four commands to get it working, has no idea... Ironed out some of it, but there are still some cross compile erros here and there. Had enough of it for now.

2 Likes

would you have any clues to adapt it, to make it work for ax1800.

are u sure about the secure boot on ax9000? It seems to be a very nice piece of hardware, but if the bootloader is locked there is no hope of OpenWRT on it.

Sorry to hijack this thread, but that one is definitely not Qualcomm proprietary. It's GPLv2 and developed despite Qualcomms efforts to make life hard for users of their hardware. I've never received any help from Qualcomm.

Don’t worry, MiCode will open these.

can you please elaborate your answer or give a link to any documentation about it? I know about the bootloader unlock in xiaomi's mobile phones, but that is a much bigger market and potentially more users insterested in that. However, in the router market I don't think that Xiaomi will provide unlock codes if they decided lock the bootloader.

I searched about micode but I can only find a github repo with kernels, which I don't think that is the thing that you are refering to.

I was sloppy, the secure boot is off

Tried today with AU_LINUX_QSDK_NHSS.QSDK.11.4.1.R1_TARGET_ALL.11.4.1.434.008, this one is at least not failing randomly at building curl, but it points to target files that does not exists at the locations the build script tries to download it from... Ridiculous.

3 Likes

@efsg

What I would like to know is how can your "openwrt-ipq-ipq807x_64-xiaomi_ax3600-squashfs-nand-factory.bin" fit mtd13 while your file is 46 010 368 bytes, but mtd13 is only able to fit 37 486 592 bytes? Can you explain that to me?

I don't know if this maybe has nothing to do with your question, but I've found a "description" of how this people has built the firmware here: https://hackmd.io/@tAQ3QkjhQp6sdU_ak2LXgQ/HJ678KU68#后记 (it's in Chinese but the Chrome translation works ok). In the postscript part they say that the nand flash is not being used totally by Xiaomi and they modify it to use all. Maybe at this moment they resize the mtd13?

I don't understand the major part of the process so maybe I'm wrong.

2 Likes

great news then!

Thank you for the info. Let's hope that the IPQ807x gets supported soon in official OpenWRT.

Hi bitthief, Would you mind detailing what you did to get to this point / would you be able to commit your changes to github for this build?

1 Like

I followed this guide: https://forum.lowyat.net/topic/5071359
But the putty telnet login is not working with the created password from https://www.oxygen7.cn/miwifi/
This firmware: miwifi_r3600_all_6510e_3.0.22_INT
login

Edit: ok somehow it worked now. I tried over some hours, killed the WLAN in the meantime but somehow I can now login with the SSH password I entered with the URL commands

This thread is for support AX3600 in OpenWRT, not for issues related to the official firmware, please use this thread instead:

I'm glad that you were able to fix it.

1 Like

I also find it highly annoying that you guys keep spamming this thread which is exclusively about porting OpenWrt to the Xiaomi AX3600 with some Chinese or whatever crappy firmware stuff! Please do use the following thread instead. Thanks!

2 Likes

I understand. Sorry I'm moving

1 Like