Adding OpenWrt support for Xiaomi AX3600

where did you route the cable? did you cut part of the plastics?

It fits because those plastic strips are flexible.
One option was to glue it, like it's in the previous photo, but for now I left it hanging out like in this photo:
(I did change the pinout order to be compatible with my USB/TLL adapter pinout.)


Hello guys, tell me in the radio settings you can somehow select the number of streams, the chip specification supports 6-stream. In the status of the wireless interface, for some reason, it always shows only NSS-2, what setting should I use 4 more?.

Where have you seen that 6 streams are supported?

2.4G should be 2 stream only while 5G should be 4 stream if up to and including 80MHz is used.
AFAIK there is no way of selecting/forcing the desired number of streams

You are right, here is the link to the description

IPQ8071A

Well, yeah its 6 streams max best case scenario for both bands combined

Channel width selection 80 + 80 MHz, no longer supported?

It should work, worked before

There is only a choice of 20/40/80/160 in the settings, maybe you can set 80 + 80 directly in the configuration file? "/etc/config/wireless"

How do you think to include support in the ath12k driver, support for IPQ 8074 ?

I use my AX3600 with dualbooting official firmware and one of Robi's and others firmware.

Lot of months ago there were problems with sysupgrade: it upgraded successfully but then the new OpenWrt had a bootloop. As an extra, OpenWrt's failsafe mode wasn't usable (at least without serial access). :upside_down_face:

I just kept it bootlooping, and once it switched to the other partition and original firmware booted.
I was able to reproduce this partition change more than once, but sadly it's not too reliable. It doesn't always saves you from TFTP recovery. :confused:

1 Like

Here I also let it boot loop for some time, can't say how much time, but nothing happened.
I also turned power off 3 times in a row (after 2 only secs power on), to see if u-boot triggered something, but nothing. I can try this again now that I can see what is happening with uart.
I also tried some button combinations, I could trigger TFTP has expected.
Openwrt failsafe can't help to recover from a kernel panic (that I had).

1 Like

I can control 5 led with luci and give them individual functions. What is the problem?
Iirc I had to add one led to the default config to control it. The led name is blue:aiot

So after you said 5, I went back and looked at the dropdown and some way missed the "blue:aiot" when trying to shut off the "IoT" antenna LED.

I had created one to turn off whatever the "ath10k-phy0" is and was thinking that would be the antenna LED. OOPS! Do you know what that's for? I'm thinking the ethernet LEDs but didn't bother looking as my unit is sitting on top of a high cabinet and I'm lazy. :slight_smile:

THANKS for the response! :slight_smile:

1 Like

Not really. It is a gpio of the ath10 chipset, but if there actually is a led connected to it somewhere I dont know.

@robimarko I just stumbled upon this patch on ath11k:

[PATCH] ath11k: update missing mumimo and ofdma stats

As I am not an expert on debugfs, do you have an idea how these stats can be read/polled?

You can just cat them out of /sys/kernel/debugfs/ath11k per PHY, debugfs is nothing special.
But that patch is not merged yet as it was sent yesterday

Hello, tell me what link is this patch ?, also interested.

Hint is there a listing of frequencies depending on the selected country?. It is not possible to change the Country in the radio module settings, can there be a source file where there is a table of frequencies and power depending on the selected country?

1 Like

https://git.kernel.org/pub/scm/linux/kernel/git/kvalo/ath.git/log/?h=master-pending

Just FYI:
An interesting patch was committed to the ath11k repo (awaits reviewing/merging) that could help us with ath11k memory usage, especially over time:
https://patches.linaro.org/project/linux-wireless/patch/20220506141448.10340-1-quic_akolli@quicinc.com/

It wont help even a bit, cause if you read it, it only reuses the memory on firmware reload like during coldboot (Which is disabled as it does not work)