Adding OpenWrt support for Xiaomi AX3600

I don't think that will work as opkg fetches them as direct links, hence why HTTP directories work best

Many repos for kodi addons are hosted on github too. You'll just need to set the url to the github raw site

Hm, that sounds interesting especially since its free.

https://github.com/Tolriq/repository.yatse.kodi look at this for example.

i tried this yed. My device is getting an ip adress form the TFTP Server but then die netwirk connection goes down - i do not know why.
And so long i did not manage to interrupt the boot process so that i can connect via intrams. I can enter the failsafe mode, but this is no use when you have problems with the bootloader

Did some extra digging and it seems that issue with WoL is actually connected to the fact, that ethernet connection is only working in 1000Mbps mode. Tried two devices and on both of them changing speed & duplex to either 100 or 10 Mbps mode resulted in broken internet connectivity. Both PC & router still reports that link is up but there is no internet connection at all and I was wondering if it could be something similar to this issue. Could someone else confirm that issue perhaps? I

Beside that issue, it backport branch seems to be quite stable - I'm using IoT antenna for IoT devices (7 of them) & on main network there are period of time when no devices are connected at all. At some point, router had only 44MB of free memory but I wasn't able to reach OOM state after 7 days of usage

Pushed some more FW stats and regulatory backports

6 Likes

@robimarko could you please add kmod-wireguard to your release (or better full support for wireguard server)? Thanks for your work.

Did any of the backports solve your Poco F2 disconnect/reconnect problem?

It wasn't even the backports fault, it's the stupid QCA switch driver using hardcoded DTS values for how to set up forwarding.
I was using one of the LAN ports in DHCP client mode for uplink but since its isolated with the LAN bitmap the WLAN interface didn't have an uplink and then Poco F2 would reconnect due to "No networking" every couple of seconds, now it works fine when using the dedicated WAN port

1 Like

I had it setup just as a dumb AP connected to my main gateway through one of the LAN ports and got the disconnect bug when connecting to the 5GHz AX radio, the 2.4GHz AX radio seems to work more or less fine.

Yeah, I had the same setup and both 2 and 5GHz radios did the same thing, its due to f*cking QCA switch drivers not using DSA but that hardcoded hackery and then it doesn't forward properly as only the WAN port is allowed to forward directly to the CPU

Sorry but what was your solution?

Connect the uplink to the WAN port instead of the LAN port?

Yeah, just use the WAN port(I know its a stupid limitation)

1 Like

Do you need to change any firewall settings or anything else?

I usually have the firewall disabled on a dumb AP.

You can disable the firewall completely or allow everything under the WAN zone.
I also usually just utilize the br-lan interface with DHCP client enable to run my AP-s as that gets rid of FW completely.

2 Likes

To answer you, I won't add anything that is not necessary, I am not aiming for one build fits all.
It's just to make life easier for people and provide some prebuilts.
Otherwise everybody will want something and we will end up with a mess.

I looked into providing prebuilt kmods in a feed, but that's a whole new level of pain for the QCA drivers as those check for kernel options and for example the bonding support will be built as a kmod and then NSS clients will fail as they want to compile more code etc.

5 Likes

After changing my config as to how you described, moved WAN port to br-lan and connected my AX3600 as a bumb AP to my gateway through the WAN port, I still get the disconnects every few seconds on my Poco F3.

I didnt move to it br-lan, that what I usually do but I dont think it will work here.
Just try using the default config, plug into WAN and start an AP as see if it still reconnects

Hello all,

Has been a while I didn't follow what was up here, las time I tried a build the main problem blocking me to use the build as a production build was the mem leak. Has this been solved? If so I will take some time to start trying again a new build :slight_smile:

Anyways huge thanks to all the devs and especially robimarko for the intense work on this platform!

Cheers!