Adding OpenWrt support for Xiaomi AX3600

OK thanks.

I asked because I have another dual rootfs partition router which sysupgrade only upgrades the rootfs partition and I could keep OEM firmware on rootfs_1.

The upgrade script must have been modified for the IPQ807x target.

Hello,
first of all, thanks for all the hard work done so far - I've flashed AX3600 few days ago and since then, I'm using it as my main router. So far it seems to perform really decently but I noticed one issue, which I hadn't before with Archer C7V5 with 19.04 OpenWRT - namely, wake on lan refuses to work on my end. Did anyone else had such issue with latest backport branch?
Thanks in advance!

I am a bit sad as 5.16 will contain a lot of ath11k stuff that we need. I wonder how soon Hauke can do some backporting. Among the many things, 160MHz is also in that set of patches...

I can tell you that Hauke won't do any more backporting, they set the 5.15 backports as the target for the next stable and you will only see point updates.
That doesn't mean that we cant just backport whatever we need

2 Likes

Yeah, this tends to happen when thinking about something else and typing fast.
Fixed it now, thanks.

1 Like

Do we need to wait until 5.15 lands in Owrt, or the two things are not related?

No, they are completely separate.
The backports only backport wireless drivers which is great when they are newer than the available kernels in OpenWrt but kind of loses sense otherwise.
It has a great side-effect off all targets using the same wireless drivers regardless if they have or haven't been ported to a newer kernel

The patches seemed to have totally solved the disconnects on the affected Xiaomi phone.

Thanks

1 Like

I recently noticed a lot of "nf_conntrack: nf_conntrack: table full, dropping packet" and I can also see that my Active Connections are at 95%. I noticed that 2/3 of the connections are pretty old UDP sessions. Can it be that we are missing a reasonable timeout value somewhere and these sessions are not dropped for some reason? As there is really no reason to keep all these open.

Just saw that Blocktrron had pushed an updated qca-nss ssdk v11.4-csu1 and a ath11k firmware
WLAN.HK.2.5.0.1-01192-QCAHKSWPL_SILICONZ-1 v2 over at:

We use the ones in ath11k-firmware repo so we need to wait for the QCA guys to upload them.

Non the less, we can start testing it now :slight_smile:

I loaded it, and so far so good. Both radios work as they did with previous versions.

@dchard I really have no clue how the QCA hackery is supposed to work, they hacked the networking part really badly.

Maybe Transmission is not closing sockets properly, as even after a standard systemctl stop, almost all sessions remain. I might try to dig in to the stock fw to see if we are not missing any sysctl parameters.

Just for reference, this is on my main router

(19 days uptime)

have the same problem :sob::sob:
But on mine I'm completly unable to interupt boot, it's not waiting even 1 second... was It the case for you ?

Have you had the AX9000 running for any length of time with ath11k connected ?

I'm wondering what the memory usage on that tops out at. The more I look at what we are seeing memory usage wise the more I'm thinking it's "normal" behaviour.

Not lately, last "long" run was around 12 hours or so and the memory was really stable

On my AX6 I tried the method shown here since they're almost the same router https://openwrt.org/inbox/toh/xiaomi/xiaomi_ax3600#tftp_recovery
but it doesn't seem to work (see attached picture: the last line is repeating and incrementing itself forever)...
Can someone help me please? maybe @robimarko :bowing_man: ?

P.S sorry for taking a picture, I only have a MAC and was running a live ubuntu on my little sister's comupter can't do better for now...

Looks like there isn't a linkup on the networking port, I doubt your router/switch is 10Base-T only