Adding OpenWrt support for Xiaomi AX3600

Later I'll reset , settings, and try to update the image with the latest change "mac80211: ath11k_nss: reduce tlv to 2k SKB"

I can't repro without the current configuration.... no idea of what you are using? special wpa thing? wifi5 devices

Sometimes, after we flash new FW, the old FW is still there and the new one didn't got flashed, it's an old bug.
So after you flash you need to keep track in status page if build changed.
Firmware Version OpenWrt SNAPSHOT r0-a9f87ed / LuCI Master git-22.137.71281-d6dbedd
New latest build:
Firmware Version OpenWrt SNAPSHOT r0-8e0d1de / LuCI Master git-22.137.71281-d6dbedd

A vlan comes to the wan port, which is bridged with a wireless interface, wireless clients receive an IP address from the Mikrotik Bras. Normal wpa2/wpa3 encryption

Finally want to get my so far unused ax3600 from the basement.
Has anyone a source for ax wifi cards (non intel) preferably somewhere shipping to europe?

Ok guys, since upstreaming is taking some time I finally made a branch that is focused towards making a OpenWrt PR using stuff that is upstream or in process of upstreaming.

So, most of the driver code has been rewritten and some we finally got rid of some nasty hacks and gained some new features like exposing the remaining PMIC regulators, PMIC GPIO-s being exposed, SDHCI controller is now being reset to get rid of bootloader config that sometimes leads to timeouts, clock driver now uses GDSC-s for USB power gating, APSS clock driver now utilizes parent data and many other things I probably forgot.

The branch is here:

Github is already building it, and this will be the only branch that will get any attention.
Feature-wise, there shouldn't be any regressions.
ath11k will also get remaining patches backported, and QMI helpers will be part of backports soon.

Like always, testing would be great.


Hi there,

finally tried the build from robimarko r0-0e7870d ipq807x-2022-05-16
and found a strange behavior:
I configured the radio2 (channel 11) to connect via mesh, static ip; disabled firewall/dnsmasq/odhcpd etc. so standard dumb ap config.
Every client which is connected to the ax3600 can‘t reach a dns server or my main router via dns.

nslookup (main router) —> connection timed out; no server could be reached
but ping is working and every connection i open via ip.

Possible driver is not ready for mesh?

Hmm must be something with ipv6 as on the ax3600
ping doesn‘t work but
ping -4 does. And i don‘t have/use ipv6

Did you manage to run the patch to get the data?

Mesh works perfectly out of the box. I've this version installed in two AX3600 using mesh without problem.


If and when Robi pulls it to his repo, I can take a look. Why?

no issues found with this release so far ...

I have updated all my three mesh nodes into this snapshot. Everything works. All I miss is the support for gre or batman support. I have managed to build a built but I have not got the confidence to use it yet..

How would I go about using the whole storage of the ax3600 and not only the 30mbs available now?
Is the uart method recommended or is it dangerous?
Will it ever be possible just by the build or will it always require uart?

@robimarko the 5.15-pr branch works fine, no change in performance.


Awesome, nice to hear that

1 Like

80MHz 2x2 AX I can get 750Mbit on my phone (single thread Iperf3 on the router), no CPU bottleneck. On the uplink however I need 6-8 threads to get 500Mbits... Single thread uplink yields around 200-250Mbits.


I tried to established a connection on 160Mhs bandwidth, but without success. On AX3600 If I put channel 100 with 160Mhz the wireless does not start. On channel 48 with channel 160 MHz starts fine, but client, a laptop with AX210NGW card does not see it. What settings should I put to have 160 MHz. With 80 MHz both channels starts ok, and connection could be made from laptop.

Try setting country to US in all radios, that works for me.
After changing channel, sometimes it takes 30secs to 1min for the SSID to show up, could be because of radar detection, I don't know.
If that works, try your country.

From what I had read, AX210 auto selects it's country, so also see what is allowed.

The Intel® Wi-Fi 6E AX210 module detects its location and automatically optimizes the Wi-Fi settings to local regulatory requirements, maximizing performance in each geography, simplifying travel experience and global enterprise procurement.

I can't and could never select channels 12-13 in 2.4Ghz, selecting EU countries.

i'm using 160Mhz on channel 100 with an AX210NGW and it works fine.
2401.9 Mbit/s, 160 MHz, HE-MCS 11, HE-NSS 2

Did you wait for DFS ?

Putting the Country to US made the router visible from laptop. Before was Driver default.
Thank you

1 Like