Adding OpenWrt support for Xiaomi AX3600

Currently, I don't think that there is any SoC with built-in AX radios except for the QCA products.
Everybody else is just reusing older SoC and adding a PCI based cards (Only Mediatek and QCA PCI cards have AP mode)

So not really the best time for all of us it seems.

Where is this offloading functionslity? Is it part of the wifi card, the Ethernet or the actual SoC? So if I would just combine any application processor with a sufficient amount of pci elanes with wifi and eth, would it come with offloading or not?

Sorry for the annoying questions, but not happy with stock mi fw, looking for an alternative...

@robimarko Do you think the ax3600 can do gigabit Ethernet without NSS/ECM?
If yes it would still be a good choice!

The famous Belkin rt3200 router is basically fully supported, but the Wi-Fi signal and coverage is really really bad. In particular if you compare it to the ax6/ax3600.

The offloading is done in the 2 UBI-based cores that run custom firmware called NSS firmware to which the whole mess of drivers interface to for offloading.
So it's part of the SoC.

It should do 1Gbit for sure without offloading.
RT3200 is just reusing the old MT7921 with an MT7915 PCI card, that is the reason it was easily supported.

2 Likes

I thought that the mediatek would be better for coverage and opensource because the 2.4g radio is a 4x4 which can compensate for the usual poor performance of opensource project drivers...2x2 performance probably acceptable only with oem firmware

Nope unfortunately coverage is really poor.

Must be the internal antennas...that will be a very good reason for choosing the new redmi ax6s (mediatek + external antennas)

Hi!

I installed the latest firmware (8cddba9) from robimarko (to whom many thanks for his efforts!), and encountered a strange problem, it seems, with ARP or smth like this. I haven't tried the previous versions btw.

I have 2 access points on the same LAN, in a common l2-domain. The second is the AX3600, which I testing.
When I switching wifi-clients (laptop or phone) from main AP to AX3600 with robimarko's owrt, there some time period, during which I can't access any resources in LAN behind AP. I can ping/access only AP itself, but no any other IP in my LAN. So the client even can't obtain DHCP settings, because my DHCP server is not on AX3600.
After few minutes connectivity returns by itself, and everything starts working.

If I reconnect client to the AX3600 again (just turn off and on Wi-Fi on laptop or phone), everything works immediately.
If I reconnect from AX3600 to another AP, everything works immediately.
But if I reconnect from another AP to AX3600, there is temporary problem with connectivity again.

I tried to replace AX3600 with another AP (the third device is at my disposal), everything works fine everytime, so somehow the problem is related with AX3600.

Any idea what the reason might be?

Hi,

Just a dumb question: is current OpenWRT port stable enough for AX3600 to be used as a dumb AP in 5GHz .ax only? So no routing/NAT/firewall or anything, just a bridge between LAN/WLAN?

Thank goodness someone else has this problem - I thought it was a very special one just for me.

My description of the problem can be found here.

The same with me: 5 GHz WLAN and 2.4 GHZ WLAN are present. With my PC (near of the AX 3600) the connection is stable und speed is good. With my IPhone I can connect with the wlan, but the internet connection is not stable.

I use the AX 3600 as stupid AP, LAN with static IP und deactivated DHCP, die Clients get their IP Configuration from the DHCP of the mainrouter (FritzBox)

These issues are all discussed before: link

The short version: use the dedicated WAN port as uplink even if you are using the AX3600 as a dumb AP.

I thought so too when I read this and of course tried it out immediately.
I have set the lan interface to eth0 (no bridge - directly the port).

Unfortunately, the result remains the same.

It sounds like the roaming issue described at Roaming Issues Xiaomi AX3600 which has a software workaround shown here Adding OpenWrt support for Xiaomi AX3600 - #3930 by avalentin

An alternative is to enable the nss-bridge-mgr module (kmod-qca-nss-drv-bridge-mgr) which fixes this, but at present you'd need to build your own image with that enabled.

3 Likes

Thank you for the advice.
But how do I make a build with this module?
In the menuconfig I can't find a correspondingly named module (robimarkos repo at branch AX3600-5.10-restart).

You need "IPQ807x-5.10-backports" branch.

1 Like

It's under Kernel modules -> Network Devices

kmod-qca-nss-drv-bridge-mgr

Both in AX3600-5.10-restart and what I believe is the more up-to-date IPQ807x-5.10-backports branch.

2 Likes

Awesome news! This issue was a showstopper for me many months ago, even more than the memory leak. Maybe now I can finally ditch the QSDK build :slight_smile:

Thanks @ psi & dchard.
I made a build with these options but still no luck - the clients still get no network connection.

Just to be sure i explain what i did (because i'm not very experienced with building my own images yet):

  • made a complete new clone of the repo
  • checkout to branch IPQ807x-5.10-backports
  • update and install the feeds
  • in menuconfig choose Qualcomm IPQ807x and Xiaomi AX3600
  • under kernel modules i enabled kmod-qca-nss-drv-bridge-mgr
  • exit the menuconfig
  • build the image with make -j 4

how can i check if the module is correctly built in? lsmod | grep nss gave me only these:

qca_nss_dp             45056  0
qca_ssdk             1667072  1 qca_nss_dp

Have you tried just connecting to the WAN port instead of one of the LAN ones?