Adding OpenWrt support for Xiaomi AX3600

Huge thank you @Apache14 , @gmzhuo , [@]efsg for your work!

I wanted to ask how is the throughput between the WAN and the LAN can it do 1Gbp/s or close to it with the current status of the firmware? Can someone test this?

My main point is - are we going to need some sort of fast-path routing or the driver is good enough to handle this on the interface/hardware level.

Thanks.

Think when things will be sorted out... Nss offload will just be enabled with custom firmware (due to the work we had done on ipq8064)
But yes I'm also curious about how much traffic can handle the CPU alone

You know there's a PMP8074 on AX3600, I'm not sure if the bootloader will shutdown the power for QCN5054 or any other module in SoC.

I did a reset of my modem and now lost the ssh.is it expected? I had 1.0.67 patched one.

A reset-to-factorydefault may trigger a Switch from Flash A to B, which would remove the patched fw. Don't know for sure.

hi everyone, I run into a small issue....
So I finally got (after 3 months, yes) the router.
I followed the instruction from Xiaomi AX3600 install guide completed all the steps and got to the Chinese luci interface. only thing I changed in the interface was the locale (from china to Europe) but then, since when connecting the internet cable to the router it wasn't connecting, I rebooted it.
On reboot the device is basically briked: the front light is red and blink once every 10 sec and the ethernet comes up for 10 sec and then disconnects(no ip get assigned). No wifi.
I tried to hold the reset button for 30 seconds, unplug and replug, use a static ip to connect etc.... no luck. No SSH or Webui
Anyone has any idea?

try connect via ssh and sysupgrade. not WebGUI. It seems LUCI is broken.

no, loss of SSH is not expected.

when you had SSH, did you check whether the patched firmware was correctly installed by checking for zero-sized binaries?

no connection to the device is possible.

no, I did not.

how do i do that. Now im back on version 17 and got the ssh access. verified in putty. If i upgrade to 67 (patched) what i should check ?

last time after upgrade i had ssh... just after factory reset. lost it. I did factory reset through webUI.

I know there are lot of work happening to get openwrt working on this device. In the meantime, is there a way i can install the adblocker alone in this device ?

I used to have asus merlin and loved the adblocking option there.

After you flash the patched version and rebooted, you can check for the patched files to make sure it is zero-sized, like this:

root@XiaoQiang:~# ls -l /usr/sbin/otapredownload
-rwxr-xr-x    1 root    root         0 Aug  6  2020 /usr/sbin/otapredownload

This makes sure that you are using the patched version, and not the stock 1.0.67 firmware.


Got back my serial adapter, got this error.... someone can help?

Back to miwifi

Hi folks,
My router is currently with firmware 1.0.17 and I want to test 1.0.67 and the 160Mhz support added back in 1.0.50.
If i do that can I easily downgrade back to 1.0.17 or any other version that you can get the ssh access without the need of serial adapter?

So, after messing around with u-boot to fix the ubi error 22 in the previous post I had power outage while editing the ubi partition.... as some of you guessed I'm now the proud owner of a dead AX3600. with the only chance of turning it back to a router being some soldering sheningan with the flash chip.
therefore, unless someone has suggestions, my fun with this router ends here.

Did you try to use the Xiaomi repair tool? I suspect it works via early boot to recovery the router but havent tried it:

http://www1.miwifi.com/miwifi_download.html

I suspect that could have been helpful before I erased completely the firmware.
but I'll give it a try! thanks!

edit: it doesn't help with a completely erased firmware.

Since ignorance, some of this could not solve your problem? the same you can directly load the firmware on the ROM chip

ROM