Adding OpenWrt support for Xiaomi AX3600 (Part 1)

Same thing happened to me, I don't know why, but after recover I was able to flash the last version a38982e without issues.
After having the last version installed, I even went back and forward in versions and the issue didn't happen again.

I wish somebody captured the sysupgrade log cause its so weird, the recipe changed only in the latest version.

Personally have been switching through various branches daily and it just works

1 Like

Maybe someone can have it on just in case, before flashing that version for the 1rst time.
I'll leave it on next flash, but this never happen before, so I'm not expecting that it happens again.

On a different subject, is there any use for ax3600-squashfs-factory.ubi? Now we use ax3600-initramfs-factory.ubi to install from factory.

Its just a normal artifact from UbiFit, can be useful and there is no point in changing the generic recipe to drop it

1 Like

I can confirm that the update from the two-partition version (with new interface names) to the new single-partition version worked without any issues. I import my previously saved config (as version 2.0) also without any problems.
Very nice!

Uwe

When flashing openwrt for the first time or after tftp recovery, we are in xiaomi FW with Chinese screens.
I had taken some screenshots translated to English with google lens, maybe they are useful to some else.

Translated Screenshots

1.Uncheck join user experience and press big blue button:

2.I only had the router connected to my computer, not to my LAN, so press the smaller white button continue, bellow the blue one:

3.Select the DHCP option:

4.Select you WIFI password and the option to use it as ADMIN password:
(can't remember, but I think password needs to be 8 chars or bigger)

After pressing next button, you need to open the router web page again, login with the password and start the steps from obtain_ssh_access in the wiki or in Robi commit.

2 Likes

Hi,

I've flashed OpenWrt successfully on my device using this image:
https://github.com/robimarko/openwrt/releases/download/ipq807x-2023-01-02-1602/openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-factory.ubi

How do I configure the WiFi radios right? Do both AX and AC radio0/radio1 need to be configured to the same channel or should I use two different channels?

btw: Can I use VLAN tagging - I don't see any switch but the TOH wiki states the device supports VLAN (?)

image

Thank you.

Kind regards,
Catfriend1

Same problem.
I've been flashing all Robimarko images, had no problem with the migration to single rootfs, but this last sysupgrade bricked my router.
Had to debrick with tftp (the first time I had to do it, also only worked on lan3), gained ssh, after that followed the last instructions and flashed the last sysupgrade with no problem and restored the last config.

Weird it's bricking a lot routers.

The screenshots won’t help me but the hint I can use lense to translate text on pictures will. Never occurred to me. Thanks!

1 Like

I only use radio1 (for AX, 4 x 4) and radio2 (for 2.4 ghz, 2 x 2) for general internet and radio0 for my IoTs only because it's only 1 x 1 antenna and not good for speed.

I use DAWN for band steering

1 Like

flashed today build a38982e without any issues

1 Like

Also brick an AX3600 with "only" an sysupgrade from [Updated prebuilt images 2023-01-07-0009] to [Updated prebuilt images 2023-01-09-2026]

I was able to update my AX3600 today.
I came from a two-root-partition version from about 3 months ago.
For this i compiled a image from robi´s branch ipq807x-5.15-pr-final yesterday.

I proceeded as follows:

  1. push the ...-initramfs-factory.ubi to the device via scp
  2. flash this file:
ubiformat /dev/mtd12 -y -f /tmp/openwrt-ipq807x-generic-xiaomi_ax3600-initramfs-factory.ubi -s 2048 -O 2048 && fw_setenv flag_boot_rootfs 0 && fw_setenv flag_last_success 0 && reboot

(or mtd13 if fw_printenv flag_boot_rootfs returns 0 instead of 1)

  1. connect now to 192.168.1.1 (the default ip in factory state) and push now the ...-squashfs-sysupgrade.bin to the device via scp.
  2. flash this image via:
service wpad stop && sleep 8 && sysupgrade -n /tmp/openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-sysupgrade.bin

Now my device is updated to the newest version with resized single root partition.
I was also able to restore my old config.
For this i take a backup file and changed the interface names in all files inside as explained above. Then i set the compat version via uci set system.@system[0].compat_version="2.0" and was able to restore the backup via luci.

Maybe my procedure will give some clues to those who have broken their device.

3 Likes

Unfortunately no.
My AX3600 was already with new unique partition and one version from 4 days ago !

Most of reports are for sysupgrading between latest Robimarko's releases.

I did upgrade from [2023-01-07-0009] to [2023-01-09-2026] and ended up with bricked router.

1 Like

Another brick on the table here. I extended the partition from a early dec robi release with 0901 release and ended with an brick. The extention part worked nicely but the sysupgraded machine never woke up.

After tftp recovery, initramfs and sysupgrade everything ok.

Same thing here, already had migrated to single partition in 2023-01-05-2313.
Used the same procedure that @slyvan uses, it was documented by Robi.
I didn't stop wpad, because radios are already off from initramfs-factory boot, but that's not relevant.
Then I had sysupgraded to all the versions released with success, until the last one issue.

Is clear that something is happening, because all the reports are from people with robi single partition doing a simple sysupgrade with a robi single partition firmware.

If someone plans to upgrade and has serial connected, will be great. Some log is the only way to take enough info to see what is happening.

1 Like

So i updated from [2023-01-06-2152] to [2023-01-09-2026] yesterday and had no problem, i even kept the settings as i already changed the interface names ...

1 Like

This is getting quite crazy, as there was no sysupgrade changes until the version from January 9th, and since you are sysupgrading to it any recipe changes arent used anyway.