Adding OpenWrt support for Xiaomi AX3600 (Part 1)

Session cookies acting up, that's purely browser side. Clear cookies, use a different browser and/or incognito mode. Not related to this build or ipq807x in general, just the browser still thinking that its old cookies were still valid after the sysupgrade/ reboot of the router.

Fine, looks like Luci error :smile:
RPCError · Issue #6078 · openwrt/luci (github.com)

1 Like

To move from my version to latest @robimarko you have to replace "eth0" with "wan" and "eth1" to "eth3" with "lan1" to "lan3" in all files:
find etc/config -type f -exec sh -c "cp -a {} {}.orig && cat {}.orig | sed -r 's/\beth0\b/wan/' | sed -r 's/\beth([1-3])\b/lan\1/'>{}" \;

FYI: @robimarko changed eth names before extended partition so device compat version history was 1.0=>1.1=>2.0, while in my version - 1.0=>2.0
But since @robimarko version will be in official trunk I suggest to rename manually and leave version 2.0

2 Likes

was just wondering , is the ax3600 capable of using the 160mhz channel on 114 ? (100-128 ) cause if i try it says device not present in owrt its kinda strange ( using robimarko port)

I tried to flash with the lastest image - but the AX3600 is bricked. Failsafe does not work. The LED is orange. I think I have to try to flash per tftp. Do I have to take the Stock Firmware from Xiaomi or the openwrt *.ubi ? I have the newest updates with one partiion and that worked until I wanted to flash the actual image from yesterday

You need to use the Xiaomi firmware for TFTP recovery as far as I know.

robinmarko thank you for your work, i have already donated. I'm doing some test and i have some problem with the wifi6 speed test.
SWOFFLOAD ON
PACKERSTEEREING ON
GRO OFF (probably, i dont know how to turn off/on)



i dont understand why the iperf3 result on wireless 5g 160mhz is so incosistent.
The channel used i 48mhz

which name must this file have ?

You need to assign the router an ip 192.168.31.2, then the file name should be C0A81F02.img

see: https://openwrt.org/inbox/toh/xiaomi/xiaomi_ax3600#tftp_recovery

1 Like

thank you. the C0A81F02.img is the openwrt *.uib file ore the xiaomi stock firmware ?

I was using Xiaomi factory linked in the tftp instructions, then converted to OpenWRT later after SSHing. I dont think it would work with the latest image from Robert since its a single partition image.

I recommend to flash Xiaomi, gain SSH, flash openwrt-ipq807x-generic-xiaomi_ax3600-initramfs-factory.ubi image, reboot, then from initramfs image flash the final openwrt-ipq807x-generic-xiaomi_ax3600-squashfs-sysupgrade.bin. For best success disable all wifi, use cable and disable wpad service (service wpad stop) before flashing sysupgrade image.

I was following the instructions from this commit: https://github.com/openwrt/openwrt/commit/e53a85e52545bca53609108be2d4b3807c60b014

1 Like

If I understand it correctly,
when you release a new fork of yours, we just have to upgrade it and start with a new config to avoid the issue with the names?

I am so happy to see all the progress you guys all made here.
At first I had a small buyers remorse because there were no Openwrt etc. but seeing post by post the progress here made and now this.
It is just awesome.
Really the only drawback AX3600 has is that it is missing a USB Port..

Bricked mine as well. Debricked using instructions in https://openwrt.org/inbox/toh/xiaomi/xiaomi_ax3600#tftp_recovery. Took me couple hours to figure it out. I had to use LAN3 port on a router.

Isn't that weird that there are so many brick reports for last release?

1 Like

There is a massive warning at the bottom for Xiaomi devices that were using out of tree builds, most people just don’t read and jump right to flashing.

@robimarko is there a reason not to keep the comp version at 2.0 in the PR?

Fully acknowledge that it’s an out of branch build so once merged its “new”, but given how many people have your prior builds running, it’s probably best safety/user experience measure with no downside.

Honestly, unless following this thread very closely, most people wouldn’t think to read the specific device’s commit log once they’re “already on OpenWRT.”

Yes, its currently out of tree and there is no reason why a compat version should be set in OpenWrt as the board was never supported

Yes for sure you can upgrade without "keep seеtings". And if you want to use old backups you have to modify them.

1 Like

Could you help me understand why flashing the a38982e for AX3600 broke the router? How would I check if future versions allow sysupgrade or not? How to solve it to avoid the orange LED and the need to restore everything from the beginning?

1 Like

What version did you had before you flashed a38982e?
Did you only flashed the pre-build images from Robimarko repository and never any others?

I flashed all versions one by one and they all worked. The last one is ef42fc4 and now I'm back to it after restoring everything from the beginning.

PS I flashed only Robimarko images.

1 Like