Adding OpenWrt support for Xiaomi AX3600 (Part 1)

Thank you, it was an issue with channel alignment.
First, I have disabled AP and connected with the client, then I have edited the channel of AP to the client's channel, then enabled AP. After that, it worked! :slight_smile:

The latest version works pretty well. Wifi is rock stable for me. There are 2 issues that I have noticed:

  1. Local DNS: Sometimes, It can not resolve the name of a device on the LAN, but I can still access the device by IP. Maybe I'm doing something wrong, I didn't dig myself into this issue.
  2. Overheating: By default, the wifi txpower is set to 1Watt. With that, when I download a file from the NAS with 800Mbit/s, then it quickly overheats and starts to throttle. The throttle manifests in freezing wifi for a few seconds, which is very annoying. However, if you reduce txpower to 100mWatt, then the wifi can endure any load. It would be cool, if there would be a power management system, that would reduce txpower intelligently based on temps instead of freezing the whole wifi, but for me, 100mW tx is enough to cover the apartment.

guide: use image from dimfish (if you prefer), while following:

I have used sysupgrade with keeping configs in luci and it worked, but currently, you need to flash the same image twice in lucy, until you actually boot into the upgraded firmware.

1 Like

Did anyone test "bridger"? It seen it can improve CPU usage when doing lan transmission stuff.

Apologies if this is off topic but has anyone had ath11k working on a IPQ6018 based board?
I have the board crashing when installing the driver (no kernel messages)
Last log messages:

[  260.081983] ath11k c000000.wifi: qmi bdf download req fixed addr type 0
ath10k hot plug board = qcom,ipq6018-cp01 FIRMWARE = ath11k/IPQ6018/hw1.0/cal-ahb-c000000.wifi.bin 
ath11k hot plug board = qcom,ipq6018-cp01 FIRMWARE = ath11k/IPQ6018/hw1.0/cal-ahb-c000000.wifi.bin 
[  260.164286] ath11k c000000.wifi: boot firmware request ath11k/IPQ6018/hw1.0/cal-ahb-c000000.wifi.bin size 65536
[  260.165318] ath11k c000000.wifi: qmi bdf download req fixed addr type 2
[  260.176233] ath11k c000000.wifi: qmi caldata type: 2
[  260.181574] ath11k c000000.wifi: qmi BDF download sequence completed
[  260.186800] ath11k c000000.wifi: qmi m3 info req
[  260.193258] ath11k c000000.wifi: qmi firmware ready
[  260.197691] ath11k c000000.wifi: qmi wlan mode req mode 7

Using WLAN.HK. firmware
Any pointers of what to check or where else to post greatly appreciated

Is anyone having trouble building an image due to xxd not downloading? From what I read we need xxd for u-boot and there's a work to replace it with pearl script though I'm not sure how to apply it to robimarko's repo.

That should have been resolved since

(not that ipq807x would replace the vendor u-boot anyways)

Btw what's limiting us from newest firmware? board-2.bin? Driver?


I flashed my Xiaomi With openwrt.

Is there a step by Step Guide to Go back to Original Firmware?

Do i have to Switch the bootfs?


When I find local DNS not resolving, I check the status page and find the router has just rebooted itself or the WiFi has restarted. At least for me, I built the kernel with support for StrongSwan IPSEC. If a device attached to the VPN tries to roam via MOBIKE the router immediately crashes every time and reboots. Haven't looked into that one, yet.

The router definitely seems to overheat at 1W. However, I've ran it for a few days set at 750mW without any problems. I'm not sure what the device is actually rated for.

@robimarko might want to rebase or pull this one, as this prevents newcomers to build it.

Both the latest ath11k fw ( and 01744) give an exception (with the latest BDF). Can't say if BDF it's part of the problem or not.
The latest BDF ( works with the older fw ( that we use.


They really should make bdf files into text files just like broadcom... I'm working to make my QCNFA765 card work under linux, however there aren't correct bdf for my card(it was torn down from thinkpad t13?). When i tried to merge bdf extracted from windows driver into board-2.bin, it always report bdf download out of time(-110). However rename any of the original bdfs inside to support my card always works. I've sent email to Kalle, wonder if he could help with this.

Someone now to get openwrt to Boot Stock Rom?

Via fw_setenv flag_boot_rootfs it does Not work. See Screenshot:

You have certainly not followed guide not as you have installed LEDE :confused:
Just use search button for recovery ? There is tens of posts how to recover. Use MIWIFIRepairTool (tftp) with an official firmware and you are good to go. In this thread is explained everything (or just use google). I have recovered even with "altered" partitions with this tool.

I don't believe that you have on rootfs 1 or rootfs 0 installed original FW.

1 Like

Will do it tommorow, I was travelling for ELCE in Dublin this whole week


I updated to the latest prebuild image, one small problem found. One package I have used, stopped working:

Unknown package 'luci-app-statistics'.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency collectd for luci-app-statistics
 * pkg_hash_check_unresolved: cannot find dependency collectd-mod-rrdtool for luci-app-statistics
 * pkg_hash_check_unresolved: cannot find dependency collectd-mod-iwinfo for luci-app-statistics
 * pkg_hash_check_unresolved: cannot find dependency collectd-mod-cpu for luci-app-statistics
 * pkg_hash_check_unresolved: cannot find dependency collectd-mod-memory for luci-app-statistics
 * pkg_hash_check_unresolved: cannot find dependency collectd-mod-interface for luci-app-statistics
 * pkg_hash_check_unresolved: cannot find dependency collectd-mod-load for luci-app-statistics
 * pkg_hash_check_unresolved: cannot find dependency collectd-mod-network for luci-app-statistics
 * pkg_hash_fetch_best_installation_candidate: Packages for luci-app-statistics found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package luci-app-statistics.```
1 Like

@robimarko Package "libwolfssl-cpu-crypto" need to be select, no more "CONFIG_WOLFSSL_HAS_CPU_CRYPTO" flag

1 Like

collectd didn't build in latest snapshot, there are some errors (see compile.txt):

1 Like

Indeed. All is working fine (AFAIK) with libwolfssl-cpu-crypto, but it's way too soon to tell... just compiled and flashed a few minutes ago.


There are changes in wolfsslcrypto with this commit

so echo "CONFIG_WOLFSSL_HAS_CPU_CRYPTO=y\n" >> .config used in github workflows isn't working anymore.