Adding OpenWrt support for Xiaomi AX3600 (Part 1)

Can't wait to test it, when its done :slight_smile:

Building your latest mods now.

It's gonna take a while, managed to sort out the clocks so far but I ain't merging the mess that the patches in target and for packages are currently.

Finally got around to adding the NSS crypto package though, but the benchmark tool it comes with is still broken.

1 Like

I've tried adding the value "\n" to the end of the lines as you indicated, but it doesn't seem to force the package to install...

here i'm sharing build file:

any ideas?

isn't one supposed to run update/install the feeds after updating .config ? try to move the step "Generate config for IPQ807x Generic" to the step before updating the feeds

I don't see for instance "speedtest-netperf" on the download step

No, you run the feed scripts before menuconfig/config

So, if it is properly inserted, at the beginning, what is the problem that it doesn't work?

thanks for the support!

It would be good to add a step that will cat .config after make defconfig is called, then you can see the final config

you need echo -e to use escape characters

I suggest taking a step back and getting back to the basics.

Optional Steps:

  1. Compile without wireguard. Copy the firmware somewhere and label it.
  2. Compile with wireguard. Copy the image somewhere and label it.
  3. Compare the two files... e.g. file sizes (wireguard one should be bigger).

All of this to say, if the compilation went fine, it's more than likely that you're hitting the "multiple tries to flash" issue. So:

  1. SSH into the router and give command /etc/init.d/wpad stop
  2. Upgrade the firwmware
  3. Reboot

By stopping wpad I've been successful at updating firmware on 1st attempt every time.

good point use cat at the end of defconfig. here i have the final config and surprise, not included any of the values i'm trying to install:

@r3pek I have added echo -e but seems that it0s not working neither :frowning:

I have a running configuration, you can use as template or cloning and adapt it to your needs.


I have a similar fork to build only for AX3600 with wireguard (without openvpn) and it's working.
I just started a build with the "cat .config" to confirm and I can actually find the packages added (using the "search logs" box on top right corner...

I just realized that my layout is way more different!

root@AX3600_OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00100000 00020000 "0:sbl1"
mtd1: 00100000 00020000 "0:mibib"
mtd2: 00300000 00020000 "0:qsee"
mtd3: 00080000 00020000 "0:devcfg"
mtd4: 00080000 00020000 "0:rpm"
mtd5: 00080000 00020000 "0:cdt"
mtd6: 00080000 00020000 "0:appsblenv"
mtd7: 00100000 00020000 "0:appsbl"
mtd8: 00080000 00020000 "0:art"
mtd9: 00080000 00020000 "bdata"
mtd10: 00080000 00020000 "crash"
mtd11: 00080000 00020000 "crash_syslog"
mtd12: 023c0000 00020000 "rootfs"
mtd13: 08000000 00020000 "rootfs_1"
mtd14: 01ec0000 00020000 "overlay"
mtd15: 00080000 00020000 "rsvd0"
mtd16: 00900000 00020000 "0:wififw"

This was from following a thread I already mentioned before, and did not knew a lot of things when I did that.
But anyway, I'm using Robimarco's builds without any issue and I had once successfully used the TFTP recovery method.

@tiagogaspar8 Finally figured out how to get the failsafe properly working.
Turns out that there is an existing way to mark a package/kmod as required by preinit so it gets loaded before failsafe can be used and then you just configure the interface you want to use, I did that based on the LAN config but it may need fixing.

Anyway, its pushed and I would really love testing on as much boards as possible to see whether the interface I picked makes sense, by tradition its first LAN port.

@dchard Can you check on AX6?


You mean the failsafe? I can later in the evening.

Yeah, I just want to know whether the set interface matches the LAN1.
Cause I just choose the interfaces based off LAN network config which doesn't always mean that whatever was first there is LAN1

1 Like


I'm going to give a try to Robimarko builds, but I wonder if I should enable uart TX like described on wiki? I have 1.8V compatible FTDI 2 USB adapter.

Have updated to the new version today.
Everything ran without problems until 2 hours ago. All wifi devices have lost connection. I also could no longer get to the admin interface of openwrt.

Do you have a log?

I had to restart the router. So no luck.