Adding OpenWrt support for Xiaomi AX3600 (Part 1)

Try "iwinfo wlan0 assoclist" in commandline. I only tried with AC 80MHz capable clients as that is what I have.

Non the less, when I receive my AX card (on its way), we can do more proper tests.

MOD: between the restart and backports there is a slightly newer wifi FW, so I doubt that can cause something like this. You can always try the newer 1192 version, which is not yet in the backport branch yet.


I doubt if "iwinfo wlan0 assoclist" will show anything different than LuCI, even in latest firmware for wlan1 it somehow shows "unknown / -105 dBm" for all devices.

I also tested 5GHz AC phone (Galaxy S7 Edge) and it works without any issue, when at the same time and same place newer phone (Galaxy S10+) with AX support - does not.

I think backports branch is already using 1192 firmware. From bad92cdb57 kernel log:

[    9.554472] ath11k c000000.wifi: fw_version 0x250704a5 fw_build_timestamp 2021-09-14 06:19 fw_build_id QC_IMAGE_VERSION_STRING=WLAN.HK.

Well, you can still try older (2.4.x.x) firmwares as well, but I kinda doubt that they managed to f*ck up the AX part selectively, as BF and MU-MIMO is also present in the AC domain, and that works correctly. Most of the BDF managed functions like DPD and other RF frontend fine tunings are applied to spectrum and not to technology. The driver is also not touching the low level features of the firmware as much as I have seen, but Robi might be abel to shed some light on this.

For me backports was not working from the first releases and I understand then it was using same firmware as in restart (WLAN.HK. which there is working without any problem. So the most likely cause is something with backports.

I think MU-MIMO in uplink direction is new feature in AX.

This looks interesting:;a=commit;h=e2c4998f6dca7d9b74a8b01762040ff2c5e38fd7


Can you rebase your branch to contain it?

Non the less, his issue is crap uplink performance on AX, I dont see how this commit can fix that.

Adding to this: since I am on 1192, I am constantly seeing 300+Mbit uplink with my phone on 80MHz AC (1x1), which I have never seen before. So the uplink performance is not crap in general.

1 Like

I tried build with this patch but it does not look like it help (or I applied it wrong).

I also get very good performance 1-2 meters from router, but just one meter more and upload performance suddenly drop. For notebook with AX200 it drops to 20Mbit/sec but internet is still working.
For mobile phone it totally loses internet, but WiFi connection remains, just with exclamation mark.
In AC mode or AC client no issue with performance.

I think this problem could be caused by beamforming issues in uplink direction.

And isn't "VHT caps" about AC mode? Maybe similar fix is necessary in AX section of that script.

After installing @robimarko last prebuilt image from the 5.10-backports release channel i noticed a weird bug.
When setting up the 5ghz wifi in ax mode with wpa3 my galaxy-s10 (with ax card) is able to connect to the AP but cant send any traffic (looks like from time to time few pings to the router are working but then, nothing again). In the same time I am able to connect my mac-pro (with ac card) and everything works fine.
When changing the configuration of the AP to work in ac mode, both the mac and the s10 are working fine.

@dchard Kalle is on a patch merge spree again, since that also includes the single MSI patches I am tempted to just export everything after he is done merged and just pretty much be equal to the future 5.17 kernel


Thank you for sharing. That is exactly same issue I am discussing in all the posts above.
To confirm you could test at 1-2 meters distance from router and S10 starts working.

Problem happens only in AX router mode with AX client and some distance between them.


@Tomakava I can confirm you are right, but i think the problem is signal strength and not pure distance. on a straight line of sight i am able to go much more then 1 meter, but with 1 concrete wall and its stops (the phone doesn't disconnect, rather packet are felling, when going close to the router i get data immediately)
On my S10 the signal threshold is -56dbm and on the router its around -60/-106dbm


similar problem,
in the room with the router, my S10 works on wifi6 (there is a 6 mark)
However, when I go to the next room (the phone signal drops by one line),
I have no internet, the phone jumps to LTE.


In last build r0-bad92cd, in the 2.4GHz radio, mode AC is missing (from the web interface options), it was there before.

In 2.4GHz mode, there is no AC mode possible. Only N or AX. AC is only for 5GHz


Sounds like a good idea. That way if we find anything, at least we can complain more properly :slight_smile:


I been trying to sort of debug this by firstly rolling back the ath11k firmware to the last build before the version merge.

The result was that I couldn't even get my wireless devices to connect, they associated but quickly disconnected even when right next to the ax3600. So much worse.

I'm no pro but I think this seems due to the latest mac80211 driver stack updates or one of the the recent ath11k patches that were included but this isn't confirmed yet.

(remember that old firmware didn't support dencap offload so remember to disable that feature with old firmware)

also do all these test with security set to open just to remove another variant of the problem that could be caused by encrypt offload.


In contrast to Ansuel's response, I always used WPA2-PSK with AES. And that worked all the time.


@dchard And QCA have decided to grant your 2.6 FW wishes (PS This should be the current one from QSDK11.5)

So expect couple more updates before the final 2.6.x FW is out.


Yep, it is pretty obvious from "r6" and "00010" that this is no the final "stable" version. :slight_smile:

MOD: just out of fun, loaded it. The quick test indicates no functional difference compared to the current build.