Adding OpenWrt support for TP-Link RE455 v1

I've acquired a TP-link RE455v1 I've opened it and seems to be a rebranded RE450v3

Here the GPL code

There is someone with experience that can support me to compile openwrt for this device?

SoC: QCA9563-AL3A
flash: winbond 25Q64JVSIQ 2037
RAM: ESMT M14D5121632A
radio: QCA9880-BR4A
switch: Atheros AR8033-AL1A

I've tried to connect to the serial port but it seems to no work.
Looking the opensource code they contain re450v3 references.

The R64 and R69 are not populated, can someone explain how to enable the uart?
need to populate o short the pin?

@herrwiese sorry for mention, can you help me to add support for this model?

Good day!
can you send some pictures of the internals and the serial pins? You might want to compare the internals with the ones included in the RE450v3. Getting the device itself supported should not be that hard as the internals should all be supported by OpenWrt itself.

Now is closed and operating, ASAP take other picture

this is the CPU RAM and flash
SoC shield opened

Okay. Thanks so far. The source code looks promising, as the system itself is based on OpenWrt. Using the direct download link doesn't seem to work. I guess you have to go to and download the source code from there.

Yes, I've download it.
The .config of re455v1 have a reference to re450v3.
Comparing the .config with diff the file are same.

If I understand how to acces serial console, I can try to get the flash layout and possibly other stuff.

Comparing the pic of pcb, the chip of re450v3 and the re455v1 match except for the flash chip.
With no experience on what to check, the pcb look identical.

Okay, that's good news. As you've already pointed out, we might just need to have a look at the flash layout. Are the LEDs and buttons identical to the RE450?

I haven't a re450v3 to compare, but from the pic seems identical,
WPS, reset, power and "led" button
WPS (the ring), 2.4, 5 and power led

next step?

The board picture requested

So, I've checked the firmware update and find

for RE450v1
bootargs=console=ttyS0,115200 root=31:02 rootfstype=squashfs init=/sbin/init mtdparts=ath-nor0:128k(u-boot),1024k(kernel),15104k(rootfs),64k(config),64k(art)

for RE450v3
bootargs=console=ttyS0,115200 root=31:03 rootfstype=squashfs init=/sbin/init mtdparts=ath-nor0:128k(u-boot),192k(config),768k(kernel),7040k(rootfs),64k(art)

for RE455v1
bootargs=console=ttyS0,115200 root=31:03 rootfstype=squashfs init=/sbin/init mtdparts=ath-nor0:128k(u-boot),192k(config),768k(kernel),7040k(rootfs),64k(art)

and it's consistent with the order in dts of the three model

I've bought a sop8 test clip to dump the flash from my model and if necessary unbrick it
waiting de delivery to try the next step

Have someone other things to check before dump the firmware?

in the meantime I've forked openwrt and add the support to re455v1
waiting the cable to dump the flash and test the firmware compiled.

Ok openwrt booted on the re455v1, 5Ghz not working properly

anybody can help?

Logged in and find

[   10.964944] ath10k 5.10 driver, optimized for CT firmware, probing pci device: 0x3c.
[   10.989732] ath10k_pci 0000:00:00.0: enabling device (0000 -> 0002)
[   10.996346] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
[   14.487280] ath10k_pci 0000:00:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[   14.496855] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
[   14.509113] ath10k_pci 0000:00:00.0: firmware ver 10.1-ct-8x-__fW-022-ecad3248 api 2 features wmi-10.x,has-wmi-mgmt-tx,mfp,txstatus-noack,wmi-10.x-CT,ratemask-CT,txrate-CT,get-temp-CT,tx-rc-CT,cust-stats-CT,retry-gt2-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT crc32 3e4cf97f
[   14.925063] ath10k_pci 0000:00:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[   15.066845] ath10k_pci 0000:00:00.0: otp calibration failed: 2
[   15.072900] ath10k_pci 0000:00:00.0: failed to run otp: -22 (download-cal-data)
[   15.080457] ath10k_pci 0000:00:00.0: could not init core (-22)
[   15.108932] ath10k_pci 0000:00:00.0: could not probe fw (-22)

the art partition seems to be the same in my official firmware dump

Fixed by adding re455v1 case in target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata

I'm ready to do a pull request, but I don't know the correct workflow to do it, a wiki page with instruction? or just do a pull request and hope?

Hope all is correct

In parallel to the PR, you can create a dataentry and a devicepage for the RE455 v1.



  • You need to be logged in to the wiki to be able to create those pages.
  • Since a PR is already existing, you can set the status to "supported" when creating dataentry and devciepage
  • In the dataentry, please add a comment (last line of the dataentry): "PR 4322 pending"

I havn't access to the wiki, how to require?

anyone tried this firmware? because there isn,t any recovery in wiki! if someone is using it with openwrt please inform us what works and what is not!!

Hi, I use it daily as my AP with my first build

1 Like

can you provide a tutorial how to revert to factory firmware if something goes wrong? and which file to use because open wrt has special needs for revert files ,like cut the headers of factory before flash, this is not mentioning anywhere and people are very sceptical to use your firmware because of it, even after tp-link hasnt updated rthis product fw for 2 years the iedea of using openwrt without any kind of tutorial seem out of question!!

Sorry, I haven't instruction to revert, and using it has my main AP I can't test anything.
In the future in case I've a second AP to test or I change my main AP, I can try to enable UART and try a way to revert it.
I've dumped the whole flash before install my firmware, thinking use it as a revert way.
Cheers Bob