Adding OpenWrt support for QNAP QHora-301W

Thanks a lot for the clarification.

Here comes the 2nd dumb question: Is there an alternative to serial connection for the first install? (i.e. SSH or other methods)

Thanks again for your help

Yes, there is:

Best regards,

1 Like

i am waiting for the stable release to include qHora-301W. but not sure when it happen, can i load the factory image from the stock web ui or i still have to use the SSH or UART method?

Hi All, Firstly thanks for the work you have all done so far.. I only recently looked into the QNAP router as a HW option as my ISP started offering a 10 Gig, up until then building a backbone for 10GB wasn't even option for me.... moving from 1gig to 10gig is now a consideration but i have concrete walls & floors WIFI gets destroyed, so i have CAT6 connecting 3 floors (Basement my office, ground and first), but moving from 1 to 10gig means new New Devices on each floor (then I came across the QNAP qhora-301w,looks like the HW fits my needs, but the config looks the worst) so you have all made my day.

Question to you as you have the HW i assume you would recommend, so any of you have more than 1 2 or more and you daisy chaining? as im seriously considering buying them but id also love to get an update of where you are all at with your image.

Thx in advance

If you really need 10G throughput via the QNAP you'd better stick to the stock firmware as there is no NSS offloading support in the official OpenWrt releases, consequently 10G is not achievable

Really need ! not really but it is tempting more than anything & ack that ill never really truly get 10gb, on a few devices i will get close but the flow will be enough, this is as close to future proofing as i would get. again i started to looking at 2.5 and 5 and that led me to the for the $ investment and this seemed a more reasonable cost option vs other options

For routing 10 GBit/s reliably at full speed, x86_64 has many advantages.

1 Like

Has anyone come across a solution to get this running at 2.5g?

2.5G works for me, you need to set the advertising:

Have you tested the performance? :wink: my WAN speed drops to 300-400 mbit when the WAN link is at 2.5G (I have a 1.5G WAN connection).


I don't use that port as WAN. Are you seeing retransmissions in iperf for example?

Can you try disabling GRO on that port at 2.5G?

I am seeing the same issue only on 2.5G while for example on 10G it doesnt happen

@MusikJunk Thank you for this instructions, great.

But it is not possible to extract the kernel and root from this .bin file. I always receive and error messge about wrong format or so.....
Is it possible that you or any other can give me the needed files to download on another way?
This would be great!

openwrt-ipq807x-generic-qnap_301w-squashfs-sysupgrade.bin is a simple tar file that can be extracted by linux tar for example.

1 Like

Great, thank you very much, this was it :slight_smile:
Another question.... I found also an "openwrt-ipq807x-generic-qnap_301w-squashfs-factory.bin" file and I thought a "factory bin" can use for an initial installation an about a second installation from the sysupgrade bin file OpenWrt will be installed? I know this from other devices.....
So, the guide from MusikJunk is this still the right way to proceed right?

Both factory.bin and sysupgrade.bin contains kernel and rootfs (due to the 301w is an eMMC device)
The guide looks good to me

1 Like

Alright, then I will using the kernel and root from the sysupgrade bin as describe...

hello all,
i wan to try openwrt on my qhora 301w too, but i don't know how to? i read here the factory firmware web ui upgrade is not going to work. pls. advise where i can find the right instruction? or give me some instruction hrere?
thanks so much!

I will try it on the weekend about this instructions:

I hope it will works

GREAT!! It works exactly as in the link describes.
Now I hope that everything else I want to configure will work. I am confident because everything on my old router already worked.
I would also like to thank all those who make it possible that devices work in OpenWrt, not only this Qnap but also all other devices that already work. Without such gigantic work the "standard" users like me could not benefit from such great software, thank you all.

Hello, guys, I wanted to ask if you are able to get full speed from your fiber connection, I currently have an ONT by ZTE (F6005V6.0) and I have the negotiated speed at 2500Mb/s after I run

ethtool -s 10g-1 advertise 18000000E102C
root@OpenWrt:~# ethtool 10g-1
Settings for 10g-1:
	Supported ports: [ ]
	Supported link modes:   100baseT/Half 100baseT/Full 
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  100baseT/Half 100baseT/Full 
	Advertised pause frame use: No
	Advertised auto-negotiation: Yes
	Advertised FEC modes: Not reported
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	Link partner advertised pause frame use: No
	Link partner advertised auto-negotiation: Yes
	Link partner advertised FEC modes: Not reported
	Speed: 2500Mb/s
	Duplex: Full
	Port: Twisted Pair
	Transceiver: external
	Auto-negotiation: on
	MDI-X: Unknown
	Link detected: yes

My profile is 2.5Gbps for download and 1Gbps for upload but I can only get 1Gbps in download (and 1Gbps in upload). I also bought a 2.5Gbps adapter to verify that 2.5Gbps speed is working on the other 10Gbps port and everything is working properly.

Any idea?

My working WAN setting with VLAN tagging for TIM (former Telecom Italia, Italian ISP provider)

config interface 'wan'
	option proto 'pppoe'
	option device '10g-1.835'
	option password 'password'
	option username 'telephone_number'
	option ifname '10g-1.835'
	option ipv6 'auto'
	option peerdns '0'
	list dns ''