Adding OpenWrt support for Linksys MR6350

luci-app-sqm and luci-app-nft-qos

1 Like

Feel free to try:

I just did a short test with wan/lan/wlan and checked if usb is still working.

2 Likes

Good afternoon, I just tried it using it as a wireless repeater and also as an access point and everything is perfect, if I don't see the wineguard configuration

From https://openwrt.org/docs/guide-user/services/vpn/wireguard/basics:

To create a new WireGuard interface go to LuCI β†’ Network β†’ Interfaces β†’ Add new interface... and select WireGuard VPN from the Protocol dropdown menu.

Is this available?

1 Like

If everything is available, perfect...Thank you for the clarification.

Good evening, in openwrt it is very easy in interfaces you can place the static ip in both wan and lan, and assign the ip static in the dhcp menu.



I did it by editing the /etc/config/dhcp file. And ready. It only took me a few minutes. I'm already quite liking this router. And at the moment, it works stable and without problems. I don't know if the range of the 5GHz network is as powerful as it should be, but it seems to work ok. Thanks for your support, @RolandoMagico . Hopefully we can have a stable and official compilation soon. It is extremely easy to install, for anyone who wants to.

@RolandoMagico, what steps do you have to follow to have official OPENWRT? I consider your build to be very, very close to being completely finished to deserve to be official. So far, zero issues and running smoothly.

There are two pull requests which must be reviewed and approved:

As soon as it is done, there will be official OpenWrt snapshot builds and then the device would be supported by the next (major?) OpenWrt release

3 Likes

I have a huge problem that has me already disappointed, and I haven't found a way to solve it, and I'm tired of trying, searching, etc. I have a TPLink WR841 with DDWRT configured as a switch (wireless ap), with dhcp disabled (as explained here: https://wiki.dd-wrt.com/wiki/index.php/Switch), and it had always worked fine with my previous routers. Now it has been literally impossible for me to get it working using the MR6530 with the latest build from @RolandoMagico .

On the MR6530 (192.168.2.1) everything works perfectly, to clarify. I can even access the TPLink configuration website (192.168.2.2).

In TPLink I cannot have internet, in the devices it does not give me IP (unidentified network or IP configuration error). Neither by LAN nor by WiFi. There are some times when it manages to receive an IP but then everything fails again. It does not respond ping to 192.168.2.1, obviously not to 8.8.8.8.

I'm about to lose the battle with all this, since I can't find anything to do, I can't find relevant information in the logs...

Connections:

TPLink > MR6530: WAN/LAN1 (It doesn't matter, WAN is assigned to the LAN switch) > LAN3.

DHCP, DNSMASQ disabled: TPLINK.

DNSMASQ in MR6530, configured. I can send the configuration if necessary.

NETWORK:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd1a:d259:ee2::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	option ipv6 '0'
	option macaddr 'E8:9F:80:80:41:6B'

config device
	option name 'lan1'
	option macaddr 'E8:9F:80:80:51:6B'

config device
	option name 'lan2'
	option macaddr 'E8:9F:80:80:52:6B'

config device
	option name 'lan3'
	option macaddr 'E8:9F:80:80:53:6B'

config device
	option name 'lan4'
	option macaddr 'E8:9F:80:80:54:6B'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '8.8.8.8'
	list dns '4.4.4.4'
	list dns '1.1.1.1'
	list dns '208.67.222.222'

config device
	option name 'wan'
	option macaddr 'E8:9F:80:80:40:6B'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option peerdns '0'
	list dns '8.8.8.8'
	list dns '4.4.4.4'
	list dns '1.1.1.1'
	list dns '208.67.222.222'

config device
	option name 'eth0'
	option ipv6 '0'
	option macaddr 'E8:9F:80:80:50:6B'

config device
	option name '2.4GHz'
	option ipv6 '0'
	option macaddr 'E8:9F:80:80:42:6B'

config device
	option name '5GHz'
	option ipv6 '0'
	option macaddr 'E8:9F:80:80:43:6B'

FIREWALL:


config defaults
	option syn_flood '1'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

DHCP


config dnsmasq
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option cachesize '1000'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	option authoritative '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option force '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config host
	option name 'Principal'
	option ip '192.168.2.100'
	list mac 'XX:XX:XX:XX:XX:XX'
	option leasetime 'infinite'
AND ALL THE OTHERS STATIC IN A SIMILAR WAY.







LOG MR6530

ERROR TPLINK

@RolandoMagico I need to talk to you, see if you can help me solve a problem I have here... Can I send you a private message with my WhatsApp number or Telegram username?

Looks like the current snapshot builds (which also include the ones I built) are affected by this issue: https://github.com/openwrt/openwrt/issues/14464

Good afternoon, I have tested the new openwrt update based on 23.05.3 indicated in https://github.com/RolandoMagico/openwrt-build/releases/tag/MR6350_Build_20240609_2 and everything works perfectly, grateful to @RolandoMagico for the update.

Thanks for testing. The images with kernel 6 will also work, except when using as dump AP as mentioned earlier:

@RolandoMagico, So far, everything has been working great with the latest build you uploaded. Can I ask you one of two things?

  1. Can you explain to me in detail (only the first time) how to compile my own version (under Windows if possible, if not with Linux but with details, sorry if it bothers you).

  2. Or if 1. is complicated, help me with a compilation that contains kmod-usb-storage, kmod-usb-storage-uas to be able to use the USB port as a NAS (I have two routers, one as the main one with the USB for printer, it works perfectly... And I want to use the secondary USB to add a USB HDD...)

I would like option 1, so as not to always bother you. Thank you for your excellent support with the MR6350.

Hi,
regarding 1)

Run the following commands:

git clone https://github.com/RolandoMagico/openwrt.git -b v23.05.3-MR6350
cd openwrt
./scripts/feeds update -a
./scripts/feeds install -a
make menuconfig
  • In the "Target System" menu, select "Qualcomm Atheros IPQ40XX"

  • In the "Target Profile" menu, select "Linksys MR6350"

  • For the web interface: In the menu "LuCI" -> "Collections", select luci (press space twice to get a "*" instead of "M":
    grafik

  • In the menu "LuCI" -> "Applications", you can select the required applications (also ensure that there is a "*", not a "M"). For example from my last build:

    • luci-app-nft-qos
    • luci-app-p910nd
    • luci-app-qos
    • luci-app-sqm
  • In the menu "LuCI" -> "Protocols", you can select the required protocols (also ensure that there is a "*", not a "M"). For example from my last build:

    • luci-proto-wireguard
  • In the menu "Kernel modules" -> "USB Support", you can select the required kernel modules (also ensure that there is a "*", not a "M"). For example from my last build:

    • kmod-usb-printer
  • And in your case

    • kmod-usb-storage
    • kmod-usb-storage-uas

If I didn't miss anything and you didn't miss anything you can exit the configuration, connfirm saving the changes.

Now you can run the build, I usually add the number of cores I have:

make -j24

Now it's time to get some coffee, the build will take some time (about 10-15 minutes on my Ryzen 9 5900X).

You'll find all the images in the folder bin/targets/ipq40xx/generic

If you missed something in the configuration, just run make menuconfig again, change the settings and run make again. Incremental builds will take much less time than the initial build.

regarding 2)
I put the files here (I didn't test much, just checked if flashing and re-flashing is working):

1 Like

Greetings, I did all the steps as you indicated, but the MR6350 does not appear anywhere...

Sorry, my bad, it should work now if you do it again.

1 Like

A question to the maintainers of OpenWrt: is there anything I can do to get it merged? It’s already open over a half year and I wonder if I missed something

1 Like