Adding OpenWrt support for Linksys MR6350

@rwl408, have you had any more success with getting a working build for the MR6350?

I am also interested

Welcome to the forum, @mdclemen. And thanks for your post in this thread. I meant to update my MR6350 effort but the forum policy doesn't allow me to add post in this thread, after 3 consecutive posts, until someone else posts to this thread again.
Yes, I have a working build (now 22.3.0), adapted from MR8300 source code, but there are a few things (Switch, VLAN and physical wan/lan port assignment) beyond my technical know-how. As such, my build has flaws but it works perfectly in my running environment (5GHz wifi in client mode, 2GHz wifi in access point mode, OpenVPN server and Asterisk). I am tired of porting the changes whenever I want to update to the new firmware version so much so that I plan to just buy an MR8300 to replace the MR6350.

1 Like

@rwl408 could you please share the steps for building MR6350 compatible image from the MR8300 source. Also what are the issues with the "Switch, VLAN and physical wan/lan port assignment"? Any ideas how this functionality might be enabled? This actually what made me want to try OpenWRT - there is no VLAN support in the stock Linksys image :frowning: ...

I am willing to share in details what I have done in my MR6350 hacking but I have no idea how to upload files. I don't want to send them in response to pm individually. If somebody shows me how to do it or other easy alternative, I can upload my modified source files and my v22.03.2 build. As mentioned in my last post, I had bought an MR8300 and retired MR6350. I built v22.03.2 not because I need it but because I used the build as a test vehicle of my recent Windows 11 upgrade and VirtualBox 7.0.0. I did test the build and it seemed to perform quite well as my early builds from Windows 10/VirtualBox 6.1 (in my usage environment).

All the information I have collected to build MR6350 is here. I have now replaced MR6350 by MR8300 so that I don't have to do my own build again and again. :slight_smile:

Some relevant information and warnings:

  1. The board calibration file "board-linksys_mr6350.qca4019" was modified based on the one in MR8300 but I only did the US region portion. The other regions may or may not work.
  2. The dts file "qcom-ipq4019-mr6350.dts" was modified based on the one for MR9000 by @reka.
  3. The file "myMR6350ChangeList.txt" has a very brief description of what I do with each souce file. If you are interested in build your own firmware, open the original source file and search for "mr8300" and add something similar for "mr6350".
  4. If you build your own firmware make sure you use the same vermagic number as explained here so that you can use the official repository.
  5. I wrote down the build steps in the file "firmwareBuildInstructions.txt". In order to have the build target MR6350 to show up during "make menuconfig", I modify the source file right before. I believe the time stamp of one of the files (generic.mk ?) must be later then ".config" but I am not sure.

Disclaimer:
Use at your own risks. I am not responsible for any damage/harms done to your device using the information or firmware in the download link.

2 Likes

Hello,

I have one of these and would like it to work with openwrt. What should I do to get that done? Thank you.

Install the firmware linked above?

1 Like

When I flashed my MR6350, I used the "TFTP + serial method" as documented in EA7500v1 (link in one of my earlier posts) because I could not find the upgrade menu from the stock firmware. However when I recently flashed OpenWRT to my MR8300, I found out that there was a way to get to the upgrade menu from the stock firmware. I assume you can follow the method documented in MR8300 to do the same.

@ rwl408, I flashed your firmware, and after fiddling with the VLAN settings, since the ports aren't assigned correctly (WAN is some LAN port), the firmware seems to be mostly working...

Except my MacBook Pro refuses to get a IP address assigned via DHCP over ethernet. I've played with all the settings I can think of. A different Windows computer works fine over ethernet. Any idea why the macOS doesn't like this firmware?

Good afternoon, has anyone installed openwrt on the linksys mr6350? I just bought one and it works well in general, but I would like to install openwrt to use it as a wireless repeater, since the factory firmware does not have it...

Can it be installed documented in this forum????some experience???since it is not officially on the list in openwrt

Good afternoon, I have installed openwrt on my mr6350 since I need it as a wireless repeater since the factory software does not include it following the instructions of rwl408 and everything is perfect, the only exception to the wan port is the lan1 port, it is incorrectly labeled, install from luci luci-app-advanced-reboot and it doesn't work... My question is, is it possible to return to the linksys software using the recovery method?
Turn on and wait 10 seconds.
Turn off and wait 5 seconds.
Repeat steps 1 and 2 three times, then go to 4.
U-boot will now boot the other partition. You should be able to access your router on LAN.Since I understand that it has 2 partitions.... ????Attached screenshots :grinning: :grinning:

Hello everyone,
is anybody already working on getting the device officially supported by OpenWrt? If not: I can provide assistance to do it.
But as I'm not owning the device, somebody has to test the images.

Good afternoon, I have the same one up and running as described above, I would be happy to support you.

Ok, means I can try to provide images and if they don't work there is always the possibility to recover?

It is my big doubt, I have just purchased this device, and installed the unofficial image from @rwl408, I have not yet tested if it works or not.

Ok, I had a first look at the files linked in Adding OpenWrt support for Linksys MR6350 - #23 by rwl408

  • board-linksys_mr6350.qca4019 seems to be handled differntly now, there is a dedicated repository for this files: https://github.com/openwrt/firmware_qca-wireless
  • target/linux/ipq40xx/base-files/lib/preinit/06_set_preinit_iface_ipq40xx.sh doesn't exist anymore in the current main. I have to check if the changes there are still required
  • target/linux/ipq40xx/patches-5.10/901-arm-boot-add-dts-files.patch doesn't exist anymore in the current main. Must be checked as well.

My work is available here: https://github.com/RolandoMagico/openwrt/tree/MR6350

Currently the build with the latest OpenWrt main fails because of the image size:
WARNING: Image file /home/roland/MR6350/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/linux-ipq40xx_generic/linksys_mr6350-zImage.itb is too big: 3263784 > 3145728

Thank you very much, I currently have it working in the OpenWrt 22.03.2 image created by @rwl408 and it works, the only detail is that the wan port is incorrectly labeled is the lan1 port, I really have very basic knowledge of openwrt, which has very discrete, IPQ4019 processor with 4 cores at 717, 256 MB of ram and 256 MB of rom.

I could gladly try images since I have the router, my fear is turning it into a brick.

Good news, I tried changing partitions and it worked successfully to return to stock, and the opposite to return to openwrt. :grinning: :grinning: :grinning:

1 Like

I suggest submitting a WIP PR for this, making it easier for folks to give feedback.

Also, be aware that since release 23.05 these devices have switched to using DSA and larger kernels. Please see https://github.com/openwrt/openwrt/pull/11405 for details of the related changes, especially ea8300.

2 Likes