Adding OpenWrt support for Linksys EA7500 v2

@holziholz my work on the EA7500v2 did not progress much. I reverted back to the opensource WiFi drivers as the close sourced binary drivers are clunky to use. As the open source drivers are also not ready for prime time, this project of mine sort of got sidelined. The last time I tried was probably 6 months ago.

My EA7500v2 is currently collecting dust at the moment tho.

Maybe @jackcolentern has a working build for the EA7500v2 as he seem to be more active compared to me in OpenWRT thinkering.

Thank you very much for your answer. Will contact @jackcolentern or maybe he reads this. Greetings from Austria.

Hi, unfortunately for Linksys EA7500 V2, according to my testing, the mt7615 driver is not really stable enough for daily use. The wifi only works at 50~150Mbps which is not really good.
If you want to give it a test, you can build from this commit:
https://github.com/jackcolentern/openwrt/commit/8f581c41eb8e47ca0e1b7b03e7aa6b0fa7b47c5a this is a firmware for EA8100, which should work on EA7500v2 (please do it at your own risk though)

Currently, if you want a fully working wifi, seems like the closed source driver is the only way to go, you can look at: https://github.com/jackcolentern/openwrt-linksys-ea7500v2
but the above link is based on a very outdated kernel version, and it lacks the linksys signing and proper bootcount reset, so it is not a good daily driver also.

Hello @jackcolentern. Thank you very much for your time. I think about it if I give it a try.

1 Like

No problem!
If you found that the new mt7615 driver is stable and fast enough for daily use, please tell us, thanks!

So support got added for this EA7500 more recently than the last post on this forum. Is it stable? Is it good?

Looks like the latest mt7615 driver is ready for production use. I’ve compiled a firmware from master for my EA7500 v2 and it’s been running for a day without issue. Both 2G and 5G WiFi seems stable.

The only drawback I observed are:

  • slower WiFi speed compared to close sourced driver: 350+ vs 600+ Mbps with iPerf 3 test, WiFi to LAN
  • slower NAT thruput, as H/W NAT not available. Linux native flow offload can only do about 500 Mbps WAN-LAN. Looks like the DSA driver is slower.
  • No Luci VLAN config as the switch configuration is not available in Luci. Apparently VLANs have to be configured manually. I have yet to configure VLAN for testing tho.

I also managed to compile QCA SFE for Linux 5.4. Using SFE WAN-LAN thruput improves to around 800+ Mbps, with 1 CPU hitting 100%.

The main support added in master could not boot my router unless I change the image build config.

My EA7500 v2 is currently sitting behind my R7800 NATed for testing. Will continue to test and report more issue.

Apparently VLAN configurations can be done via Luci as well. It can be configured just by adding a custom interface to the bridge, wan, or whatever interface you desire. The custom interface should be suffixed with the VLAN ID. For example, for 'lan1', you can create a VLAN ID 123 tagged interface with the interface 'lan1.123'. UCI will auto configure the VLAN tags.

Of course you can manually edit the '/etc/config/network' file as well and restart the network. Here's an example of my router's config with LAN port 1 configured with tagged VLAN ID 123. My computer connected to LAN port 1, with tagged VLAN 123 could obtain an IP address from the router with this configuration.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd3e:9fa2:da35::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option delegate '0'
	option ifname 'lan1 lan1.123 lan2 lan3 lan4'
	option stp '1'
	option igmp_snooping '1'

config device 'lan_lan1_dev'
	option name 'lan1'
	option macaddr '24:f5:a2:xx:xx:xx'

config device 'lan_lan2_dev'
	option name 'lan2'
	option macaddr '24:f5:a2:xx:xx:xx'

config device 'lan_lan3_dev'
	option name 'lan3'
	option macaddr '24:f5:a2:xx:xx:xx'

config device 'lan_lan4_dev'
	option name 'lan4'
	option macaddr '24:f5:a2:xx:xx:xx'

config interface 'wan'
	option ifname 'wan'
	option proto 'dhcp'

config device 'wan_wan_dev'
	option name 'wan'
	option macaddr '24:f5:a2:xx:xx:xx'

config interface 'wan6'
	option ifname 'wan'
	option proto 'dhcpv6'
1 Like

Hello guys! Please help - I´m flashing factory.bin and after reboot get same oem firmaware. I tried to flash original flash first as in manual but it did not help. Any suggestions?
UPD: I was able to force it booting to flashed fw. I can connect to router, get ip address from dhcp, but no sshd looks running, 80 port is able to connect by netcat but it does not responds with any information.

@sneshin See https://openwrt.org/toh/linksys/linksys_ea7500_v2#installation
You have to install OEM firmware first. This will switch the bootloader to second boot image. Then install OpenWRT image.

Thank you for your reply. Yes, I did try this method with no luck. Flash did not boot 3 times and then switched back to OEM. What worked for me is to flash OpenWrt for EA8100 (similar HW) from this link https://wiki.codepowered.com/xwiki/bin/view/Linksys%20EA8100/Openwrt%20for%20Linksys%20EA8100/

I've been running a snapshot build on my EA7500v2 for over a month. It's working very well.

What needs to happen to migrate EA7500 support from snapshot(s) to an official release?

Patience and the passing of time, until 21.xy.0 gets released.

support is broken in current snapshot. I've opened an issue at openwrt bug tracker: https://bugs.openwrt.org/index.php?do=details&task_id=3603

Maybe its a general problem with ea7500v2 or its an issue with bad blocks in the nand. ea8100 image from above is working aswell.

Update:
I did some research and I guess the problem is related to the mt7621 nand driver, and not handling bad block table properly. If bad blocks exist, the driver does not read the bad block table and set the wrong offset to the partitions.

trying XWRT on this router (fork of openwrt)
firmware download link

result :

  • wifi works better than 19.07, higher speed tested with iperf3, but slower than factory firmware
  • i cant get dhcp client working on wan interface connected to docsis modem
1 Like

Do you have tutorial to install this XWRT from start? Also is the external USB storage working?
Thank you.

I've been running Openwrt on my router EA7500 v2 and i like the acquired functionalities with the firmware. However, performance is poor over 2.4Ghz radio getting bandwidth less than 11Mbps compared to the OEM firmware where I get speeds of 54 Mbps and 5.0Ghz radio performance is better, but the radio is disabled every moment.

Has anyone update to 21.02.0? How is the performance? Thank you.
http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-linksys_ea7500-v2-squashfs-factory.bin

FYI - OpenWrt 21.02.0 support is available now.

Please open new topics for any remaining questions.

Thanks! :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.