Adding OpenWrt support for Comfast CF-E130N V2

Hi.

Sorry, my units are mounted quite high so I can't really take them down to note down a procedure.
As for how I got mine working, uploaded the sysupgrade snapshot image via the stock WebUI. Keep pinging the device, you'll notice it when it reboots then. Once rebooted, hold the reset button for like 20 seconds on the unit. Then it resets the device to factory defaults, you can then SSH the unit to get it setup since it doesn't have LUCI installed.

If it truly is bricked, get it wired to your PC, use wireshark to see if it tries to grab an image using tftp, then provide the stock image back to the unit that way perhaps?

Thanks

Do you have the link for the sysupgrade snapshot image via the stock WebUI? or this is the page you referring: https://openwrt.org/toh/comfast/comfast_cf-e130n_v2? Also, the IP I am going to ping is 192.168.10.1 which is the default IP for the router.

You mean wire to the PC using the USB port?

thanks,

hey ODickins, I already connected to the comfast via SSH using 192.168.1.1 and logged in using root. what should I be doing next?

should I do this?

sysupgrade

  • Login as root via SSH on 192.168.1.1, then enter the following commands:

cd /tmp wget http://downloads.openwrt.org/snapshots/trunk/XXX/xxx.abc
sysupgrade /tmp/xxx.abc

This is possibly the wrong forum to get help now then, I don't believe you can gain SSH access to the stock image.

I uploaded the sysupgrade image by using the Stock image Web interface. Then held the reset button which reset all settings to default (and cleared the root password). From there, SSH to 192.168.1.1 and you'll be greeted with the OpenWRT prompt, from there you can use opkg and UCI commands to configure or install LUCI for a web interface.

Sorry I can't help my Futher, I don't really use OpenWRT for a lot, only really as AP's so my knowledge regarding this is fairly limited.

Check optional next steps here as by what you describe I believe you've got the unit flashed and it is running OpenWRT snapshot. https://openwrt.org/docs/guide-quick-start/developmentinstallation

I already logged in to SSH and trying to install LUCI

image

image

opkg update
opkg install luci

I already did opkg update but result is this.

I have a working connection.

nslookup downloads.openwrt.org

Please don't post console output as screenshots.
Please use the "Preformatted text </>" button for logs, scripts, configs and general console output.
grafik

https://openwrt.org/faq/failed_to_download_wget_returned_4

I did nslookup and results:

root@OpenWrt:~# nslookup downloads.openwrt.org
^[[;; connection timed out; no servers could be reached

You don't.

https://openwrt.org/faq/failed_to_download_wget_returned_4

Hi Guys,
I have flashed with the snapshot, but would like some Luci but having a real problem>Have posted my problem here, In short:
I have tried this a number of time using Putty on a win10 , but with out luck. I get the prublem:

* opkg_download: Failed to download http://downloads.openwrt.org/snapshots/packages/mips_24kc/telephony/Packages.gz, wget returned 4.
* opkg_download: Check your network settings and connectivity.

I see many people have this problem but can't ind a answer to it, I can connect to the internet though the router ( I'm replying now connected to it) so I'm at a loss.

Any suggestions (in layman's terms) welcome

With your PC connected to the CF-E130Nv2, can you download this file?
http://downloads.openwrt.org/snapshots/packages/mips_24kc/telephony/Packages.gz

Please can you issue the following commands on your CF-E130Nv2 and let us know the output.

route
nslookup downloads.openwrt.org
ping 8.8.8.8 -c 1
wget http://downloads.openwrt.org/snapshots/packages/mips_24kc/telephony/Packages.gz

Here is an example of my output if I do the same on my CF-E130Nv2.

root@192.168.10.248's password:


BusyBox v1.31.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r13487-712e00877d
 -----------------------------------------------------
root@OutdoorAP:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.10.254  0.0.0.0         UG    0      0        0 br-lan
192.168.10.0    *               255.255.255.0   U     0      0        0 br-lan
root@OutdoorAP:~# nslookup downloads.openwrt.org
Server:         192.168.10.1
Address:        192.168.10.1#53

Name:      downloads.openwrt.org
downloads.openwrt.org   canonical name = mirror-02.infra.openwrt.org
Name:      mirror-02.infra.openwrt.org
Address 1: 176.9.48.73
downloads.openwrt.org   canonical name = mirror-02.infra.openwrt.org
Address 2: 2a01:4f8:150:6449::2
root@OutdoorAP:~# ping 8.8.8.8 -c 1
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=116 time=818.739 ms

--- 8.8.8.8 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 818.739/818.739/818.739 ms
root@OutdoorAP:~# wget http://downloads.openwrt.org/snapshots/packages/mips_24kc/telephony/Packages.gz
Downloading 'http://downloads.openwrt.org/snapshots/packages/mips_24kc/telephony/Packages.gz'
Connecting to 176.9.48.73:80
Writing to 'Packages.gz'
Packages.gz          100% |*******************************| 70023   0:00:00 ETA
Download completed (70023 bytes)
root@OutdoorAP:~#

This will;

  • Confirm you have a default route.
  • Confirm you have the ability to resolve domain names
  • Confirm you can route to the WAN & confirm any upstream NAT is working
  • Confirm you can download packages over HTTP

hey master ODickins, how can I revert it from openwrt to original comfast firmware? thanks.

I'm afraid I've probably hit the same wall as yourself; cannot find the original firmware posted online by the manufacturer.

Your options would be to either; email the manufacturer or attempt to extract the firmware somehow from a working unit, original, unit.

Otherwise; happy to help you get OpenWRT working on it - I have recently upgraded mine to the latest OpenWRT snapshot and reconfigured; which worked without issue.

Finally; as stated before - I don't think this is the correct forum for your questions however, since this is the development forum. You'll probably want to head over to the "Installing and Using OpenWRT" Forum.

Regards.

I already reflashed it back to stock comfast firmware. I just follow this tutorial.

Sorry for the delay- work :frowning:

root@OpenWrt:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 br-lan
root@OpenWrt:~# nslookup downloads.openwrt.org

;; connection timed out; no servers could be reached

root@OpenWrt:~# ping 8.8.8.8 -c 1
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable
root@OpenWrt:~# wget http://downloads.openwrt.org/snapshots/packages/mips_24kc/t
elephony/Packages.g
Downloading 'http://downloads.openwrt.org/snapshots/packages/mips_24kc/telephony/Packages.g'
Failed to send request: Operation not permitted

Yes no problem downloading with the PC