Adding OpenWrt support for Comfast CF-E130N V2

I already did opkg update but result is this.

I have a working connection.

nslookup downloads.openwrt.org

Please don't post console output as screenshots.
Please use the "Preformatted text </>" button for logs, scripts, configs and general console output.
grafik

https://openwrt.org/faq/failed_to_download_wget_returned_4

I did nslookup and results:

root@OpenWrt:~# nslookup downloads.openwrt.org
^[[;; connection timed out; no servers could be reached

You don't.

https://openwrt.org/faq/failed_to_download_wget_returned_4

Hi Guys,
I have flashed with the snapshot, but would like some Luci but having a real problem>Have posted my problem here, In short:
I have tried this a number of time using Putty on a win10 , but with out luck. I get the prublem:

* opkg_download: Failed to download http://downloads.openwrt.org/snapshots/packages/mips_24kc/telephony/Packages.gz, wget returned 4.
* opkg_download: Check your network settings and connectivity.

I see many people have this problem but can't ind a answer to it, I can connect to the internet though the router ( I'm replying now connected to it) so I'm at a loss.

Any suggestions (in layman's terms) welcome

With your PC connected to the CF-E130Nv2, can you download this file?
http://downloads.openwrt.org/snapshots/packages/mips_24kc/telephony/Packages.gz

Please can you issue the following commands on your CF-E130Nv2 and let us know the output.

route
nslookup downloads.openwrt.org
ping 8.8.8.8 -c 1
wget http://downloads.openwrt.org/snapshots/packages/mips_24kc/telephony/Packages.gz

Here is an example of my output if I do the same on my CF-E130Nv2.

root@192.168.10.248's password:


BusyBox v1.31.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r13487-712e00877d
 -----------------------------------------------------
root@OutdoorAP:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.10.254  0.0.0.0         UG    0      0        0 br-lan
192.168.10.0    *               255.255.255.0   U     0      0        0 br-lan
root@OutdoorAP:~# nslookup downloads.openwrt.org
Server:         192.168.10.1
Address:        192.168.10.1#53

Name:      downloads.openwrt.org
downloads.openwrt.org   canonical name = mirror-02.infra.openwrt.org
Name:      mirror-02.infra.openwrt.org
Address 1: 176.9.48.73
downloads.openwrt.org   canonical name = mirror-02.infra.openwrt.org
Address 2: 2a01:4f8:150:6449::2
root@OutdoorAP:~# ping 8.8.8.8 -c 1
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=116 time=818.739 ms

--- 8.8.8.8 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 818.739/818.739/818.739 ms
root@OutdoorAP:~# wget http://downloads.openwrt.org/snapshots/packages/mips_24kc/telephony/Packages.gz
Downloading 'http://downloads.openwrt.org/snapshots/packages/mips_24kc/telephony/Packages.gz'
Connecting to 176.9.48.73:80
Writing to 'Packages.gz'
Packages.gz          100% |*******************************| 70023   0:00:00 ETA
Download completed (70023 bytes)
root@OutdoorAP:~#

This will;

  • Confirm you have a default route.
  • Confirm you have the ability to resolve domain names
  • Confirm you can route to the WAN & confirm any upstream NAT is working
  • Confirm you can download packages over HTTP

hey master ODickins, how can I revert it from openwrt to original comfast firmware? thanks.

I'm afraid I've probably hit the same wall as yourself; cannot find the original firmware posted online by the manufacturer.

Your options would be to either; email the manufacturer or attempt to extract the firmware somehow from a working unit, original, unit.

Otherwise; happy to help you get OpenWRT working on it - I have recently upgraded mine to the latest OpenWRT snapshot and reconfigured; which worked without issue.

Finally; as stated before - I don't think this is the correct forum for your questions however, since this is the development forum. You'll probably want to head over to the "Installing and Using OpenWRT" Forum.

Regards.

I already reflashed it back to stock comfast firmware. I just follow this tutorial.

Sorry for the delay- work :frowning:

root@OpenWrt:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 br-lan
root@OpenWrt:~# nslookup downloads.openwrt.org

;; connection timed out; no servers could be reached

root@OpenWrt:~# ping 8.8.8.8 -c 1
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable
root@OpenWrt:~# wget http://downloads.openwrt.org/snapshots/packages/mips_24kc/t
elephony/Packages.g
Downloading 'http://downloads.openwrt.org/snapshots/packages/mips_24kc/telephony/Packages.g'
Failed to send request: Operation not permitted

Yes no problem downloading with the PC

"route" command output has told me you have no default route.
"nslookup" command output has told me you have no DNS servers configured, or DNS servers configured which are not accessible on this LAN.
"ping" is irrelevant, due to the output of "route".
"wget" is irrelevant, due to the output of "route".

Please check your configuration found under "/etc/conf/network". Here an example of mine;

config interface 'vlan10'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.10.254'
        option ipaddr '192.168.10.240'
        list dns '192.168.10.1'
        option stp '1'
        option ifname 'eth0.10 gre4t-trunk0.10'

Note:

  • option gateway
  • list dns

Edit: You really are asking questions regarding "using" OpenWRT, not development specific questions. Faster replies will most likely be found at the forum "Installing and Using OpenWRT"

1 Like

Thanks for the quick reply, I will give it a try.

I had posted in Installing and Using OpenWRT with out luck but found this thread which seems people here have had the same problem.

Would be nice if firmware has debug channels available on stock firmware.

Debug channels = 2300-2700mhz

maybe not the best place to ask, but i cannot find a good place to ask...

i want to buy two....
is there any diffrance between V1 and V2?
can i really get lets say 500 meters?

BEWARE, I used the linked image to install via the web gui, and found myself in a world of pain.

I found - too late - https://openwrt.org/toh/comfast/cf-e120a (a different Comfast device) which says for v2.6.0.5 (I have v2.6.0.7):

Standard OpenWrt images can not be flashed anymore from the web interface.

It doesn't say why, but having done that, in failsafe mode, with mount_root I was seeing

jffs2 not ready yet, using temporary tmpfs overlay

Trying to workaround that, I got to a state where I couldn't enter failsafe mode. And I can't seem to get to the U-Boot recovery page.

I think if I was attempting this again, I'd start by getting SSH access (as described on the cf-e120a page)

The key to getting the U-Boot recovery web page turned out to be setting the IP address of the connected computer to 192.168.1.10. It wasn't enough to use some other address on the same subnet!

After this, I was able to upload the image again via the recovery web page, and after that ssh in (without a root password).

From there, it was possible to install luci. But first, I had to add DNS settings and a gateway to the lan interface, in /etc/config/network . For example:

        option dns '8.8.8.8 8.8.4.4'
        option gateway '192.168.2.1'

http://www.comfast.cn/index.php?spm=a2g0s.imconversation.0.0.6b4e3e5fP4sS1x&m=content&c=index&a=show&catid=86&id=284

If anyone still needs it