Adding Device Support TP-Link WR941HP

Any news on v2 support?
I have one v2 hardware laying around (with stock firmware). I would like to contribute with something (as for now the router itself it's just a piece of garbage collecting dust in my shelf). Is there anything that I could help you with?

1 Like

If there was a way to split the kernel into 2 partitions, I think I would try again. But I couldn't do it.

You shared the sysupgrade firmware for the tl-wr941hp v1, but if i have the stock firmware this won't work right?

Hi Guys, greeting from Brazil! This thread is in my watch for a long time and, seeing @FabianoTSS's progression I decided to open up my TL-WR941HP v2, which is collecting dust in my shelf since I brogth an Archer C6. I have an PL-2303HX USB-Serial adapter which is supposed to read the 3.3v serial directly, but, when I hook it up, I just see garbage in the screen. First of all, I tried the 115200 1N8 configuration on Putty, and nothing. Than, I tried the most common serial bauds (9600, 19200, 38400, 57600 and 115200), I also tried to poke around other configurations and also tried other terminal programs (minicom and dterm). Last thing I tried was to wire some pull-ups and pull-downs resistors, as I see this used in other models, without success too.

So, is there anything I can do? I do read (more than once) this entire thread, but, did I miss something?

I know that my USB-Serial is functioning as I already used it to write some ESP8266, but, as I already tried everything, I will try to hook this up to a Raspberry PI 3 Serial, just to see if I receive the same garbage.

Cheers!

EDIT: Raspberry PI did the trick. Now I see garbage in the begining (uBoot log, I suppose) and then I can see clear text and enter the console.

I also had this problem with the adapter.

I took the files that you had asked @hectorgrom: https://github.com/grstein/TL-WR941HP_v2_br

1 Like

Is these ok fw for tplink wr841hpv1? Or there is or not for version 1

The WR841HPv1 uses a Realtek chipset that will never be supported.

Completely different from any WR941HP.

Could you share the image just to be flashed to the chip please. Or if you can share a datailed way to make the image please do. I also have a V2 laying around and is just collecting dust.
Ps. I have a spi programmer and everything that is necessary to do the procedure.
So please dont forget........
Great work on the V1

It'll convert your version 2 in a version 1.
Use the FULL_FIRMWARE.bin
if you want to change the mac adress use this software: https://mh-nexus.de/en/hxd/

Download the firmware here: https://github.com/FabianoTSS/tl-wr941hpv1

Where I change the mac adress: