Adding binary with shared library to base-files

I would like to include some closed source binaries in an openwrt sdcard image I would have thought I could just have added the file f.ex here:


unfortunately the openwrt make system finds that there is a dependence on a shared library (a binary-library which I also extract from the orignal equipment).

So my question how can I add a binary to a build.

Copy them as custom files by placing them to files/


Same for imagebuilder

I doubt that it will work. The embedded device binaries are usually linked tightly to certain core libraries like the C lib. They rarely work even with different versions of the same library.

That doesn't change anything:

I tried creating: package/system/yi-home/Makefile

include $(TOPDIR)/
include $(INCLUDE_DIR)/
define Package/yi-home
   CATEGORY:=Base system
   TITLE:=binary files from original YI-home camera
define Build/Prepare
         mkdir -p $(PKG_BUILD_DIR)
define Build/Compile/Default
Build/Compile = $(Build/Compile/Default)
define Package/yi-home/install
         $(CP) ./files/* $(1)/
$(eval $(call BuildPackage,yi-home))

the result is still the same

Package yi-home is missing dependencies for the following libraries:

To figure out what was going on I tried changing the last line in package/base-files/Makefile from eval to error to see what rules hit me, here is the culprit, I do not know where it comes from, why it is there or how to disable it

@( rm -f /y/yi/openwrt/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/pkginfo/base-files.missing; ( export READELF=arm-openwrt-linux-muslgnueabi-readelf OBJCOPY=arm-openwrt-linux-muslgnueabi-objcopy XARGS="xargs -r"; /y/yi/openwrt/scripts/ "$(IDIR_base-files)"; ) | while read FILE; do grep -qxF "$$FILE" /y/yi/openwrt/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/pkginfo/base-files.provides || echo "$$FILE" >> /y/yi/openwrt/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/pkginfo/base-files.missing; done; if [ -f "/y/yi/openwrt/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/pkginfo/base-files.missing" ]; then echo "Package base-files is missing dependencies for the following libraries:" >&2; cat "/y/yi/openwrt/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/pkginfo/base-files.missing" >&2; false; fi; )

It is compiled against a different C lib ...