Adding a new repo in UniFi AP (UAP-AC-EDU)

I have an installation with UAP-AC-EDUs which is AC-PRO with a loudspeaker connected to it (the product is discontinued). I'm using the SIP feature where the unit has baresip client. I want to add Opus codec (or something better than g711/alaw). My idea was to try update just baresip packages from the recent repository.

I've tried to create /etc/opkg/customfeeds.conf containing this (I also tried

src/gz reboot_telephony

But opkg update fails on the signature:

Signature check failed.
Remove wrong Signature file.

Because it is limited system with just busybox, there is no /etc/opkg/keys, no openwrt-keyring, opkg doesn't know option check_signature (opkg version 9f61f7acf3845d2e09675b49fec5d783d57eb780 (2017-12-08)).

I don't know how to skip this check or if I'll have to prepare my own repo and somehow sign it to pass.

ubus call system board; cat /etc/openwrt_release:

	"kernel": "4.4.153",
	"hostname": "foobar",
	"system": "Qualcomm Atheros QCA956X ver 1 rev 0",
	"model": "Ubiquiti Networks Inc. (c) gen2",
	"board_name": "unknown"
DISTRIB_DESCRIPTION='LEDE Reboot 17.01.6 r3979-2252731af4'
DISTRIB_TAINTS='no-all mklibs busybox'

LEDE 17.01 isn't anywhere near recent.

1 Like

LEDE (17.01) is extremely old and has been EOL and unsupported for many years.

You'll probably need to update to a recent/supported vesion (22.03.3 is the current version as of this writing). The UAP-AC-PRO is supported on the latest version.

1 Like

You won't find ar71xx in newer releases either, ar71xx has been superseded by ath79.


Adding to @Borromini's point on ath79...

your upgrade path for best succes will likely be 17.01 (current) > 18.06 (ar71xx) > 19.07 (ath79) > 22.02 (ath79).

Reset to defaults before you start, and do not keep settings on each of the upgrades. The upgrade from ar71xx > ath79 will show a scary warning about an unsupported image... go ahead and force the ugprade (make sure you've selected the correct file and that the checksum matches what is shown on the download site).

1 Like

Thanks guys, if it is no chance to do it w/o upgrading the whole system, I'll try to upgrade as suggested by @psherman. I'm a little worried about resetting to defaults. I'm not sure if I'll be able to adopt that AP later in the Controller. ... but I'll see.

Btw. for the record, AC-EDU is AC-PRO with some different signature because UniFi Controller is showing just EDU and also EOL product, so I can't upgrade its firmware in an official way.

oh... wait! You're using the Unifi firmware and the UNA? If you upgrade to pure OpenWrt, you will not be able to use the Unifi environment at all.

1 Like

... then this is no-go for me. What else? Compile everything with static libs and upload it besides the opkg and try to solve eventually broken dependencies?

The Unifi firmware is "based on OpenWrt" but is not OpenWrt at all.

You need to ask your questions on the UI community forums.

1 Like

That probably won't fly, due to dependencies you can't resolve in the public LEDE version.

1 Like