Add TP-Link TL-WN722N wifi usb adaptor

Hello, I have a tp-link tl-wn722n and I'd like to add it to my netgear WNDR3700's usb to act as a wireless client (WWAN). Right now the neatgear's 2.4ghz is acting as a client and the 5ghz as the actual wifi network. I want to substitute the wifi with the usb wifi adapter, but I don't know how.

Can anybody point me to the right direction?
Thanks!

You should be able to just install the driver and reboot.

https://wikidevi.com/wiki/TP-LINK_TL-WN722N_v1.x

https://wikidevi.com/wiki/TP-LINK_TL-WN722N_v2
https://wikidevi.com/wiki/TP-LINK_TL-WN722N_v3

  • Versions 2 and 3 uses the Realtek RTL8188EUS...I don't see this driver in the Package Table.
1 Like

also do

cp /etc/config/wireless /etc/config/wireless.original
rm -f /etc/config/wireless

wifi config
wifi
reboot

and enable the new radio1 in web interface

ver 1.x after loading driver still could not use it as a mesh
Could not find driver for ver 2.x of the adapter

1 Like

Thanks both, I have the v2 version :thinking:

anyway there is a linux driver

https://www.tp-link.com/us/download/TL-WN722N_V2.html#Driver

anything I can do?

Operating System: Linux Kernel 2.6.18~3.19.3

Version 18.06.1 uses 4.9 and 4.14...it would likely need patching.

Is this something I could do? With some help of course... If this is the case, can you pont me out where to start or some tutorial/documentation to read?

Or does tp-link has to provide the updated driver? Meaning I should use the usb stick somewhere else (:man_juggling: or :golfing_man:)

Have you tried kmod-rtl8192cu?
It should also support RTL8188, maybe it needs to be patched to include the TP-Link VID/PID of your adapter.

1 Like

sorry can't help I've got version 1

In theory, the rtl8188eu should be supported by kmod-rtl8xxxu, maybe your usb card is supported by this driver

1 Like

thanks @s_2 & @Mynzer I'll try it!

How can I install and enable the packages you suggested? via opkg?

If you're using LuCI, go to System -> Software, Update package lists and search for kmod-rtl8192cu.

Using the shell it would be:

opkg update
opkg install kmod-rtl8192cu
1 Like

OK installed, dmesg shows

[3813581.365991] kmodloader: loading kernel modules from /etc/modules.d/*
[3813581.407049] usbcore: registered new interface driver rtl8192cu
[3813581.416600] kmodloader: done loading kernel modules from /etc/modules.d/*
[3813581.686348] kmodloader: loading kernel modules from /etc/modules.d/*
[3813581.702149] kmodloader: done loading kernel modules from /etc/modules.d/*
[3813692.358280] usb 1-1: new high-speed USB device number 2 using ehci-platform

Next step should I followd @markbirss advices, but no new interface is shown (already had radio0 and radio1: 2,4 and 5 Ghz of same interface)

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

my previous /etc/config/wireless was

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        option htmode 'HT20'
        option channel '8'
        option country 'IT'
        option distance '4'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'HT20'
        option country 'US'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'XXX'
        option encryption 'psk2+ccmp'
        option key 'XXX'
        option network 'lan'

#client, wwan:
config wifi-iface
        option network 'wwan'
        option ssid 'XXX'
        option device 'radio0'
        option mode 'sta'
        option bssid 'AA:88:3A:1C:D8:C1'
        option key 'XXX'
        option encryption 'psk2+ccmp'

Where should I go next?

ok, seems your driver not match usb device?

as it should have added a radio with option path on USB:///:///

do this

opkg update && opkg install usbutils
lsusb -t 
lsusb

want to see what usb wifi you actually have

lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-platform/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Vendor Specific Class, Driver=, 480M

lsusb
Bus 001 Device 002: ID 2357:010c
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

As I posted before there is no Openwrt driver that supports this USB adapter.

:(((((

thankyou anyway for your time and support

1 Like

Curiously there is a package rtl-8188-eu-firmware available, containing the binary blob to operate the device.

But the driver itself has apparently not yet made it to the master branch:

1 Like

There is someone that got working the TL-WN722N V2 on Fedora using rtl8xxxu driver, in theory should work on OpenWrt too

To install kmod-rtl8xxxu, first uninstall kmod-rtl8192cu, on shell use

opkg remove kmod-rtl8192cu
reboot

Then install kmod-rtl8xxxu using the same procedure suggested by @s_2

Using LuCI, go to System -> Software, Update package lists and search for kmod-rtl8xxxu.

Using the shell it would be:

opkg update
opkg install kmod-rtl8xxxu
reboot
1 Like