Add vlan with id 7 in current master (DSA)

Hey

on 19.07.4 I have a working network config which allows me to use pppoe, the provider requires a VLAN with id7 to allow connection.

How can I translate that config to current master with DSA (linux-5.4.x)??

on 19.07.4 the working config looks like the following:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd31:7dd2:4118::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.39.1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 5t'
	option vid '7'

config interface 'WAN'
	option proto 'pppoe'
	option password 'xxxxx'
	option ipv6 'auto'
	option username 'xxxxxxxxx'
	option ifname 'eth0.7'

in luci:

Rather similar, except for the swconfig switch configuration section. If you start from scratch (not keeping settings), you'll end up with wan, lan1, lan2, lan3, lan4 (actual interface naming differs between devices), using a tagged VLAN on wan would be expressed as wan.7.

Thanks for your answer!
So in principle just:
?

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd31:7dd2:4118::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'lan1 lan2 lan3 lan4'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.39.1'

config interface 'WAN'
        option proto 'pppoe'
        option password 'xxxxx'
        option ipv6 'auto'
        option username 'xxxxxxxxx'
        option ifname 'wan.7’

this one works - thanks for your help!

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fda8:227f:b622::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.39.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'lan1 lan2 lan3'

config interface 'wan'
        option proto 'pppoe'
        option username 'xxxxx'
        option password 'xxxxx'
        option ipv6 '1'
	option ifname 'wan.7'