Add Syslog-ng to 15.05.1

While using OpenWrt version 15.05.1 "Chaos Calmer" , observed that syslog-ng package is not there while doing the make menuconfig , hence wish to check if there is a way to include this feature ; I suppose we have the same feature supported in the latest 18.x version but wish to see if we can make it in 15.05 , do let me know your thoughts, Thanks for the support


You're on your own.

15.x is LONG obsolete. 17.x and 18.x are only getting critical security patches to my knowledge.

1 Like

If on a recent, Qualcomm-based device, this may be the QSDK, which incorporated open-source components of OpenWrt, but is a proprietary OS to which only Qualcomm licensees have access.

Thanks Jeff
Yes its on QC 401x series device , somehow I am not getting your

this may be the QSDK, which incorporated open-source components of OpenWrt, but is a proprietary OS to which only Qualcomm licensees have access

you mean Chos Calmer release is proprietary one to QC and in general wont be able to add any additional packages on top of it , Sorry if my understanding is wrong

Thanks for the swift response and your time and effort


The QSDK and OpenWrt are very different systems. The QSDK, as I understand it, took1 portions of originally "Barrier Breaker" (c. 2014) and later "Chaos Calmer" (c. 2015) and integrated their own kernel, drivers, and who knows what else with it. The resulting boot logs tell me that it has very little to do with how OpenWrt operates.

The ipq40xx target was not present in OpenWrt during the v15 releases. Since I do not have access to the QSDK, I can't comment meaningfully on it, but you might be able to port the OpenWrt package for syslog-ng to the QSDK build system.

[1] As OpenWrt is an open-source project, as long as they fulfilled the license terms, this is not illegal.

1 Like

Thanks a lot Jeff, Yes I intend to port syslog-ng package to QSDK, since not done such things before , thinking that use/download the same source code, build and create a package and do ./scripts/feeds install ; Hope this will work

1 Like

Hi , Subsequently we tried out integrating syslog-ng in QSDK , but we faced issues in compilation throwing following error

Loop initial declarations errors

configure: WARNING: Could not build Java modules without Java
lib/secret-storage/nondumpable-allocator.c: In function 'nondumpable_mem_zero':
lib/secret-storage/nondumpable-allocator.c:148:3: error: 'for' loop initial declarations are only allowed in C99 mode
   for (gsize i = 0; i < len; ++i)
lib/secret-storage/nondumpable-allocator.c:148:3: note: use option -std=c99 or -std=gnu99 to compile your code
lib/secret-storage/nondumpable-allocator.c: In function 'nondumpable_memcpy':
lib/secret-storage/nondumpable-allocator.c:182:3: error: 'for' loop initial declarations are only allowed in C99 mode
   for (gsize i = 0; i < len; i++)

Even in the above we tried out xcompiling of syslog-ng package with gcc options c99/gnu99, we still face error

Would like to know if any alternates to solve this issue is known , Thanks


You need to add following line to Makefile:

TARGET_CFLAGS += -std=gnu99

@Pepe , Thanks for the response , we have tried this changes too , like adding gnu99, c99 and c11 and the results pretty much remains the same in all the trials (same error); One more observation being we see this error in QSDK only and in native Linux its compiling fine , hence not sure where would have been the issue


Tried with OpenWRT(15.05), (not on QSDK) and now facing issues with libtool version mismatch

make V=s -j1 package/syslog-ng/compile

Error Log:
Making all in src
/bin/bash ../libtool  --tag=CC   --mode=compile mips-openwrt-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I..  -D_GNU_SOURCE -I../src/include -I../src/include -I/home/wlc/sat_ap/chaos_calmer-15.05.1/staging_dir/target-mips_34kc_uClibc- -I/home/wlc/sat_ap/chaos_calmer-15.05.1/staging_dir/target-mips_34kc_uClibc- -I/home/wlc/sat_ap/chaos_calmer-15.05.1/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc- -I/home/wlc/sat_ap/chaos_calmer-15.05.1/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc- -I/home/wlc/sat_ap/chaos_calmer-15.05.1/staging_dir/target-mips_34kc_uClibc- -I/home/wlc/sat_ap/chaos_calmer-15.05.1/staging_dir/target-mips_34kc_uClibc- -I/home/wlc/sat_ap/chaos_calmer-15.05.1/staging_dir/target-mips_34kc_uClibc-   -O2 -g -pthread -Os -pipe -mno-branch-likely -mips32r2 -mtune=34kc -fno-caller-saves -std=gnu99 -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result -msoft-float -mips16 -minterlink-mips16 -I/home/wlc/sat_ap/chaos_calmer-15.05.1/staging_dir/target-mips_34kc_uClibc- -I/home/wlc/sat_ap/chaos_calmer-15.05.1/staging_dir/target-mips_34kc_uClibc-  -Wno-error -c -o iv_avl.lo iv_avl.c
libtool: Version mismatch error.  This is libtool 2.4.6 Debian-2.4.6-0.1, but the
libtool: definition of this LT_INIT comes from libtool 2.4.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.6 Debian-2.4.6-0.1
libtool: and run autoconf again.
Makefile:544: recipe for target 'iv_avl.lo' failed
make[8]: *** [iv_avl.lo] Error 63
Makefile:396: recipe for target 'all-recursive' failed
make[7]: *** [all-recursive] Error 1
Makefile:326: recipe for target 'all' failed
make[6]: *** [all] Error 2
Makefile:23201: recipe for target 'lib/ivykis/src/' failed
make[5]: *** [lib/ivykis/src/] Error 2
Makefile:20980: recipe for target 'all-recursive' failed
make[4]: *** [all-recursive] Error 1
Makefile:8637: recipe for target 'all' failed
make[3]: *** [all] Error 2
make[3]: Leaving directory '/home/wlc/sat_ap/chaos_calmer-15.05.1/build_dir/target-mips_34kc_uClibc-'
Makefile:93: recipe for target '/home/wlc/sat_ap/chaos_calmer-15.05.1/build_dir/target-mips_34kc_uClibc-' failed
make[2]: *** [/home/wlc/sat_ap/chaos_calmer-15.05.1/build_dir/target-mips_34kc_uClibc-] Error 2
make[2]: Leaving directory '/home/wlc/sercomm_qsdk_build/MS3/syslog_ng_pkg/syslog_ng_log/syslog-ng'
package/Makefile:191: recipe for target 'package/feeds/syslog_ng_pkg/syslog-ng/compile' failed
make[1]: *** [package/feeds/syslog_ng_pkg/syslog-ng/compile] Error 2
make[1]: Leaving directory '/home/wlc/sat_ap/chaos_calmer-15.05.1'
/home/wlc/sat_ap/chaos_calmer-15.05.1/include/ recipe for target 'package/syslog-ng/compile' failed
make: *** [package/syslog-ng/compile] Error 2

Since we see libtool version mismatch , if there are any solutions available wish to check the same

While I'm still puzzled by why you don't want to upgrade to a current, supported release without the slew of known security issues with a five-year-old kernel and third-party firmware, building on a c. 2015 OS might resolve some of your build issues.


Thanks Jeff, I know the latest one has support for this feature (syslog-ng) , hence this ask might not be relevant with latest release, but for other business reasons cant upgrade now to the latest release (which is in road map) and now I intend to do patch on the old versions to make this feature available !

1 Like