Add support for Xiaomi AX1800 Wifi 6 router

I haven't tried creating a link between the new libraries ( and and the old libraries ( and in the same directory, but maybe that could work. I will try later and report if we can actually get real dns over tls with just Unbound.

1 Like

is it not possible to compile openwrt without the wireless driver ???

This is what I'm thinking lately. Make it as a managed switch then connect a dump AP on one of its port.

I do know technical stuffs but I'm nowhere have the skill to make this happen, but if someone wants to give it a go. I volunteer for preliminary testing.

not surprisingly, it didn't work and broke everything.

If anyone has the latest chinese firmware on the white global AX1800 AX5 RA67, can you tell me what version of the libopenssl and openssl-util packages do you have?

Thanks for all the useful comments guys, I successfully flashed to the old chinese firmware from the wiki (1.0.16) and sshed.
I've been able to partially unbloat thanks to the linked sh script, and also successfully installed adblock (although I couldn't find any logs about blocked DNS, but it seems to be correctly blocking them).

Any advice on what else I should do?
Any way to make the ssh permanent without having to edit some binary dump for example? (although I don't really mind using my exploit script when needed)
Should I then update to the latest chinese firmware? Or use the international patched image (any advantage except having an EN gui?)?
And I see many opkg packages have available updates (after changing the sources as explained in a comment), is it recommended to update some? (except the ones I needed, for example wget)

Pretty cool to be able to tweak a bit this router even if no OpenWRT support is planned :slight_smile:

You can use xqrepack to repack the latest chinese firmware or just flash the above global firmware; ssh access will be permanently enabled even after hard reset. You'll have to repack new releases, of course, and flash again if Xiaomi ever releases an update.

No, don't update any opkg packages yourself, you'll most likely break something, specially so if you update any base package.

To properly install adblock, you have to install the libustream-mbedtls package and change the fetch utility to curl. Also, run curl on the terminal (to see if curl is working properly) and make a symlink between the missing libraries, if there's any.

I did find out about adblock curl config and missing package in your previous post (although I believe you also mentioned installing libutils, but mine was apparently already updated) :slight_smile:
Before that I first tried to install adguardhome, but I couldn't configure the xiaomi gui to use it as DNS, as the default DNS port was already used and it's apparently not possible to specify a custom port in Xiaomi config.
But except for the missing logs/stats adblock is great already! (and probably lighter?)

Well I'll take a look at xqrepack next then, thanks for the advice!

Also, anybody successfully installed ovpn client and/or wireguard? There's no particular issue?
And performance isn't too bad with this weak hardware? (apparently wireguard might be lighter on the cpu and ram, I had no idea about that)

Hi! Can anyone help me please. I have configured Mesh on 4 routers with fw 3.0.34 Release with permanent SSH access on all mesh nodes (thanks to you guys) and I found the following restrictions:

  1. I cannot add mesh nodes above those 4 I have;
  2. When I activate the guest wifi, is activated and working only on main router. If the default LAN segment is on, the guest Wifi works on So, can the guest wifi be activated on the other mesh nodes as well? If so, how?
    Thanks in advance!

few days ago I bought Xiaomi Mi AX1800 router and noticed that WiFi speeds are really poor - I found this forum, went through everything and from my understanding I need to switch from Global Firmware - MiWiFi Release 3.0.34 to Chinese one in order to gain access to SSH & make WiFi better

Problem is - I've found few ROMs online (ie. 1.0.378) but while trying to flash it (via router settings page) I always get "Couldn't verify file"

Can someone help me? Maybe can someone provide me with working firmware, so I can flash it?

Or what else can I do to gain SSH access?

Which one do you have the black or white one?

I have white one

Try the ones here:

1 Like

Okay I have Router Repai Tool & ROM but I can't get into flash mode :confused:

  1. I turn off the router (disconnect power cable)
  2. I push & hold RESET button
  3. I connect power cable (still holding reset button)
  4. Orange light comes up & flashes, I release RESET button
  5. Orange light stops blinking... Idk what am I doing wrong?

Thats the process for getting into recovery mode, I found you have to launch the repair tool quite quickly after.

Have you tried flashing from the webUI and of the firmwares from the MiWIfi site?

Yes, I tried to download newest firmaware from the website above & upload .bin via router webUI - I'm always getting "Couldn't verify file" error :frowning:

Try this file, it’s for the AX5.

1 Like

This one worked - thanks!

Another problem now I cant use - Xiaomi ax3600 ssh guide to get SSH - I get an error:

edit:// okay, I rolled back to 1.0.16 version of firmware and got SSH access - thanks a lot for helping me :slight_smile:

1 Like

Hi! I'm a noob and had similar issue with missing channel 149 after setting up mesh with AX1800 Chinese firmware. Would you mind sharing your method to edit the channel with browser inspector? what browser did you use? Thanks in advance

Hi! Has anyone decoded what is being sent to the broker ( on MQTT protocol (port 1883) on "xqac" topic? A lot of bytes is sent from the router to the xiaomi cloud :(. Program responsible for research: /usr/bin/messagingagent.