Add support for Xiaomi AX1800 Wifi 6 router

This thread seems quite stale compared to AX3600. Is there any work being done to run OpenWRT on AX1800? Maybe there are some experimental branches out there?

2 Likes

I think so ! :wink:

1 Like

If so - would be great to get some links.

I am enjoying device so far - but knowing what possibilities OpenWRT would bring - really makes me restless

2 Likes

HI,

I unlocked port 22 as written.
Ax1800 is answering on a request SSH, asking for the password.
But I can't type in the password.

Bild_2020-12-07_134603

Any idea ?

Perhaps to use SSH on AX1800 I need Version 1.0.17. for configuration ?
Does anybody knows, where to find it ?

Thank's in advance.

Try this

1 Like

Hi, if you have used the full script the default password is "admin" for "root" user.

Hi guys, i received my first ax1800 last week with 1.0.336 firmware from factory. I can get SSH without problems also a friend with the same router updated to 1.0.378 too using the ax3600 SSH script, not permanent access but i only lost it if i reset to factory defalts.

Once you have SSH access you can use WinSCP with protocol SCP and port 22 to access to the full files structure of the router.

I´m going to share here all test and commands i used to optimize my router until the other units arrive to create a mesh with them.

SSH access:

Log in to your router and copy the stock code, then use it to replace "Stok" in the path of the commands above.

Change the router IP too.

http://"IP"/cgi-bin/luci/;stok="STOK"/api/misystem/set_config_iotdev?bssid=Xiaomi&user_id=longdike&ssid=-h%3Bnvram%20set%20ssh%5Fen%3D1%3B%20nvram%20commit%3B

http://"IP"/cgi-bin/luci/;stok="STOK"/api/misystem/set_config_iotdev?bssid=Xiaomi&user_id=longdike&ssid=-h%3Bsed%20-i%20's/channel=.*/channel=%5C%22debug%5C%22/g'%20/etc/init.d/dropbear%3B

http://"IP"/cgi-bin/luci/;stok="STOK"/api/misystem/set_config_iotdev?bssid=Xiaomi&user_id=longdike&ssid=-h%3B/etc/init.d/dropbear%20start%3B

http://"IP"/cgi-bin/luci/;stok="STOK"/api/misystem/set_config_iotdev?bssid=Xiaomi&user_id=longdike&ssid=-h%3B%20echo%20-e%20'admin%5Cnadmin'%20%7C%20passwd%20root%3B

Then you can access via SSH wit PuTTY to port 22, user "root" and password "admin"

By default Country Code and WIFI Code are CN (china) for both wifi bands, for 2,4Ghz the is no problem using this configuration, because all channels (1-13) are available and TX power output reachs 28dbm (630mW), but 5Ghz channels are limited to 36-40-44-48 and 149-153-157-161 with 80Mhz frecuency with 26dbm (398mW) TX power.

Commands:
"nvram get CountryCode"
"uci get wireless.wifi0.country" (5Ghz)
"uci get wireless.wifi1.country" (2.4Ghz)

If you want to get more channels you need to know what are your preferencies and limitation from your country because router is limited to 4 Country Codes but has a lot of WIFI Codes availables. If you change Country Code you need to reboot your router to clean the 5Ghz channels list in the web interface.

Availables Country Codes are EU,HK,TW,KR and CN and depending which one you select more or less channels will be availables to be selected, but not all country codes work fine with all WIFI Codes because if, as example, you only change Country Code to EU, to enabling all channels from 36 to 144, and keep CN as WIFI code, because only channels from 36 to 64 will works even channel 100 and up appears as selectables.

Commands:
"iwinfo wl0 freqlist" (5Ghz)
"iwinfo wifi0 txpowerlist"
"iwinfo wl0 txpowerlist"

"iwinfo wl1 freqlist" (2.4Ghz)
"iwinfo wifi1 txpowerlist"
"iwinfo wl1 txpowerlist"

Now, by default the Country registry is set to Global country 00: DFS-UNSET, it peform the frecuency ranges and what parameters need to aplied in every range by the Country limitations, you can find all information of all countries in google.

Command
iw reg get

global
country 00: DFS-UNSET
1-11 (2402 - 2472 @ 40), (N/A, 20), (N/A)
12-13(2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
14 (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, PASSIVE-SCAN
36-48(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
52-64(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
100-144(5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, PASSIVE-SCAN
149-165(5735 - 5835 @ 80), (N/A, 20), (N/A), PASSIVE-SCAN
(57240 - 63720 @ 2160), (N/A, 0), (N/A)

3 Likes

@Makunan

Thank you so much, have SSH access now with Version 1.0.378.

If someone can adapt OpenWRT for this device, I will donate to him :wink:

Hi all, good news, without changing Country code or Wifi Code we can use channels from 52 to 64, with max TX power, HT80 and working in mesh environment (you need apply this change to all nodes)

Open a WinSCP connection, go to etc/config/ edit wireless file, at the beginning of the text look for "wifi0" "option channel ´X´" and change it to 52, 56, 60 or 64.

Regards!!

As a test I manually updated the wireless drivers from kvalo's github branch and they seem to work fine. I only use the AX1800 as an AP so I haven't tested much.

https://github.com/kvalo/ath11k-firmware/tree/master/IPQ6018/hw1.0/testing/2.5.0.1.r1/WLAN.HK.2.5.0.1.r1-00004-QCAHKSWPL_SILICONZ-1

Did an quick iperf session with an Intel AX200 adapter:

Connecting to host 192.168.1.15, port 5201
[  5] local 192.168.1.185 port 63072 connected to 192.168.1.15 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec  94.2 MBytes   790 Mbits/sec
[  5]   1.00-2.00   sec  99.4 MBytes   831 Mbits/sec
[  5]   2.00-3.00   sec   104 MBytes   871 Mbits/sec
[  5]   3.00-4.00   sec  99.5 MBytes   837 Mbits/sec
[  5]   4.00-5.00   sec   101 MBytes   845 Mbits/sec
[  5]   5.00-6.00   sec   103 MBytes   865 Mbits/sec
[  5]   6.00-7.00   sec  97.1 MBytes   817 Mbits/sec
[  5]   7.00-8.01   sec   105 MBytes   874 Mbits/sec
[  5]   8.01-9.00   sec   104 MBytes   879 Mbits/sec
[  5]   9.00-10.00  sec   100 MBytes   841 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-10.00  sec  1007 MBytes   845 Mbits/sec                  sender
[  5]   0.00-10.09  sec  1005 MBytes   835 Mbits/sec                  receiver

At what distance did you get these measurements?

Close, about a meter away.

Measured 1.1 gbps at about the same distance with my Ax3600 so not much of a difference obviously.

1 Like

Hi guys,

I've got ssh acces on 1.0.378 and played around with /etc/config/wireless and also with
nvram set CountryCode=EU but as previously posted this breaks up app usage.
I want to respect Italy EMF limits ( 100 mW on 2,4 and 200 on 5 Ghz) but did not find a way to obtain this.
Do you know how to?
Googling i've also tried

uci set wireless.wl0.txpower=20

but command returns bad parameters error
i've checked and in /etc/config/wireless that parameter is set as char 'auto'

so didn't find a way to get this working

any idea?
ty have a nice day

Will there ever be support to flash the AX1800 with a real version of OpenWrt and not this strange crippled build that comes with the router?

Hi, if you need keep app functionalities you only can use CN for Country Code but you can try changing Wifi Code to apply country restrictions and It needs to be apply to both wifi interfaces, 5 and 2,4Ghz.

First keep CN as Country Code

nvram set CountryCode=CN
nvram commit

Second change Wifi Code for both interfaces, if IT does not match you need to use another country with similar restrictions.

uci set wireless.wifi0.country='IT'
uci commit wireless.wifi0.country

uci set wireless.wifi1.country='IT'
uci commit wireless.wifi1.country

Them check the txpower for both interfaces

iwinfo wl0 txpowerlist
Iwinfo wl1 txpowerlist

Additionaly you can change regional settings

iw reg set IT

Please give us feedback

1 Like

Hi,
thank's for your reply
i did some tests but they did not end well.
I managed to have 5ghz at 23db which if fine but 2,4 stays always at max power which is 5 times higher than what i'm allowed to do by laws.
I keepd searching around and find this reply in AX3600 thread from @pbaclawski
if the AX1800 is in the same situation i don't know if there can be a fix or workaround

Now i did a factory reset to keep back all clean and see if i'll be more lucky

If you don't need to use all funtionalities from the app you can change CountryCode, wifi Code and regio,n from reg set, together getting more limitations. But at first you can try changing only wifi Code to ES (Spain) in both wifi radios to know if the issue with 2,4 remains.

Country Code can be changed to EU, HK, KR and CN, but internally looks like US os allowed todo.

Ty for your help
changing wifi code lead to same problem; lowering power tx in web gui i reached 25dbm (316mW) for 2.4ghz but my target is 20.
Sadly seems i cannot use this router atm. at least on 2.4 Ghz