Add support for Xiaomi AX1800 Wifi 6 router

I find my router updated with version 1.0.385 on returning from vacation .. and no more root access

What can I do to find it?

Thanks for your help

After Easter I'll order a standby router (a white ax1800 this time, 'cause why not). Before that I can't risk disconnecting from the internet for days in case something goes wrong.

So my best bet is downgrading back to 1.0.378 and do the ssh exploit again. Google for miwifi_rm1800_firmware_ed621_1.0.378.bin to find an old firmware.

For permanent ssh (Gingernut's 'bdata ssh perm mod') the best source I've found so far is this, note the github link with all the scripts that cover the steps of the original chinese article. Again, don't send your S/N to anywhere, the scripts will generate telnet password too.

1 Like

I am wondering if my /etc/rc.local still exists or if it was overwritten or destroyed by this update.

I have no tools to find out.

You can downgrade to the official 1.0.378 fw and use xqrepack to generate a 1.0.385 rootfs image with ssh enabled and flash to the secondary rootfs partition.
Xqrepack will remove the xiaomi data collection software, so after flashing the rootfs partition the Miwifi app will not work.
Xqrepack is is compatible with the AX1800 firmware image, you must use the --data flag in the step

1 Like

I downloaded firmware version 1.0.378 but upon flashing from the web interface, I get a “File verification failed” error. I’m currently running version 1.0.44.
Any advice please?

Is yours an international device?

edit: Just checked and 1.0.44 is a Redmi AX5 firmware, 1.0.378 is for the Xiaomi AX1800.

@GilDev You can download firmware here :

During the re-installation of firmware 1.0.378 I unchecked the automatic update option and for now it remains in this version.

When I came back from vacation and the router had made its update automatically, I immediately had problems with the Iphone of the house : loss of wifi calls and especially battery drains.
Since the re-installation of the firmware yesterday, problems with battery have disappeared.
This may sound very strange, but it is so.

AX1800 exists today in two forms: black@tower and white@classic. They did it most probably on purpose.
So one fair question: Does the firmware under fit both?

(I don't think so. I have both devices, just opened the box of the white (standby) one. What I already see from its setup wizard is that it has an international firmware, so MUST differ from the black one. I assume as soon as I'll finish setup it will upgrade itself to the latest FW right away. I'm afraid after downgrading I'll most probably end up with one working and one bricked device...)

EDIT: google images returns the black model for "xiaomi rm1800". But I'm still not 100% sure.

Is there a serial connector on the AX1800 like the one on the AX3600, I would like to know it to avoid breaking the case for nothing.
Does anyone have started to adapt openwrt for AX1800 ?

No, you have to install it yourself.

Greetings friends.

I have a big problem and if anyone has the solution, it would save me from throwing this router in the garbage.

I live in Europe and I did change the region to EU, but the problem is that I want to use my AX1800 in repeater mode and I can't connect to my internet box in wifi 6 or even in wifi 5.

The problem is that I can create a wifi network with the European channels but I can't connect to my box in wifi 5 or 6. I can only connect in wifi 2.4 because it does not see the frequencies of wifi 5 or 6 of Europe.

Is there a solution to activate Europe also for the correction to the box internet in Wifi 5 or 6 with the frequencies Europe please?

Thanks in advance.

Again, I have set the AX1800 in EU with the guide that allows me to create wifi points in Europe frequencies, but I can not repeat the wifi with Europe frequencies except with the wifi 2.4 which is very slow in comparison.

Thank you very much for helping me.


I use my AX1800 as wifi access point but when I dig on its Ip I get an answer:

dig +short @

For me it’s a mystery. I didn’t know that the access points served as a DNS server.

When dnsmasq is running, it'll respond to dns queries

1 Like

Does anyone have a solution to my problem, please?

To resume, I tried to increase the range of my main router with a AX1800 router, the problem is that despite the change of region in EU which allows to create a HotSpot with EU channels, it was not possible to repeat an existing wifi signal that is in EU channel, ie to increase the range of my main wifi router that is in EU channel.

If someone can help me with a solution for example by changing a parameter in the files from an SSH access it's fine with me or even another solution that would save me the AX1800.

Thank you for paying attention to my problem and helping me, because otherwise my AX1800 is useless and I will just throw it away.

1 Like

Has anyone had any luck getting this to run?

There is a Mi AX1800 config available in menuconfig.

Got it built but it panics out while booting.

So is the Redmi AX5 / Xiaomi mi AX1800(white), being considered to be added for support?

I have several of the Xiaomi mi ax1800(white). Would love to run the vanilla OpenWRT on them.

BTW I have them all runing as AP's ,wonderful! I've also tried it as a router, awesome!

ipq807x (e.g. ax3600, ax6, ax9000, etc.) support is somewhat 'in sight' now (no, neither complete, nor 100% stable, let alone enduser compatible), support for ipq60xx (ax1800) is not at all on that stage, yet (but conceivable for the future, RAM sizes of those devices will be tight, though).

1 Like

thank you slh!

If you want a device that might run OpenWrt (snapshots-) by ~christmas, go with the Xiaomi ax3600.