Add support for MikroTik RB5009UG

From what I gathered - @robimarko might have a better take on this - the best way would be to replace the bootloader altogether with u-boot.

Yeah, the best solution would be to use U-boot as second-stage bootloader to boot OpenWrt.
That way, RouterBoot, and everything is preserved.

I was working some more on U-boot, it boots OpenWrt fine, but there is an issue that it appears to corrupt the NAND if it expands the rootfs_data volume.

I dont think its viable to include the aux-loader2 in the source nor the binary form in OpenWrt

2 Likes

What freezing switch?

https://downloads.openwrt.org/releases/22.03.0-rc4/targets/

Good morning all ! is there the target for the mikrotik in this page? i know it's marvel cpu

but can give her another name so good on her available on 22.03, thank you very much

Did you read the text on the wiki page linked to, 8 posts up?

Does anyone having RB5009 use Fast Ethernet (100Mbps) devices connected to the built-in switch.
I ask because I have an issue with WAN/LAN performance degradation when using Fast Ethernet devices. I consider getting this when it is available but want to make sure that I won't face the same issue.

I seem to have a problem with the image linked in the Wiki as well as my self-built image based on 22.03-rc4.

I am using the SFP+, p1 and p2 as separate ports, the br-lan switch has p3-p8 in it. I am running a DHCP client on all of the 3 separate interfaces in my test configuration. The p2 seems to work fine, but there seems to be some interference between the SFP+ and the p1 ports. When both are connected, the p1 does not get any IP address. I have to disconnect the SFP+, then the p1 gets an address, and then re-connect the SFP+ (which gets an address after it was removed when the cable was removed).

So on power on with all cables in, the p1 would not get an address and the SFP+ cable would have to be removed and re-inserted.

Can anybody also observe some interference between the p1 and SFP ports?

I'm not sure if the image has this commit included? That moves the SFP+ port from the WAN to the LAN.

Would help if you'd share your /etc/config/network.

For those rolling their own, wiki page links to an updated patch on top of master/22.03 which saw some cortexa72 crypto commits.

2 Likes

For those who dont see the download link for @Borromini patch on the wiki:

https://paste.debian.net/download/1243978

Download the patch and add .patch as an extension and then git am patchname.patch did the trick for me. Building now on top of 23.04 rc4. Fingers crossed.

(and tnx @Borromini for the behind the scenes pm assistance)

4 Likes

Hi, I am not sure this was a reply to my post or something else. In case this is related to my issue:

I can confirm I have this change implemented and here is the network config:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb4:3496:aa8d::/48'

config device
	option name 'bridge_3_8'
	option type 'bridge'
	list ports 'p3'
	list ports 'p4'
	list ports 'p5'
	list ports 'p6'
	list ports 'p7'
	list ports 'p8'

config interface 'lan'
	option device 'bridge_3_8'
	option proto 'static'
	option ipaddr '172.30.32.1'
	option netmask '255.255.255.0'
	option ip6assign '0'

config interface 'wan'
	option device 'p1'
	option proto 'dhcp'

config interface 'sfp'
	option proto 'dhcp'
	option device 'sfp'

config interface 'wan2'
	option proto 'dhcp'
	option device 'p2'
1 Like

Now that RB5009UPr_S_IN will soon to be released I was going to pull the trigger on streakwave.com since they have 1000 on order or should I get the Plain UG version over the UPr. Question is there going to much difference in hardware? and do you think someone could port openwrt on it eventually. Reason why I know a smaller school could use the RB5009UPr_S_IN to power 3-4 Ruckus R610 in at mode. Right now it's powered in af mode. Plus they can use a new router.

1 Like

And like predicted they added PoE, now just a WiFI version

1 Like

Hello everyone, I would like to obtain an OpenWrt image (the most recent if possible) for the RB5009 router! Do any of you have an image to show me? actually I do not know how to build an image :(… if you need more information I am available .. I specify that the router already has an OpenWrt version!

Scroll up a little bit.

thank you but when I scroll I see no image .. just a link on github .. as I said I don't know create an image and even less apply a patch

Hi,
If I'm not mistaken there is a precompiled image.


ulpian

1 Like

Yeah, but he's looking for a recent image :slightly_smiling_face:.

@segal_72 I put up a newer image here but this is a one-off. I warmly recommend you familiarise yourself with the buildroot and learn how to build an image yourself. Patches and config have been shared.

Build is from 22.03 HEAD.

2 Likes

Ok thank you .. what kernel has this image?

this image allows me to install the current package?
yes I would like to learn how to build.. where to start and how?
is there a guide that could allow me to familiarize myself and create my image?
Thanks again for your reply, I really appreciate it!

hi the kernel image has a 5.10.136

1 Like