Add support for MikroTik RB5009UG

Have you tried jailback? Doesn't it work too?
In general, the latest aux-loader does not depend on the RouterBOOT version for ELF boot.

Yes, right.

1 Like

I haven't tried the jailbreak yet with the DHCP boot protocol activated, no. Will give that a shot later.

Thanks for confirming the range.

Yes you will do change to dhcp

ok i has well done flash but i can't install luci ,
is normal ??
Capture d’écran 2022-02-15 à 19.59.49

the list of update is small compared tu used

how do I go about utilizing aux loader if I can't boot the elf file?

If using @adron's images they come with luci pre-installed.

1 Like

Capture d’écran 2022-02-15 à 20.15.49

i' don't have the full packages is normal ?

Sorry @sumo but not luci for the moment :frowning:

I tested with both BOOTP and DHCP protocols again, it doesn't work. BOOTP will serve the jailbreak file, but then dnsmasq goes silent and when I switch to a LAN port (so port 2 or port 8 e.g.) then I won't be able to obtain an IP. Setting a static one (192.168.88.x or 192.168.1.x) doesn't help either. With DHCP the RB5009UG will just boot through ignoring the file offered by dnsmasq.

Probably something on my end, since it is working for other people. Will see about writing to the flash directly later.

@Dopam-IT_1987 Could you explain how you got it to work? I'm under the impression you did not use dnsmasq?

1 Like

yes i have done the first party with tinypxe but i don't have luci again

i has only 4 opkg list ...

At least @adron's previous version really had luci built-in:

BusyBox v1.35.0 (2022-01-16 21:13:46 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt SNAPSHOT, r18606+6-87d489f67a
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
root@OpenWrt:/# opkg list-installed | grep luci
liblucihttp-lua - 2021-06-11-3dc89af4-1
liblucihttp0 - 2021-06-11-3dc89af4-1
luci - git-22.038.79726-2ab828f
luci-app-firewall - git-22.038.79726-2ab828f
luci-app-opkg - git-22.038.79726-2ab828f
luci-base - git-22.038.79726-2ab828f
luci-lib-base - git-22.038.79726-2ab828f
luci-lib-ip - git-22.038.79726-2ab828f
luci-lib-jsonc - git-22.038.79726-2ab828f
luci-lib-nixio - git-22.038.79726-2ab828f
luci-mod-admin-full - git-22.038.79726-2ab828f
luci-mod-network - git-22.038.79726-2ab828f
luci-mod-status - git-22.038.79726-2ab828f
luci-mod-system - git-22.038.79726-2ab828f
luci-proto-ipv6 - git-22.038.79726-2ab828f
luci-proto-ppp - git-22.038.79726-2ab828f
luci-theme-bootstrap - git-22.038.79726-2ab828f
rpcd-mod-luci - 20210614
1 Like

@Dopam-IT_1987 You can edit /etc/opkg/distfeeds.conf to add the LuCI entry, similar to the other ones you already have, then update and install.

1 Like

ok i will test thanks

src/gz openwrt_core
src/gz openwrt_base

i'm very happy now :wink: thanks everybody for all

is possible to test qosify on this router ??

Not i'm not ise dnsmasq i use tiny pxe with reset hold 10 sec :+1::slightly_smiling_face:

You should be test with this software if you want

Sorry for that, when I did the build I forgot to connect the feeds - I already fixed it and re-uploaded the images - please check. htop and mtr is also included now.

robimarko had a similar problem at the very beginning with his rb4011 as TFTP server. Its replacement with RB450Gx4 helped. Most likely this is just the incompatibility of the RB5009 port1 with some other ethernet ports.


ok thanks is good now :+1::slightly_smiling_face:

can you include for test qosify please

Capture d’écran 2022-02-16 à 08.51.05

Sorry, but this package has a lot of dependencies and is not going to be built that easily. And I don't have time to deal with it in detail.


I happen to have two RB5009UGs, so I will see if i can get that going. That way at least one of them can get flashed :smile:.

@Dopam-IT_1987 Might be better if you familiarise yourself with building your own images. I can provide you with a patch for @adron's RB5009UG tree that you can apply on top of current master if you'd like. It might take a while for support to get merged and until then you'll need to get by.

1 Like

with pleasure it's really very nice I have a macbook but I have parallel desktop with ubuntu I am new to firmware construction on the other hand

when you say a certain time is how much about 1 month or 2 before openwrt 22 is right

Going on what robimarko said I wouldn't expect support before OpenWrt switches to 5.15, so I wouldn't get my hopes up for 22.xx. That will use kernel 5.10. And between branching and a stable release will be quite a few months as well.

Once 22.xx gets branched though you might very well be able to apply adron's patches on top of it and build a stable version like that.

1 Like

Ok i understand i you send mp about build :+1::slightly_smiling_face:

I got it working with the new elf image

sudo ip addr add dev eth0
sudo dnsmasq --bind-interfaces -i eth0 -a --dhcp-range=,  --dhcp-authoritative --dhcp-boot=openwrt-mvebu-cortexa72-mikrotik_rb5009-initramfs-fit-uImage.elf --enable-tftp --tftp-root=/srv/tftpboot/ -d -u nobody -p0 -K --log-dhcp --bootp-dynamic

Then this time around it got past the sending image, i was able to get a link light on port2 of the router, and I switched my desktop's eth0 to be a dhcp client instead of a dhcp server and was able to ssh to

EDIT: also fwiw since the files don't have clear versions, this is the file that worked

$ sha256sum openwrt-mvebu-cortexa72-mikrotik_rb5009-initramfs-fit-uImage.elf                                                                                                                                                                                              
4c4eefea7d5031e23cabaeef61c22b77a255ce64165658bf3c062988b247a09a  openwrt-mvebu-cortexa72-mikrotik_rb5009-initramfs-fit-uImage.elf

1 Like