Add support for MikroTik RB5009UG

@Borromini
I've asked about the kernel version because actually I've never been able to run 6.6 properly on this device - installed nor initram.
I have this issue on it.
I even bought an USB LAN adapter for my Laptop just to be able to test on it as a router but I simply get general failure/unidentified network with kernel 6.6.
Booting from Robimarko's initram image gave the same result for me - a PC never gets an IP address. Manually assigning one doesn't help either. Unfortunately I don't have a serial connection on it.
I still have a build with kernel 6.1 that runs OK and can boot from initram too.
So my question is, can I run all commands from my initram 6.1 image?

@robimarko
I've made a second try. This time the device booted from your initramfs image.
Here is what I've done.
First i got this error.

root@OpenWrt:~# yafut -d /dev/mtd0 -w -i /tmp/u-boot.elf -o kernel -T
file_driver_yaffs.c:87: file_yaffs_open_for_writing: unable to open 'kernel' for writing: error -28 (No space left on device)

Then I tried second time and it went without any output.

root@OpenWrt:~# yafut -d /dev/mtd0 -w -i /tmp/u-boot.elf -o kernel -T
root@OpenWrt:~#
root@OpenWrt:~# ubiformat /dev/mtd1 -y
ubiformat: error!: please, first detach mtd1 (/dev/mtd1) from ubi0
root@OpenWrt:~# ubidetach -p /dev/mtd1
root@OpenWrt:~# ubiformat /dev/mtd1 -y
ubiformat: mtd1 (nand), size 1065353216 bytes (1016.0 MiB), 8128 eraseblocks of 131072 bytes (128.0 KiB), min. I/O size 2048 bytes
libscan: scanning eraseblock 8127 -- 100 % complete
ubiformat: 8120 eraseblocks have valid erase counter, mean value is 0
ubiformat: 8 bad eraseblocks found, numbers: 8120, 8121, 8122, 8123, 8124, 8125, 8126, 8127
ubiformat: formatting eraseblock 8127 -- 100 % complete

root@OpenWrt:~# cat /sys/firmware/mikrotik/soft_config/boot_device
eth flasheth ethonce flash [cfg] cfgonce

root@OpenWrt:~# sysupgrade -n /tmp/sysupgrade.bin
Tue Dec 20 04:26:40 UTC 2095 upgrade: Commencing upgrade. Closing all shell sessions.

After this it looks like the device is in a bootloop.
The system LED doesn't blink with the normal boot frequency patterns.

1 Like