Add support for Linksys EA6350 v3


#144

Hi
im getting the following error when trying to build from source.
im using a fully upto date Ubuntu 18.10 install.
Im building as a normal user

patch: **** malformed patch at line 36:  ;qcom-msm8960-cdp.dtb \

Patch failed! ;Please fix /home/imran/Downloads/chunkeey-12f0eb9/target/linux/ipq40xx/patches-4.14/901-arm-boot-add-dts-files.patch!

I get the same error with full chunkeey HEAD tree as well as the snapshop just for the ipq40xx changes.

Im not a developer or know how to code, but more than willing to test builds and provide usage feedback


#145

yes, there was a leftover patch that I kept around to see the changes I did. I deleted it now, but you'll need to rebase if you want to get rid of it. Though, I would recommend that you just use https://git.openwrt.org/openwrt/openwrt.git , git://git.openwrt.org/openwrt/openwrt.git , https://github.com/openwrt/openwrt.git over mine since it's bound to be in a state of constant breakage ;).

You can also just download the snapshot images from the ipq40xx target over at:
http://downloads.openwrt.org/snapshots/targets/ipq40xx/generic/

linksys_ea6350v3-squashfs-factory.bin

(Be aware, they do not include LuCI Webinterface, just ssh at 192.168.1.1 over the LAN ports and the kernel module (kmod-) packages will only stay around for a limited time.)


#146

Thank you for the quick reply,
I've successfully built a image using the link you provided above, with luci, usb mount, samba4, dnla, and adblock.
Ive just flashed it, and so far the 5gz wifi seems a lot more stable than escalion image.
I done a sysupgrade and it has kept all settings from the previous escalion image, including samba, adblock and dnla server settings.

I will do further testing over the next few days, and come back with any findings on this thread. ( if this is the correct place?)


#147

Great to see that the PR has been merged!
I can also confirm that 5GHz is working fine now using the standard repo build.
Really good work, thanks!


#148

I now switched to firmware snapshot r9253-3da230a and started to use my EA6350 router as gateway at home, running it towards a 100Mbps WAN connection with an LTE backup route through the USB port (MWAN3). Sadly I can still see issues with the 5GHz Wifi. But everything else works perfectly.
Sometimes 5GHz seems to work fine, the next time it claims that the stored WPA2 password is incorrect and sometimes it's not even visible from the client end.


#149

Have you tried the latest firmware?

Announcement: http://lists.infradead.org/pipermail/openwrt-devel/2019-February/015693.html

Download: https://www.candelatech.com/downloads/ath10k-4019-10-4b/

If it's still a problem? Then report it to https://github.com/greearb/ath10k-ct/issues , https://www.candelatech.com/ath10k-bugs.php


#150

No, I'm using an openwrt snapshot build from February 1 and it looks like this new firmware was released February 2. In the current openwrt source as of today I can see that version .002 is still used.
I'll see if I can update it myself or wait for someone to update it in openwrt.
Anyway, a big thanks for the information @chunkeey !


#151

I'm having the same problem. But the problem is also present in the stock firmware and happens only with my iPhone. I have no more iPhones to test but my Macbook connects well.

Lately, however, I've seen a worst 2.4 GHz quality as it drops many packages. This does not happen in 5.0 GHz nor from Ethernet.

Are you experiencing this problem (wrong password) with an iPhone?


#152

Now that you mention it I think I have only seen the "Incorrect password" ones on iPhone.
But the other 5GHz connection issues I have noticed on both iPhone and Macbook: Unable to connect, connected but no traffic goes through, network not visible.


#153

Hello,

I'm the maintainer for the luci-app-advanced-reboot and with the tremendous help of @imi2003 and very helpful information from @hnyman I've added support for EA6350v3 to the package.

Before I send a pull request and the new code goes live at official OpenWrt repo, could you please test the version 37 of luci-app-advanced-reboot currently available at my repo: https://stangri.github.io/openwrt-repo/

I welcome feedback before I send PR.


#154

Hi all,
I've just noticed this device's board name is not consistent with other supported linksys routers, I propose the board name should be renamed to "civic" instead of "ea6350v3"

WRT1200AC - caiman
WRT1900AC v1 - mamba
WRT1900AC v2 - cobra
etc...

What do you guys think?


#155

Good evening , thanks to the members who participated in this project , i'm confused , i want to flash a ready firmware with luci and all the stuff needed luci, usb mount, samba4, dnla, and adblock...and more if its possible (i want all the options of official firmware too)
the reason that i want to change the original firmware is OPENVPN, ill be grateful if anyone can show me how to flash the firmware which source should i use the firmware of @NoTengoBattery https://github.com/NoTengoBattery/openwrt/releases
or the link provided by @chunkeey , and how to add the required package specially OPENVPN
thanks in advance


#156

Since the pull request has been merged, the easiest is just to install the latest snapshot release as suggested by @chunkeey in a previous post: firmware

It will not install LuCI but it's just a few commands away:

opkg update
opkg install luci-ssl-nginx

I have not used OpenVPN on this platform myself but there seems to be good information on the openwrt webpage


#157

Yes, this is pretty much the situation for now. You can also check out @NoTengoBattery releases. From what I saw he included the the LuCI webui. As for the future: Once the upcoming OpenWrt 19.0x release hits the street there will be a official image with LuCI too.


#159

thanks guys for the reply , i have a question ,how can i install frimware from @NoTengoBattery github after i downloaded ea6350v3-2019_01_22.tar.bz2 file, also inside the file i can see a lot of files i know i should flash openwrt-ipq40xx-linksys_ea6350v3-squashfs-factory.bin but is this firmware contain all the addons in the folder package provided in the same bz2 File ?


#161

As @elitedz is interested in a full distro, I just uploaded a prebuilt to GitHub which is a full distro (not actually a full distro but you understand).
It have a sensible selection of software which will cover most users out of the box. I will keep uploading prebuilts once in a week.
Please take your time to understand the release notes on GitHub.

Note this: I'm not legally allowed to "release" OpenWrt software. I use that word just because GitHub uses it. These are not release, just prebuilts.

Note this: those are prebuilts from developer previews. The software is not production ready, not this prebuilt nor the official prebuilts from OpenWrt. The prebuilt is provided for mere convenience only.


#162

@NoTengoBattery

https://patchwork.kernel.org/patch/10782507/

See, it was a slam dunk. :wink:


#163

hi everyone , if anyone know how to revert back to original firmware , im trying wihtout succes ,even forcing the upgrade , i think @No TengoBattery changed the internal system erasign the schema of the original firmware ,i'm not an expert , but because of the wifi issue 5ghz and 2.4ghz cannot exceed 54mbps i want to revert back to original firmware , please help me


#164

@elitedz don't blame on me: I've changed anything. If you flash a custom firmware twice, you will lost access to the original firmware and you need to manually reflash it. No, forcing a sysupgrade with the original firmware will soft-brick the router and will force the device to revert back to the latest working firmware.

As for the 5.0GHz WiFi, in fact, it's a problem not isolated to my build. In fact @anders reported this 5 days ago. I didn't bothered because I was getting a 500 Mbps in the 5.0GHz band, but now it barely rises to 27Mbps.

I think that we really, really, really need volunteers to test most if not all of the calibration board files from the original firmware. Also, this may o may not be related to what @chunkeey said about a new firmware. Maybe it would be wise to test firmware built before Feb 02 and after Feb 02.

And yes, I can see a clearly performance degradation in the 5.0 GHz WiFi as I used it for Time Machine backups with stunning speed. Now it barely loads YouTube videos al 360p.


#165

@chunkeey I have several questions if the calibration board is the problem:

  1. Do I need to send the new "good" files to infradead again?
  2. Do I need to amend the files sent or can I just pick another ID?
  3. Shall I sent another set of patches to Upstream to change the calibration board files?

(This if enough people help and the calibration board fixes the problem, I'm not saying that this is the problem but just in case)